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QUICK REFERENCE for Experienced Administrators
1. FLEXlm SETUP
NI AWR Design EnvironmentTM (NI AWRDE) conforms to standard FlexLMTM guidelines. The vendor daemon name
is awrd for the NI AWR. NI AWR requires version 11.14 or later of lmgrd and awrd.
The NI AWRDE client software uses the AWRD_LICENSE_FILE environment variable to find the server. The client
queries the server to determine what features are available, and presents those features so you can select the desired
configuration.
NI AWRDE versions after AWRDE 2006 use the “awrd” vendor daemon. If you need to support versions earlier than
AWRDE 2006 contact AWR Support to request the “awr” vendor daemon.

2. USER DIRECTORY CONFIGURATION
The NI AWRDE writes data to several locations. In an environment where users have limited rights, you can configure
the directories the software uses. See “Configuring Program File Locations” for more information.

3. COMMAND LINE INSTALLATION
See “Command Line Installation” for options for installing the NI AWRDE .msi from the command line.

4. NETWORK INSTALLATION
If you are installing the software on a network drive and users will run the software from that location, each user machine
still requires some setup to operate correctly. See “Administrative (Network) Installation”.
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Chapter 1. Introduction
1.1. NI AWRDE and Analyst Installation and Licensing
The NI AWR Design EnvironmentTM (NI AWRDE) employs the FLEXlmTM licensing scheme. FLEXlm can be used in
either locked or floating configurations. Locked licensing dedicates a license to a particular machine. Floating licensing
allows multiple users to share a license over a network via a client-server architecture that grants or denies licenses based
on availability. With floating licensing, the license is assigned to a machine defined as the license server, and each client
workstation running the NI AWRDE (Microwave Office (MWO)/Visual System SimulatorTM (VSS)/Analog Office
(AO)) requests licenses from the server as needed.
FLEXlm user license keys are stored in a license file. The license key can be calculated from the Ethernet address of the
computer's network card, disk volume serial number, or from the serial number of an NI AWR-supplied hardware dongle
attached to the machine's parallel or USB port.
You can purchase a license with full functionality (for example, in the NI AWRDE: linear simulator, nonlinear simulator,
EM simulator(s), HSPICE, layout tool, and Visual System Simulator), or with one or more limited features. The license
keys in the license file activate only the purchased features.

1.2. About This Guide
This guide describes how to install the NI AWRDE and AnalystTM. It also provides complete details for configuring and
troubleshooting your site for FLEXlm licensing in both locked and floating configurations, using either software- or
hardware-based keys. Chapters 2 and 3 cover basic NI AWRDE and Analyst program installations, chapter 4 details
FLEXlm configuration, and chapter 5 discusses FLEXlm troubleshooting issues. Appendix A provides information on
the installation and Addin programs.
The latest version of this book (install.pdf ) is available at Install.pdf. Comments and suggestions regarding this book
are welcome and should be e-mailed to awr.install@ni.com.
This book assumes that you have an intermediate level of knowledge as a PC user or administrator.

1.2.1. Typographical Conventions
This document uses the following typographical conventions.
Item

Convention

Anything that you select (or click on)
in the Microwave Office or Analog
Office design environment, such as
menus, submenus, menu items, dialog
box options, button names, and tab
names

Shown in a bold alternate type. Nested menu selections are shown with a ">" to
indicate that you select the first menu item and then select the second menu item
from the menu:
Choose File > New Project.

Text that you enter using the keyboard Shown in bold type within quotes:
Enter "my_project" in Project Name
Keys or key combinations that you
press

Shown in a bold alternate type with initial capitals. Key combinations using a
"+" indicate that you press and hold the first key while pressing the second key:
Press Alt+F1.
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Item

Convention

Filenames and directory paths

Shown in italics:
See the DEFAULTS.LPF file.

Contents of a file, fields within a file, Shown in an alternate type:
command names, output from a
Define this parameter in the $DEFAULT_VALUES field.
command at the command prompt
Optional arguments in a command

Shown in square brackets:
The command line format is: dir [/w]

Variables for which you must specify Shown in angle brackets:
values
To run the program from a network server, enter: msiexec /a
AWR_Design_Environment_<version_build>.msi
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Chapter 2. Installing the NI AWR Design Environment
This chapter describes how to install the NI AWR Design EnvironmentTM (NI AWRDE) which includes Microwave
Office (MWO), Visual System SimulatorTM (VSS), and Analog Office (AO). A procedure for performing command line
installations is also included.
The installation procedures are intended for evaluators and licensed users who wish to install MWO, VSS, and AO with
a FLEXlm license dedicated to their particular machine. For licensing configurations, see “Configuring FLEXlm”.

2.1. Installation Overview
You can download and install the NI AWRDE from the NI AWR website (www.ni.com/awr) or request a CD for
installation. You can access vendor libraries from within the NI AWRDE via the Element Browser, and on the NI AWR
website.
The AnalystTM 3D EM simulator is a separate download and installation process. See “Installing Analyst” for information
about installing Analyst if you plan to use this simulator.
After installing the software you need to configure your FLEXlm licensing before using the software. For FLEXlm
licensing information see “Configuring FLEXlm”.

2.1.1. Licensing and Available Features
You may have purchased a complete MWO/VSS/AO license with full functionality (for example: linear simulator,
nonlinear simulator, EM simulator, and layout tool), or you may have purchased a license for one or more features. In
either case, the complete application is installed and your license determines the specific MWO and/or VSS and/or AO
functions that are available to you. The default program installation directory for 64-bit operating systems is C:\Program
Files (x86)\AWR\AWRDE\[version_number].

2.2. Preparing for Installation
Before you start the installation:
1. Ensure that the PC on which you want to install the NI AWRDE software meets the following minimum requirements
(recommended requirements are shown in parentheses):
• Hardware: Core 2 CPU (latest multi-core processor), 2GB (4GB) RAM, 1.5 GB (10 GB) available disk space.
• Software: Microsoft® Windows® 7, Windows 8, or Windows 10 64-bit operating systems
For the latest recommended hardware requirements see the NI AWR website: Minimum Requirements. NI AWR
recommendations are based upon tests performed using Intel processors.
2. When installing an upgrade to the NI AWRDE, retain your existing version until you verify that your projects work
successfully in the new version. (To uninstall the NI AWRDE suite, choose Programs and Features from the Windows
Control Panel, select the program and follow the instructions.)
3. Ensure that you have Administrative rights on the PC. The NI AWRDE and FLEXlm licensing software both
require Administrator privileges for installation and configuration.
4. (Optional) Disable your spyware and/or virus checking programs if interference is probable. Re-enable these programs
after installation.
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5. The NI AWRDE does not support unicode languages. For proper operation of the software, you need to make sure
you have set your operating system to use English for the language for non-unicode programs. If you are unsure how
to check this, see our Knowledge Base at: www.awrcorp.com/support/help.aspx?id=9

2.3. Installing the Software
To install the NI AWRDE suite:
1. If you downloaded the software from www.ni.com/awr, browse to the download folder and run
AWR_Design_Environment_<version_number>.msi to display the NI AWRDE Setup Wizard screen. If you downloaded
the AWRDE_Analyst_<version_number>.exe file to install the NI AWRDE with the Analyst 3D EM simulator, run
this file to start the installation and see “NI AWRDE Analyst Installation Program” for details about using the
bootstrapper. First, the NI AWRDE is installed, then the Analyst Setup Wizard screen displays, and finally, the Intel®
MPI Library is installed if needed.
If you have the program CD, place it into the CD drive and run the appropriate installation file.
2. After accepting a license agreement, you proceed with the installation and are prompted to specify the following:
Option

Description

Select the installation folder

Browse to the directory in which you want to install the NI AWRDE. DO
NOT INSTALL THE SOFTWARE IN THE SAME DIRECTORY AS A
PREVIOUS INSTALLATION.

Set the default Units value

Choose the default units to use in schematics and layouts (and affect the default
sizes for components such as transmission lines). The default is Microns. You
can alternatively set this default within the program; see the User Guide for
details.

Choose the file extensions to open
with the NI AWRDE

Specify the file type(s) you want to open with the NI AWRDE by selecting
the option(s) for the associated file extension.

Your installation progress is shown.
3. When installation is complete click Close to close the screen.

2.3.1. Setting Up a Group Policy
The NI AWRDE installer uses Windows Installer technology, which allows installations to be managed through a Group
Policy. By setting up a Group Policy, you can automate the installation of the software for specific users or computers
within a domain. For more information on how to configure Group Policies, see Microsoft's Support Website.

2.4. Configuring Program File Locations
By default, the NI AWRDE looks for files and folders in specific directories. You can change these default directories
to accommodate roaming users.
To view the location of the directories and files that the NI AWRDE uses, choose Help > Show Files/Directories to display
the Directories dialog box.
The NI AWRDE uses three primary base locations:
• application - the NI AWRDE installation directory
• appdatacommon - items common to all user accounts
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• appdatauser - items specific to a single user
The installation directory is user-specified during program installation. The location of the appdatacommon and
appdatauser directories is determined by calling the Windows SHGetFolderPath API. An administrator can set the
physical location of these directories. The default locations on Windows machines are:
application:
C:\Program Files (x86)\AWR\AWRDE\[version_number]
appdatacommon:
C:\ProgramData\AWR\Design Environment\[version_number]
appdatauser:
C:\Users\[username]\AppData\Local\AWR\Design Environment\[version_number]
A fourth virtual location, appdata, is set to either appdatacommon or appdatauser depending on a configuration setting.
All other subdirectories, with the exception of projects are under one of the three primary directories.

2.4.1. Searching mwoffice.ini
A search is performed for the mwoffice.ini file in the following locations:
1. the appdatauser version specific directory
2. the appdatacommon version generic directory
3. the application directory
4. If not found, this file is created in the appdatacommon directory.
The first location in which the file is found is the location that is used.

2.4.2. Searching user.ini
A search is performed for the user.ini file in the following locations:
1. the appdatauser version specific directory
2. the appdatacommon version generic directory
3. the application directory
4. If not found, this file is created in the appdatauser directory.
The first location in which the file is found is the location that is used.

2.4.3. Customizing File Locations
You can customize the default AWRDE directories by creating a file named REDIRECT.INI in the Documents folder
for a single user, or in the application directory for multiple user configurations. The default location for the Documents
folder for Windows is C:\Users\[user]\Documents.
This file has a section that allows you to configure how the NI AWRDE behaves, and a section that tells the software to
change the default primary directory locations.
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You can change the behavior of the NI AWRDE by specifying one or more of the following flags under the [Design
Environment] section. For example:
[Design Environment]
CommonDirectory=D:\All Users\AWRDE\Data

2.4.4. Overriding appdatacommon and appdatauser Locations
By default, the NI AWRDE gets the locations of the appdatacommon and appdatauser default locations from the system.
As noted in “Configuring Program File Locations”, an administrator can change the location of these directories. Doing
so, however, causes a system-wide change and affects all programs. There are circumstances when you may want to
change the location for only the NI AWRDE. You can do so by adding entries to the REDIRECT.INI file to override the
appdatacommon and appdatauser directories as follows:
[Design Environment]
CommonDirectory=D:\All Users\AWRDE\Data
UserDirectory=D:\[username]\AWRDE\Data

A convenient way to place all of your NI AWRDE data under a common directory is to specify the AppDataDirectory
instead of the CommonDirectory and UserDirectory individually. When you use the AppDataDirectory key, the NI
AWRDE automatically appends to the specified path "All Users" for the appdatacommon directory, and the user name
to the appdatauser directory.
For example, specifying:
[Design Environment]
AppDataDirectory=C:\Data\AWRDE

results in:
appdatacommon:
C:\Data\AWRDE\All Users
appdatauser:
C:\Data\AWRDE\[username]
You can also redirect directories based on the machine name, the user account name, or both. This is useful in a group
setting when the NI AWRDE is run from a network location or from multiple machines.
For instance, you have two machines with the NI AWRDE installed, one in your office and one in a meeting room. The
machine in the meeting room is shared by multiple users, however, when you use it, you want it to use the customizations
and cache files from your desktop machine. You can do this by adding a username category to the REDIRECT.INI file
on the meeting room machine, and redirecting the appdatacommon and appdatauser directories to your desktop machine
as follows.
[yourusername]
CommonDirectory=\\YOURMACHINENAME\AWRDE\CommonData
UserDirectory=\\YOURMACHINENAME\AWRDE\username
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NOTE: You need to log on to the meeting room machine using your own account.
When looking for path overrides, the NI AWRDE searches categories in this order:
[machine_username]
[username]
[machine]
[Design Environment]
If both the CommonDirectory and AppDataDirectory are found in a given category, the path specified for
CommonDirectory is used. If both UserDirectory and AppDataDirectory are found in a given category, the path specified
by UserDirectory is used. The first successful override that it finds is used.

2.5. Running the Software
NOTE: Before using the software you need to configure your FLEXlm licensing. For FLEXlm licensing information,
see “Configuring FLEXlm” .
To run the NI AWRDE, from the Windows Start menu, choose All Programs > AWRDE [version_number] > AWR Design
Environment [version_number].
If an error occurs while running the NI AWRDE, check “Solutions to FLEXlm-Related Problems ” to see if it is listed.
If not, contact NI AWR Technical Support by e-mail at awr.support@ni.com or by phone at the number listed on
the inside title page of this book.

2.5.1. Specifying License Features
To specify with which license features you want to run, start the program and in the Select License Features dialog box
choose the primary and optional features (licenses) available to you. You can access this dialog box within the program
by choosing File > License > Feature Setup. After selecting the desired features, you can specify to always run with them
or to be prompted for feature selection upon program startup, and to create a desktop icon for your selection.

2.5.2. Specifying a Foundry Library
To load a foundry library for use with a new project, start the program and choose File > New with Library. If installed, a
list of foundry libraries displays, or you can browse to locate a foundry configuration (.ini) file. The name of the foundry
library is saved in your project file. Whenever you reopen the project, the associated foundry library is automatically
loaded.
Many of the Analog Office (AO) standard examples and Getting Started projects use the AWR Generic Library, called
the GenBic35 process. This library is available in the $AWR/Library/example_pdks/genbic35/ folder. If you choose File
> New with Library and then browse to the Generic_GenBic35.ini file in this directory, the software remembers the location
of this library.

2.5.3. Accessing User Resources
The Getting Started Guide (gettingstarted.pdf on the NI AWR website or NI AWRDE CD) is included with the software
to help explore the suite and learn how to perform tasks. For easy access to this guide choose Help > Getting Started. A
concise, comprehensive Quick Reference resource is also available by choosing Help > Quick Reference.
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2.6. Command Line Installation
The NI AWRDE is distributed as a Windows Installer (MSI) file on Windows. In addition to a typical installation where
the installation file is launched by double-clicking in the Windows Explorer, and removed using the Control Panel Add
or Remove Programs or Programs and Features option, a msiexec.exe command line utility offers additional features such
as command line installation.
For current command usage you can type msiexec /? in a command prompt window.
To initiate a command line installation anagrammatically, type the following from a command line:
msiexec /i AWR_Design_Environment_<version>.msi
The following additional parameters can be passed at the end of this command line.

2.6.1. Limiting User Interface Display
The amount of user interface displayed is controlled by the following /q options:
/qn to indicate no interface
/qb to indicate use of a basic interface using only a small progress dialog box

2.6.2. Specifying a Target Directory
TARGETDIR determines the root/installation directory of the software, for example:
TARGETDIR="C:\AWRDE [version_number]>"
The default TARGETDIR is [ProgramFilesFolder]\AWR\AWRDE\[version_number].

2.6.3. Removing Previous Installations During Install
REMOVEOLDVERSION=YES uninstalls previous installations of the software during install. Only installations of the
same major version number are uninstalled.
msiexec /i AWR_Design_Environment_<version>.msi REMOVEOLDVERSION=YES
The default is REMOVEOLDVERSION=NO.

2.6.4. Uninstalling the Current Version
msiexec /x AWR_Design_Environment_<version>.msi
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Chapter 3. Installing Analyst
This chapter describes how to install the AnalystTM 3D Electromagnetic EM simulator.

3.1. Installation Overview
The Analyst simulator is not included in the main NI AWR Design EnvironmentTM (NI AWRDE) installation, you must
use a separate installer. You can download and install Analyst from the NI AWR website (www.ni.com/awr) or request
a CD for installation.

3.1.1. Licensing and Available Features
You may have purchased one of several Analyst licenses with different features. The complete application is installed
and your license determines the Analyst features that are available to you. The default program installation directory is
C:\Program Files\AWR\Analyst\[version_number].

3.2. Preparing for Installation
Before you start the installation:
1. Ensure that the PC on which you want to install the Analyst software meets the following minimum requirements
(recommended requirements are shown in parentheses):
• Hardware: Core 2 (best in market multi-core, 64-bit processor), 2GB (as much as possible) RAM
• Software: Microsoft® Windows® 7, Windows 8, or Windows 10 64-bit operating systems
2. When installing an upgrade to Analyst, retain your existing version until you verify that your projects work successfully
in the new version. (To uninstall Analyst, choose Programs and Features from the Windows Control Panel, select
Analyst and follow the instructions.)
3. Ensure that you have Administrative rights on the PC. Analyst requires Administrator privileges for installation
and configuration.
4. (Optional) Disable your spyware and/or virus checking programs if interference is probable. Re-enable these programs
after installation.

3.3. Installing the Software
To install Analyst:
1. Analyst comes in a bootstrapper which installs the NI AWRDE and Analyst. If you downloaded the software from
www.ni.com/awr, browse to the download folder and run AWRDE_Analyst_<version_number>.exe to start the
installation. See “NI AWRDE Analyst Installation Program” for details about using the bootstrapper. First, the NI
AWRDE is installed if needed, then the Analyst Setup Wizard screen displays, and finally, the Intel® MPI Library
is installed if needed.
2. After accepting a license agreement, you proceed with the installation and are prompted to specify the following:
Option

Description

Select Installation Folder

Browse to the directory in which you want to install Analyst. DO NOT
INSTALL ANALYST IN THE SAME DIRECTORY AS A PREVIOUS
INSTALLATION.
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Your installation progress is shown.
3. When the Analyst installation is complete click Close to close the screen.

3.4. Running the Software
Analyst is run from within the NI AWRDE, see “Running the Software” for details.
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Chapter 4. Configuring FLEXlm
This chapter describes how to configure your site for FLEXlm licensing.
FLEXlm can be configured in a locked or floating licensing environment using either software- or hardware-based keys.
For instructions on configuring your machine for locked licensing using either type of key, see “Configuring Locked
Licensing” . For instructions on configuring your site for floating licensing, see “Configuring Floating Licensing”.
If you cannot successfully configure FLEXlm, see “Troubleshooting FLEXlm” for troubleshooting information.
NOTE: FLEXlm licensing software requires Administrator privileges for installation and configuration.

4.1. Configuring Locked Licensing
FLEXlm locked licensing can use either a software-based or hardware-based key. For instructions on configuring FLEXlm
using a software-based key, see “Configuring Locked Licensing with a Software-Based Key”. For instructions on
configuring FLEXlm with a hardware-based key, see “Configuring Locked Licensing with a Hardware-Based Key”.
These instructions assume that the NI AWRDE is installed on your machine. For installation instructions, see “Installing
the NI AWR Design Environment”.

4.1.1. Configuring Locked Licensing with a Software-Based Key
The following steps configure your machine for FLEXlm locked licensing with a software-based key. In this configuration,
the NI AWRDE is installed on and licensed to your particular machine.
1. From the Windows® Start menu, choose All Programs > AWRDE [version_number] > AWR Design Environment
[version_number].
Alternatively, double-click My Computer on your desktop, open the folder where you installed the program and
double-click MWOffice.exe to display the AWR License Configuration dialog box.
After your initial license file configuration you can access this dialog box by choosing File > License > Configuration
while in the NI AWRDE.
2. To obtain a valid license file from AWR Corporation, click License Info and follow the instructions. NOTE: Evaluators
must complete the registration process to obtain an evaluation license. See Get Evaluation License for registration
information.
3. When you receive your license, copy it to your computer and then specify the directory path by clicking the Set
Location button on the License Configuration dialog box.
FLEXlm locked configuration using a software-based key is complete. To verify FLEXlm operation see “Verifying that
a License Can Be Checked Out”.

4.1.2. Configuring Locked Licensing with a Hardware-Based Key
The following procedure configures your machine for FLEXlm locked licensing with a hardware-based key calculated
from the serial number of the hardware dongle attached to your machine's USB port. AWR supplies you with the hardware
key. In this configuration, the NI AWRDE is installed on your machine, but the license can be transferred between
machines simply by moving the hardware dongle.
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Installing with a USB Hardware Key
To install with a USB hardware key:
1. Download and install the latest Sentinel HASP4 device driver from
http://sentinelcustomer.safenet-inc.com/sentineldownloads/, or run the HASPUserSetup.exe file from the
FlexLM/Windows/Hardware Key directory on the NI AWRDE CD.
2. AWR supplies you with a license file. When you receive your license, copy it to your computer and then specify the
directory path by clicking the Set Location button on the License Configuration dialog box.
FLEXlm locked configuration using a hardware-based key is complete. To verify FLEXlm operation, see “Verifying
that a License Can Be Checked Out”.

4.2. Configuring Floating Licensing
In a FLEXlm floating licensing configuration, the license file is assigned to a machine designated as the FLEXlm license
server. Each client workstation runs the Microwave Office (MWO)/Visual System Simulator (VSS)/Analog Office (AO)
application, requesting licenses from the server when needed.
AWR tools require FlexLM version 11.14 or later. You can download the FLEXlm drivers and tools as described in
“Obtaining the License File”.

4.2.1. Configuring Floating Licensing on the License Server
Perform the following steps on the machine designated as the FLEXlm license server to configure the server:
Obtaining the License File
To obtain the FLEXlm license file:
1. Create a C:\awr_flexlm directory and download the "FLEXlm Drivers and Tools" from the NI AWR website at
www.ni.com/awr under Support Resources > Customer Resources > Download Site on the Products tab after logging
in. Alternatively, the FLEXlm files are available in the FlexLM directory on the NI AWRDE CD. These files run,
debug, and maintain the FLEXlm license manager.
2. To obtain a valid FLEXlm license file, you must provide the machine's Ethernet address (hostID) as well as the
hostname. Locate and launch the lmtools.exe program included with the FLEXlm files. The LMTools dialog box
displays.
3. Click the System Settings tab.
4. E-mail the value in Ethernet Address, the value in Computer/Hostname, and your name, company name, address, phone
number, and purchase order number or invoice number to AWR at awr.license@ni.com.
5. When you receive the license file, rename it to awrd.lic and place it in your C:\awr_flexlm directory.
6. Open awrd.lic in a text editor and check the first line (the line starting with "SERVER"). If you see
"ReplaceWithServerName" replace it with the correct machine name and save the file.
Installing the FLEXlm Server
These instructions cover a simple FLEXlm license server installation. More complex configurations are described in the
License Administration Guide included with the FLEXlm files available from www.ni.com/awr under Support Resources
> Download Site on the Products tab or available in theFlexLM directory on the NI AWRDE CD.
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To install the FLEXlm Server:
1. If applicable, copy to your C:\awr_flexlm directory the awrd.exe, awrcheckout.exe, lmgrd.exe, lmtools.exe, and
lmutil.exe files from the appropriate Flex_Tools folder in the FlexLM directory on the NI AWRDE CD.
2. Start lmtools.exe. The LMTOOLS dialog box displays.
3. Click the Service/License File tab.
4. If you previously installed and set up FLEXlm services, select Config Services and specify AWR License Manager. If
you have not previously installed FLEXlm services, proceed to the next step.
5. Click the Config Services tab and verify that your settings match the following:
Service Name:

"AWR License Manager"

Path to the lmgrd.exe file:
Path to the license file:

"C:\awr_flexlm\awrd.lic"

Path to the debug log file:
Use Services:

"C:\awr_flexlm\lmgrd.exe"

"C:\awr_flexlm\debug.log" (for initial setup enter this information)

(selected)

Start Server at Power Up:

(selected)

6. Click Save Service to save these settings. When asked to confirm saving the settings for the license server, click Yes.
7. Click the Start/Stop/Reread tab and click Start Server to start the FLEXlm license server.
8. Click the Server Status tab and then click Perform Status Enquiry to display information about the server status.
NOTE: The first few times you start the license server, you should view the debug file C:\awr_flexlm\ debug.log for
any messages. You may first need to stop the license service if it has a lock on the file.
9. If necessary, click the Server Diags tab and then click Perform Diagnostics to diagnose any problems.
10. Choose File > Exit to close the LMTOOLS license service.
FLEXlm server configuration is complete. To verify FLEXlm server operation, see “Verifying that a License Can Be
Checked Out”.

4.2.2. Configuring Floating Licensing on Client Workstations
The NI AWRDE must be installed on the client machines. For instructions on installing the program, see “Installing the
NI AWR Design Environment”.
Perform the following steps on the client machines to configure FLEXlm clients:
1. Set the AWRD_LICENSE_FILE environment variable in the AWR License Configuration dialog box by clicking Set
Location.
<portNumber>@<serverName>
where <portNumber> is the port number described in the license file and <serverName> is the name of the
server machine. These variables are defined on the SERVER line of the license file in the following format:
SERVER <serverName> <hostID> <portNumber>
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If a <portNumber> is not specified, you should specify the SERVER line of the license file (on the server machine)
as
SERVER <serverName> <hostID> 27007
and you should stop and restart the server process.
2. If applicable, copy the awrcheckout.exe, lmutil.exe, and lmtools.exe files from the FlexLM directory on the NI AWRDE
CD to your C:\awr_flexlm directory. These utilities are used to troubleshoot the FLEXlm licensing configuration.
FLEXlm client configuration is complete. To verify FLEXlm client operation, see “Verifying that a License Can Be
Checked Out”.
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Chapter 5. Troubleshooting FLEXlm
This chapter references the information and tools available to verify the operation of and troubleshoot a FLEXlm licensing
environment. It provides a troubleshooting walk-through designed to verify FLEXlm operation and identify any errors
made during FLEXlm configuration, includes descriptions of the command line programs and Windows®-based program
(for example, FLEXlm Toolbox's LMTOOL program) that you can use during verification and troubleshooting, and
provides solutions to the FLEXlm-related errors that may occur during NI AWR Design EnvironmentTM (NI AWRDE)
operations.
If you cannot solve a FLEXlm-related problem using this information, contact AWR Technical Support by e-mail at
awr.support@ni.com or by phone at the number listed on the inside title page of this book.
For additional information on FLEXlm and FLEXlm management tools, see the License Administration Guide available
on the NI AWRDE CD or on the product downloads page.

5.1. FLEXlm Troubleshooting Walk-through
You can use the following procedures to verify FLEXlm configuration and operation and identify the most common
configuration errors.

5.1.1. Checking License File Location
To check client settings, follow these steps on the client workstations:
1. In the NI AWRDE, choose File > License > Configuration. The AWR License Configuration dialog box displays.
2. Click Set Location to display the Select License File dialog box and set it to <portNumber>@<servername> where
<portNumber> is the TCP/IP port number.

5.1.2. Checking License Server Configuration
To check the license server configuration, follow these steps on the server machine:
1. Start lmtools.exe. The LMTOOLS dialog box displays.
2. Click the Config Services tab.
3. If you have only one copy of FLEXlm running on the server, the Service Name should be AWR License Manager. If
you have more than one copy, make sure the correct service name is selected.
4. Verify that Path to the lmgrd.exe file points to the NI AWRDE version of the lmgrd.exe file. (Since each application
using FLEXlm can ship its own version of lmgrd.exe, you must use the one shipped with the NI AWRDE.)
5. Verify that Path to the license file points to the full path name of the correct license file.
6. Verify that Path to the debug Log file specifies a file name on the license server.
7. Click the Server Status tab, and then click Perform Status Enquiry to verify that the FLEXlm Version is 11.14 or later
and that the connection to the server was successful.

5.1.3. Restarting the License Server
To restart the license server on the server machine:
1. Start lmtools.exe. The LMTOOLS dialog box displays.
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2. Click the Start/Stop/Reread tab.
3. Click Stop Server, and wait for at least 10 seconds to ensure that all processes have stopped. If the license service was
not running, this command fails. Continue regardless.
4. Click Start Server. A "Server Started" message should display.

5.1.4. Checking the Debug Log
To check the debug log file on the server machine:
1. On the Config Services tab of the LMTOOLS dialog box, click View Log, or open the Debug.log file in a text editor.
Note that it can take up to 30 seconds for text to display in this file. If you get a message that another program has
control of this file, stop the license server, then try to open the debug log file again.
2. Verify the relevant information in the file, as follows:
• Make sure that you are looking at the latest information by checking the time stamp.
• Check for:
FLEXlm (v11.14)

if you see a lower version, you are running the wrong lmgrd.exe.
• Check for:
License file(s): <mwo_license_file>

where <mwo_license_file> is the name of the license file.
• Check for:
lmgrd tcp-port <nnnnn>

where <nnnnn> is the TCP/IP port on which FLEXlm is running. (The default port range is 27000-27009, however,
other values can be set via the SERVER line in the license file.)
• Check for:
Started awrd (internet tcp_port 0 pid xxx)

to verify that the vendor daemon has started.
• Check for:
Server started on serverName
for: feature1, feature2, ..., featureN

to verify which features are being served. This list should match the features listed in your license file.

5.1.5. Verifying that a License Can Be Checked Out
To verify that a FLEXlm license can be checked out on the server or client machines, follow these steps on the machine:
1. At a command prompt, from the C:\awr_flex directory for servers, or from the program directory for clients, run
lmflex.exe. The following table summarizes the different NI AWRDE product features.
2. Enter a feature specified in your license file (for example, "MWO_225"). The command output tells you if the feature
was successfully checked out.
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MWO_225 checked out...press return to exit...

3. If the feature cannot be checked out, a dialog box displays to inform you. See “Troubleshooting FLEXlm” for instructions
on finding possible causes for the problem.

5.1.6. FLEXlm Diagnostic Tools
To verify FLEXlm operation, you can either invoke the command line based lmutil.exe program or run the Windows-based
FLEXlm Toolbox program. For complete details, see the FLEXlm End Users Guide.
Command Line Program: lmutil.exe
To determine who has licenses checked out, at the command prompt, change to the C:\awr_flex directory and run
lmutil.exe as follows. The command output lists the status of the license manager, the number of licenses available, and
who has licenses checked out. For example:
C:\awr_flexlm> lmutil
lmstat -a
lmutil - Copyright (C) 1989-2009
Globetrotter Software, Inc.
Flexible License Manager status on Thu 8/25/2008
20:44
[Detecting lmgrd processes...]
License server status: 27007@mizar
License file(s) on mizar: C:\awr_flexlm\awrd.lic:
mizar: license server UP (MASTER) v9.1
Vendor daemon status (on deneb):
awrd: UP v9.2
Feature usage info:
Users of MWO-228: (Total of 1 license
available)
"MWO-228" v8.0, vendor: awrd
floating license
slr Mizar Mizar (v8.0) (deneb/27007
103), start Thu 8/25 20:44

5.2. Solutions to FLEXlm-Related Problems
This section lists some of the FLEXlm-related problems you may encounter when starting or running the NI AWRDE.
Additional troubleshooting information is available in the appendices of the License Administration Guide available on
the NI AWRDE product download page or available on the supplied NI AWRDE CD. For an online License
Troubleshooter, go to License Troubleshooter.
Problem

Cause

Solution

A Choose Server or
File dialog box
displays.

The NI AWRDE cannot connect to the license Click Cancel in this dialog box and follow the
server. This could be because the license server instructions in “Troubleshooting FLEXlm”.
is running on a different port, running on a
machine different from the one specified, or not
running at all.

Installation Guide 5–3

Solutions to FLEXlm-Related Problems
Problem

Cause

Solution

A "License server does
not support this version
of this feature
FLEXLM error:
-25,147" message
displays.

Each FEATURE line in the license file contains
a version number field that determines what
versions of the software it authorizes. This field
displays after the "awrd" and before the date.
The following are the license versions that
correspond with the various AWR product
releases:
Version: 13.0 ProductRelease:AWRDE V13
Version: 12.0 ProductRelease:AWRDE V12
Version: 11.0 ProductRelease:AWRDE V11
Version: 10.0 ProductRelease:AWRDE V10
Version: 9.03 ProductRelease:AWR Suite 2010
Version: 9.0 ProductRelease:AWR Suite 2009
(V9.0)
Version: 8.0 ProductRelease:AWR Suite 2008
(V8.0)
Version: 7.5 ProductRelease:AWR Suite 2007
(V7.5)
, Version: 1.7 ProductRelease:AWR Suite 2006
(V7.0)
, Version: 1.6 ProductRelease:AWR Suite 2004
(V6.5)
Version: 1.5 ProductRelease:AWR Suite 2003
(V6.x)
, Version: 1.4 Product Release: AWR Suite
2002 (V5.x)
Version: 1.3 Product Release: MWO 2001
(V4.02)
Version: 1.2 Product Release: MWO 2000
(V3.22)
, Version: 1.1 Product Release: MWO V2.6

If you are on maintenance, request a new license
file for the new version of the NI AWRDE from
AWR. If you are not on maintenance, you will
need to purchase an upgrade to run the new
version.

A "Cannot connect to FLEXlm has a default port range of
server" message
27000-27009. If the port specified in your
displays.
license file is within this range, you can specify
the AWRD_LICENSE_FILE in the form
@<serverName>. Although this works on
most machines, it can cause problems on some.

Specify a port number that does not conflict
with any other servers in the SERVER line of
the license file. (In the future, all NI AWRDE
license files will use a specific port number to
avoid this problem.) For example, if your
current SERVER line is as follows:SERVER
name 0000aaaabbbb you would change it
to: SERVER name 0000aaaabbbb 27033
where "27033" is the TCP/IP port number now
specified for your license file. You will also
need to change the AWRD_LICENSE_FILE
environment variables on all of the client
workstations from @<serverName> to
27033@<serverName> .

An "(awrd) Invalid
license key
(inconsistent

The license file has been improperly edited or Open the license file in a text editor such as
created.
Windows Notepad. If the license file is for a
floating configuration, the first line starts with
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Problem
encryption code for
...)" message displays
(this message can also
display in the
Debug.log file).

Cause

Solution
SERVER and the second line starts with
DAEMON. Verify that the lines are not merged
together and that there are no invalid control
characters in the file. FEATURE or
INCREMENT lines (are present in both floating
and locked license files. The FEATURE or
INCREMENT lines are usually line-wrapped, so
they will always start with FEATURE or
INCREMENT and end in a backslash, with the
second line starting with VENDOR_STRING.
For example:FEATURE MWO_225 awrd
1.7 13-mar-2002 1 D25C75B75E80
\VENDOR_STRING=cg123
HOSTID=00104b72d5f7 ck=191 If the
license file does not conform to these rules, it
is probably because your e-mail program cannot
interpret it correctly. Send the license file to
AWR at awr.license@ni.com for a
purchased license or at
awr.registrar@ni.com for an evaluation
license, and NI AWR will attempt to send it to
you in a format that your e-mail program
understands.
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Appendix A. Installation Program Reference
This appendix provides information about the NI AWR Design EnvironmentTM (NI AWRDE) installation programs.
These programs are automatically invoked by the installation program, but you can also run them from the Windows®
Start > Run command or from a command prompt if, for example, you want to create script files to perform network
rollouts.

A.1. NI AWRDE Installation Program
A.1.1. Description
This is the main installation program. The NI AWRDE is distributed as a Windows Installer (MSI) file on Windows.

A.1.2. Command Line Format
msiexec /argument AWR_Design_Environment_<version_build>.msi

Argument

Opt./Mand.

Description
Displays current command usage for install, display, restart, logging,
update, and repair options.

/?
/i

optional

Command line installation. See “Command Line Installation” for details.

/a

optional

Administrative (network) installation. See “Administrative (Network)
Installation” for details.

A.2. Administrative (Network) Installation
A.2.1. Description
This section addresses the administrative (network) installation. The NI AWRDE is distributed as a Windows Installer
(MSI) file on Windows.
During an administrative installation, files contained in the installer are installed in the targeted network directory. A
smaller msi file is also generated as part of the administrative installation within the targeted installation directory. With
this generated msi and source image, clients can install the entire product locally, or choose to only install required
components locally and run the rest of the application from the network location.
For example, the server can host an administrative installation on a network path:
msiexec /a AWR_Design_Environment_<version>.msi TARGETDIR=C:\path
where path is a shared directory on the server.
To install the NI AWRDE locally, you can run the above msi file without the additional command line options listed
below. All files are installed on your local PC and the program is run locally.
To run the NI AWRDE from the network directory (there are still some required files and registry information stored
locally), you need to specify the following properties with the msiexec command:
ADDLOCAL=mergemodules
ADDSOURCE=AWRFeature
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For example (as one continuous command):
msiexec /i \\server\path\AWR_Design_Environment_<version>.msi ADDLOCAL=mergemodules
ADDSOURCE=AWRFeature TARGETDIR=\\server\path
In this example, the mergemodules feature is installed locally and the NI AWRDE program is run from the network
location.
When running the program from a network server, to uninstall the program you must uninstall the client installation
before removing the network installation.
When repairing a network installation on a client, you should avoid the repair functionality in the Add/Remove Programs
dialog box within the Windows Control Panel, and instead repair the installation on the commandline.
For example (as one continuous command):
msiexec /faumv \\server\path\AWR_Design_Environment_<version>.msi
ADDLOCAL=mergemodules ADDSOURCE=AWRFeature TARGETDIR=\\server\path
Type msiexec /? for a full list of repair options.

A.2.2. Command Line Format
Argument

Opt./Mand.

Description

/a

mandatory

Administrative install - installs a product to a shared network server
directory.

ADDLOCAL

optional

List features you want to run locally.

ADDSOURCE

optional

List features you want to run from a network location.

A.3. Addin Manager: ADDINMANAGER.EXE
The Addin Manager allows you to enable/disable dynamically loadable DLLs to aid in troubleshooting. You can browse
for a DLL and register it within the NI AWRDE without needing to use the Windows Registry Editor (regedit.exe).
At startup, the NI AWRDE first searches the program installation directory for a DLL. If the DLL isn't stored there, it
locates and uses the registered version.
To open the Addin Manager choose Tools > Manage Addins. The Addin Manager displays with a list of add-in programs
in several categories: EM Simulators, General, Wizards, and all of these categories, (All). Select each option to view a brief
description of it in the Description area of the dialog box. To disable the DLL for an addin, clear the associated check
box.
You can also start the Addin Manager by launching AddinManager.exe from the NI AWRDE program directory.

A.4. NI AWRDE Analyst Installation Program
A.4.1. Description
NI AWRDE AnalystTM is distributed as an executable bootstrapper containing a set of executable files for installing NI
AWRDE and Analyst. At run-time, the bootstrapper determines which of these files needs to be executed (and in what
way) to complete the installation.
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A.4.2. Command Line Format
AWRDE_Analyst_<version>.exe [arguments]

Argument

Opt./Mand.

Description

/?

optional

Displays current command usage for install, user interface
mode, logging, and component arguments

/i

optional

Command line installation

/DisplayConfig

optional

Displays the IDs and display names of the individual
bootstrapper components

/ComponentArgs
optional
"id|display_name":"value"

Passes additional arguments to components of the
bootstrapper. Use this to install Analyst or NI AWRDE to a
specific location from the command line.

Examples
Command line

Description

AWRDE_Analyst_<version>.exe

Install NI AWRDE Analyst in full user interface
mode.

AWRDE_Analyst_<version>.exe /q

Install NI AWRDE Analyst in silent mode.

AWRDE_Analyst_<version>.exe /ComponentArgs
"mwo":"TARGETDIR=D:\temp\awrde_install"

Install NI AWRDE to D:\temp\awrde_install
and Analyst to the default location.

AWRDE_Analyst_<version>.exe /ComponentArgs
mwo:"TARGETDIR=D:\temp\awrde_install /log
mwoinstall.log"

Install NI AWRDE to D:\temp\awrde_install
and Analyst to the default location. Also write
the install log for MWO to mwoinstall.log

AWRDE_Analyst_<version>.exe /q /ComponentArgs
Install Analyst silently to a path containing
"analyst":"TARGETDIR=""D:\temp\analyst_install spaces (D:\temp\analyst_install newver) and NI
AWRDE to the default location.
newver""

A.5. Job Scheduler Service Installation
A.5.1. Description
This section provides information for installing the Job Scheduler service for remote computing.

A.5.2. Command Line Format
The following command line syntax is for NI AWRDE installation. The installer writes the installation log to
awrde_install.log.
msiexec /i awrde_vXX_XX_XXX.msi JOBSERVICE=YES /l*v .\awrde_install.log

The following command line syntax is for NI AWRDE with 3D Editor installation. The installer writes the NI AWRDE
installation log to awrde_install.log and the 3D Editor installation log to awrde_bootstrap.log.
awrde_analyst_vXX_XX_XXXX.exe /ComponentArgs "mwo":"JOBSERVICE=YES /l*v .\awrde_install.log"
/Log /LogFile .\awrde_bootstrap.log
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After running the installers, you need to specify the license file location by either running the NI AWRDE, or by running
LicLocSetup.exe from thethe NI AWRDE installation directory. You also need to restart the Job Scheduler service in
order to configure the Job Scheduler for the newly set license. See the Simulation and Analysis Guide for details on
managing the service. NOTE: Licensing changes always require a restart of the Job Scheduler service.
After installation, open the Windows Task Manager and click the Services tab to verify that the AWR_JobScheduler
service is listed with its Status as "Running". For further details and service options, click the Services button at the
bottom of the window to display the Services window. After the Job Scheduler is registered as a service, it launches
whenever Windows starts and serves jobs on that computer until the computer shuts down or you stop the service. See
the Simulation and Analysis Guide for information on stopping and removing the Job Scheduler service.
NOTE: Running the NI AWRDE installer again switches the version of the Job Scheduler service to that of the most
recent installation. When installing multiple versions of the NI AWRDE on a remote computer, you should install from
the lowest to the highest version number to ensure that the highest version of the Job Scheduler service is installed. See
the Simulation and Analysis Guide for information on manually changing the service version.
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