Quick Reference

NI AWRDE QUICK REFERENCE
You can access this file (Quick_Reference.pdf) in the NI AWR Design EnvironmentTM (NI AWRDE) by choosing Help > Quick
Reference.

This menu command opens any document named Quick_Reference.pdf in the NI AWRDE installation folder.

ADDITIONAL RESOURCES AVAILABLE
NI AWR Knowledge Base
https://awrcorp.com/support/help.aspx?id=9 or Help > Knowledge Base
• Application Notes - Articles written by the NI AWR technical staff or our partners about how to use the software.
• Examples - A list of all the examples shipped with the NI AWR installer and other examples only available in the Knowledge
Base.
• Licensing - A step-by-step guide to resolving most common licensing problems.
• Questions - Answers to common customer questions or issues.
• Scripts - A collection of scripted utilities to help solve specific problems and a collection of scripting examples.
• Documentation - A complete copy of the latest released NI AWRDE documentation.
• Videos - Short videos on how to accomplish specific tasks, and longer videos for training on specific topics.

NI AWRDE ONLINE HELP
Hotkey

Description

Hotkey

Description

F1

View context sensitive Help on the selected item

Space bar

Scroll down in the online Help

Shift + Space
bar

Scroll up in the online Help

Search

tab

Search the Help. There are advanced search
options at the bottom of the pane.

PROJECT BROWSER / DESIGN ENVIRONMENT
Design Environment
Most actions are customizable to create your own hotkey, toolbar button, or menu option. Choose Tools > Customize to add your own
customizations for toolbars and menus, and Tools > Hotkeys to add your own hotkey commands.
Use these keystrokes from anywhere in the NI AWRDE:
Hotkey

Description

Hotkey

Description

Ctrl+O

Open a project

Ctrl+D

Duplicate an item in the Project Browser

Alt+1

Open Project Browser

F6

Update an equation display

Ctrl+Y

Redo last operation

F7

Open the Optimizer dialog box

Shift+F7

Display a list of all variables used in a project F8

Simulate

Ctrl+S

Save a project

Open/close the Variable Tuner

Ctrl+Tab

Cycle through open windows in one direction Ctrl+Shift +Tab

Cycle through open windows in the opposite
direction

F2

Rename a selected item using Rename dialog Shift+F2
box

Rename a selected item directly

F9
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Zooming and Scrolling
These keystrokes are common to most window types (circuit schematic, system diagram, layout, EM, global and output equations).
Mouse wheel actions are customizable. Choose Options > Environment Options... > Mouse to add your own customizations.
Hotkey

Description

Hotkey

mouse wheel

Scroll up and down

Shift+mouse wheel Scroll right and left

Ctrl+mouse wheel Zoom in (centers on the cursor) and out

Description

Up Arrow

Scroll up

Down Arrow

Scroll down

Left Arrow

Scroll left

Right Arrow

Scroll right

Num -

Zoom out

Num +

Zoom in

Home

View All

Ctrl+W

View Area

End

View Previous

Project Browser
• Display additional context menu options in the Project Browser by Shift + right-clicking a Project Browser node.
• Change model list views in the Element Browser by right-clicking in the lower pane to select the model display. The Details view
provides the model name and a brief description of the model.
• Open a project item by name by right-clicking in the Project Browser and choosing Open Project Item to view and select an item
in your project. The list of items is filtered as you type, and the item that best matches your input is highlighted.
• Open a specific example by choosing File > Open Example or Help > Open Example to filter a list of examples by name or keyword.
Ctrl-click a column header to filter by that column.
• Show all previously opened projects by choosing File > More Projects to display and filter by rank, project (name), (date) last
opened, or path a list of all projects you have opened. Ctrl-click a column header to filter by that column.
• Browse to specific files and folders by choosing Help > Show Files/Directories to display all of the files and folders the NI AWRDE
uses. Double-click a folder or file to open it.
• Add/delete/rename/... an item by right-clicking it to display a context menu with options to add, delete, rename, import/export,
collapse/expand, link to, view properties for, and other actions.
• Bypass the default deletion confirmation by pressing the Shift key while deleting Project Browser items (such as graphs or
schematics).
• Duplicate an item by dragging it up to its parent node in the Project Browser and dropping it (schematics/system diagrams, data
files, EM structures, graphs and measurements only). The new item has the same root name appended with "1" so it displays next
to the original item in the Project Browser. You can also right-click an item and choose Duplicate <item> or press Ctrl + D.
• Add a subcircuit to a schematic window by right-click dragging and dropping a schematic or EM document from the Project
Browser onto an open schematic window.
• Create an output equation identical to a measurement by dragging and dropping a measurement from the Project Browser into
the Output Equations window.
• Quickly access document options by right-clicking in a document with nothing selected and choosing Options.
• Copy between different instances of the NI AWRDE by selecting the item you want to copy and pressing Ctrl + C. Select the
parent node in the second instance and press Ctrl + V to paste.
• Import items from another project by choosing File > Import Project.
• Archive a project by choosing File > Archive Project.
• Open archives by selecting Project Archive (*.emz) as the file type in the Open dialog box.
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Floating Windows
• Classify a window as floating by right-clicking the window title bar. You can move a floating window outside of the NI AWRDE.
This feature is useful when using dual monitors.
• Maximize a window by double-clicking the title bar of a floating window; double-click again to restore it to its previous size.

Window in Window
• Create a window in a window by dragging and dropping an item from the Project Browser onto an active window. The cursor
changes to allow you to click and drag to draw the desired window size. You can insert multiple, pre-sized windows at once by
choosing Draw > Insert Windows. If more than one window is selected for insertion, a second dialog is present to allow arrangment
into an array pattern.
• Resize and align multiple windows by right-clicking the toolbar and choosing Align to display the Align toolbar with various
alignment options, and then selecting the "window in window" objects and the proper align command. You can also size each
selected window identically.
• Edit "window in window" views by double-clicking the view or by selecting it, right-clicking and choosing Activate View. When
editing these windows you are editing the original object (for example, the schematic or graph). Click once to select and move an
object.

User Folders
• Create a user folder by right-clicking the User Folders node and choosing Add New > Folder. You can also create subfolders under
any folder.
• Add new items to a user folder by right-clicking the User Folders node or existing user folder, choosing Add New and then selecting
the item type you want to add.
• Add existing items to a user folder by dragging the item(s) to the user folder. You can also right-click the User Folders node or
existing user folder and choose Add Existing Item to select items from a list.
• Remove items from a user folder by selecting the item and pressing the Del key or right-clicking and choosing Delete. A dialog
box displays to confirm removal from the folder only, or deletion from the project.
• Reorder items in a user folder by selecting the item and pressing the Alt key and up or down arrow keys to move it.
• Organize items in a user folder by type by right-clicking a folder and choosing Group by Type, or alphabetically regardless of
type by choosing this option again to toggle it off.
• Organize folders by type by right-clicking a folder and choosing Show Grouping Folders.
• Take measurements on user folders by including angle brackets around the folder name: "<user folder>".
• Take a measurement on specific sources within a user folder by using the <user folder> syntax and selecting the measurement
source as <user folder=> in the measurement, and then clicking the sources you want to plot in the user folder.

Variable Browser
• To access, choose View > Variable Browser.
• Sort entries in a column by clicking the column header. Click again to reverse sort.
• Filter entries by typing in the filter text box above the column you want to filter. Hover the cursor over the filter text box to display
tool tips for different filter mechanisms.
• Select multiple items in a column by Shift-clicking them. You can also press the Shift key in combination with the arrow keys.
Press Ctrl + A to select the entire column.
• Go to an element or equation by clicking the link in the Element column.
• Enter constraint values quickly by typing "%" or "#" after the value. When applied to the value field, both lower and upper
constraints are computed and set.
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Measurement Editor
• To access, right-click a source document or graph and choose Edit All Measurements.
• Sort entries in a column by clicking the column header that you want to sort on. Click again to reverse sort.
• Filter entries by typing in the filter text box above the column you want to filter. Hover the cursor over the filter text box to display
tool tips for different filter mechanisms.
• Select multiple items in a column by Shift-clicking them. You can also press the Shift key in combination with the arrow keys.
Press Ctrl + A to select the entire column.
• Change measurement simulators, modifiers, or parameters by modifying the appropriate column in the Measurement Editor.
For setting the simulator to APLAC, simply type AP and the system deduces the correct simulator string, e.g., AP vs. AP_HB vs.
AP_DC.

CIRCUIT SCHEMATIC / SYSTEM DIAGRAM
Keyboard/Mouse Shortcuts
Hotkey

Description

Hotkey

Description

Ctrl+G

Add a ground connection (schematic only)

Ctrl+P

Add a port (schematic only)

Ctrl+E

Add an equation

Ctrl+K

Add a subcircuit

Ctrl+L

Add an element

Ctrl+T

Add text

Mouse 5

Descend into SUBCKT

Mouse 4

Ascend out of SUBCKT

Common Operations
• Unit modifiers: Add the following standard unit modifiers to element models to simplify the entry of model parameters: a, f, p,
n, u, m, c, d, mil, k, meg, g, t. These modifiers follow SPICE rules; they are not case sensitive, they must follow the number directly
without a space, and any characters directly following the modifier are ignored. Unrecognized modifiers are treated as a unit
multiplier (x1).
• Auto-wire elements: Press the Shift key when inference lines appear during wiring.
• Edit parameters in a schematic: Double-click a model parameter value in a schematic to display a text box for editing. Press Tab
to move to the next parameter and Shift+Tab to move to the previous parameter.
• Edit the same parameter for multiple elements: Select all of the elements to edit, right-click any of the elements and choose
Properties. Edits are applied to all common (by name) parameters.
• Replace an element: Double-click a model name and type a new name. For example, double-click "RES" and type "CAP" to
replace a resistor with a capacitor. Any parameters that match by name are preserved just like swap element.
• Replace multiple elements: Select all of the elements to replace, then in the Element Browser find the element with which to
replace them. Right-click that element and choose Replace Schematic Selection. The Preserve Parameters option retains any common
parameter values while Replace Parameters uses the element's default parameters (useful when replacing with library elements).
• Change element layout or symbol: In the Element Options dialog box for each element, Symbol and Layout tabs allow changes
to the element symbol and layout.
• View subcircuit contents: Press the Shift key while double-clicking to open the subcircuit in the same window. Press the Ctrl key
while double-clicking to open the subcircuit in a new window. Ctrl double-clicking works with any element that references another
document like PORT_TN, LIN_S, etc.
• Work with linked documents: Right-click a schematic and choose Link to display the Save As dialog box and convert from
imported to linked, Embed to convert from linked to embedded, Load to update a linked schematic after it is edited, Save or SaveAs
to save edits to file, and Explore to open the folder containing the linked schematic.
• Make a measurement a favorite: Click the Favorite button in the Add/Modify Measurement dialog box.
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• Add a favorite measurement to a graph directly from a schematic or system diagram: Right-click in an open area of the
document and choose Add Measurement.
• Repeat commands with a single click: Click the Command Repeat Mode button on the toolbar.

Adding/Placing an Element
Add/Place an element by pressing Ctrl+L or choosing Draw > More Elements to filter a list of elements by name, description, or path.
Ctrl-click a column header to filter by that column. Searches can use multiple words: "micro line" displays matches for both words.
After dragging an element from the Element Browser into the work area, or copying and pasting an element, you can:
Keystroke

Description

Keystroke

Description

Click

Place at current location

Right-click

Rotate counter-clockwise 90-degrees per
click

Ctrl-right-click

Mirror about the Y-axis

Shift-right-click

Mirror about the X-axis

Setting up a Sweep
• Create a sweep for a parameter or variable by right-clicking the parameter or variable and choosing Setup Sweep.
• Edit the sweep parameters of an existing sweep by right-clicking the element parameter using the swept variable. You can change
the sweep type (linear or log), the way the sweep is specified (step size or number of points), and the range of the sweep.

Schematic/Diagram Connectivity
• For models requiring a substrate or model block, right-click the model and choose Add Model Block.
• Start a wire from the middle of another wire or node by right-clicking to select the wire and then choosing Add Wire.
• Remove a previous point by right-clicking while you add a wire.
• Control wire direction after starting a wire by changing the location of the cursor relative to the starting point of the wire.
• Set auto wire deletion by selecting the Auto wire cleanup check box in the Project Options dialog box on the Schematics/Diagrams
tab (choose Options > Project Options). When deleting an element, the wires connected to it are also deleted. If not selected (the
default setting), the wires remain.
• Highlight a net by selecting a wire, right-clicking and choosing Highlight On to highlight a net through hierarchy in a different
color. Any iNets in layout for these nets are also highlighted in this color.
• Create a bus net by selecting a wire, right-clicking and choosing Create BusNet.
• Edit net properties by selecting a wire, right-clicking and choosing Edit Net Properties (circuit schematics only).
• Disconnect an element by pressing the Ctrl key while dragging the element (wires are deleted).
• Move an element orthogonally only by pressing the Shift key while dragging the element to constrain its movement to horizontal
and vertical directions from the original position.

Symbols
• Create a custom symbol for a subcircuit using the Symbol Generator Wizard located under the Wizards node in the Project Browser.
These symbols can place nodes based on the schematic or layout representation of your subcircuit.
• Add a default subcircuit symbol to schematics, EM structures, and data files by right-clicking these documents in the Project
Browser, choosing Options, and on the Options dialog box Symbol tab setting the default.
• Quickly edit a user-defined symbol by right-clicking the symbol and choosing Edit Custom Symbol.
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Element Selection
Restrict items for selection by right-clicking anywhere in a circuit schematic/system diagram with nothing selected and choosing
Restrict Selection to turn on/off different items for selection. When items are turned off they cannot be selected for the following
operations:
•

Shift-click

to select multiple models or remove models from those selected.

• Click and drag to select all objects completely inside the drawn selection area.
•

Shift-click

and drag to select all elements that are even partially enclosed in the drawn selection area.

• Press Ctrl+A to select all objects.
• Press Ctrl+Shift-click to cycle through elements if elements overlap.

Elements on Schematics/System Diagrams
Select an element and right-click its symbol (not the parameter text) to display a context menu to:
• Edit element properties/parameters in the Element Options dialog box.
• Toggle enable or disable the element in the schematic or diagram.
• Swap the element with another element.
• Rotate or flip or freeze in place the element.
• Zoom In/Out, View Area, View All to change the view.
• Display the Help for the element.
• Select or place the element in the layout for the schematic.
• Edit the element symbol in the Symbol Editor.

Buses and Vector Instances
• Make a vector instance: Edit the ID and add the iteration count; for example, change "ID=R1" to "ID=R1[0:3]" to make four
resistors for simulation and layout.
• Make a bus: Connect a wire to a vector instance. A bus label displays on the wire. You can edit the label to name it or resize it.
You can also give an NCONN a bus or bundle name. The attached wire resizes to match.
• Name a bus using vector notation: B[0:3] denotes a bus named B with 4-bits.
• Bundles are names separated by commas: B1,D,E3,A is a 4-bit wide bundle containing nets B1, D, E3 and A.

Tuning
•
Tune Tool (F10): Click on a variable or parameter to make it tunable.
•
Variable Tuner (F9): Open the Variable Tuner with controls for

each tunable parameter, or click the Tune button on the toolbar.

• Control the tuning step size by changing the Step.
• Press the Shift key while tuning to Start a simulation only when you release the mouse button.
• Press the Ctrl key while tuning to update the layout at every tuner point instead of when you release the mouse button.
• In the Variable Tuner, turn off an item for tuning by clearing its check mark in the Tune column.
• Filter variables in the Variable Tuner by assigning the parameter or variable a tag in the Variable Browser or Tuner.
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• If an element parameter is set for tuning but the element is not constrained, the upper tuning limit is 2X the nominal value and the
lower tuning limit is 0.5X the nominal value. Change this by setting constraint limits on each parameter. If a parameter has
constraints, those values are used as the tuning limits. You can also edit these values in the Variable Tuner to edit the constraints
for that parameter.

LAYOUT
Keyboard Shortcuts
Hotkey

Description

Hotkey

Description

Ctrl+T

Add text

Ctrl+E

Draw ellipse

Ctrl+L

Draw path

Ctrl+P

Draw polygon

Ctrl+B

Draw rectangle

Ctrl+G

Toggle grid snap

Ctrl+O

Toggle orthogonal mode

Ctrl+D

Start Measure tool

Common Operations
• Coordinate entry: While drawing a rectangle, polygon, or path, or while dragging an object or placing a cell, press Tab or the
Space bar to specify a location using relative or absolute coordinates.

• Snap shape: Press Ctrl to snap the mouse to endpoints, midpoints, and edges during dragging, moving, stretching, and measuring
operations.
• Aligning shapes: Select all shapes to align, then choose Draw > Align Shapes to view alignment options. The first item selected is
the reference point for the alignment.
• Boolean operations: Select all the shapes for the Boolean operations (such as AND, OR, XOR), and choose Draw > Modify Shapes
to view the operators.
• Move or Copy shapes using commands: Choose Edit > Move or

Edit > Copy with reference.

Parameterized Layout Modifiers
• Parameterize a layout by selecting the shape(s) to be parameterized and then choosing Draw > Parameterized Modifiers and selecting
one of the many modifiers.
• Verify the order of the parameterization by choosing Layout > Modifier Properties. The order of execution of layout modifiers
can affect the final layout.

Layout Selection
Restricted selection: Right-click in a layout (with nothing selected) and choose Restrict Selection to display a dialog box to turn on
or off different items for selection. Items that are off cannot be selected for the following operations:
• Select a shape by clicking it.
•

Shift-click

to select multiple objects or remove objects from those selected.

• Press Ctrl+Shift to cycle through overlapping shapes when selecting a shape that overlaps other shapes.
• Click/drag to Select all objects completely inside a drawn selection area.
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•

Shift-click

and drag to select all objects that are even partially enclosed in a drawn selection area.

• Choose Layout > Layout Mode Properties to specify manual or auto-selection in Selection mode. Auto select selects any item clicked.
Manual select requires a Shift-click to select and deselect objects.

Measuring Distances
• Display a temporary ruler to measure a distance when you click and drag. Choose Draw > Measure, press Ctrl+D, or click the
Measure button on the toolbar to activate. When you release the mouse button the ruler goes away. Hold down the Ctrl key while
measuring to snap to vertices, midpoints, etc. Hold down the Shift key for cummulative measurements.
• Display a set layout ruler to measure a distance when you click and drag. The layout ruler remains on the screen and has configurable
properties. Choose Draw > Layout Ruler to activate. To configure ruler properties, select the ruler, right-click and choose Shape
Properties.
• Display dimension lines that show the distance between two selected points when you click and drag. Choose Draw > Dimension
Line to activate. To configure dimension line properties, select the line, right-click and choose Shape Properties.
• Display smart dimension lines that show the length of an edge of a polygon. Select a polygon and choose Draw > Parameterized
Modifiers > Edge Length to activate. Edge length modifiers track any changes to the edge length and can be used to control edge
length.

Layout Modes
Layout modes allow you to configure different layout settings and then easily switch between them while working in the Layout
Editor.
• Layout Mode Setup: To set up different layout modes, in a Layout window, choose Layout > Layout Mode Manager to open the
Layout Mode Properties dialog box. Click Edit to view the Layout Editor Mode Settings dialog box with tabs and options for
controlling different layout modes.
• Layout Mode Selection: To quickly select different layout modes, in a Layout window, click the Layout Editor Mode toolbar button.

Routing MTRACE2 or MCTRACE Elements
• To display "drag handles", double-click a cell.

• When a cell is a straight line, drag the middle handle to add a "dogleg" bend.

• To stretch or shrink a trace, drag the endpoints.
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• With one or more bends, press Ctrl and drag a "midpoint" handle to add another bend.

• To change the angle of the last bend, press Ctrl and drag an endpoint.

• To stretch a trace while maintaining a constant length, drag a "midpoint" handle.

• To stretch a trace without maintaining a constant length, press Shift and drag a "midpoint" handle.
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• To redraw a trace from scratch, double-click either end point. Click to place vertices, and double-click again to finish the trace.
The entire trace must be re-routed; a segment cannot be added from pin2.

Routing iNets
• To start routing an iNet double-click a rat line in layout.
•
Click the Show Routing Properties button on the toolbar to open the iNet Routing dialog box to set the default width and line
type for routing. Select the Use HV routing check box to use different defaults for horizontal versus vertical lines.

• Set the layout mode settings (choose Layout > Layout Mode Properties) in the Routing options group to automatically start a route
on the pin layer or start a route the same width as the area pin connected to the iNet.
• When routing, press the Shift + Ctrl keys while scrolling the mouse wheel to change the line type for the iNet.
• When routing, right-click to undo the last segment.
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• To return to drawing mode, right-click an existing route and choose Redraw Route. You can enter new segments to the route or
right-click to remove the last segment. The end of the route the cursor is closest to is the end of the route you edit.
•

Shift-click to select individual segments of an iNet, then right-click and choose Route Segment Properties to change the width and

line type of only the selected segments.
• To view edit handles and resize a via, double-click an iNet via.

Stretching Layout Shapes
• To stretch orthogonally, drag corner handles.

• To stretch without angle snap, start dragging an element, then press the Shift key and drag the corner handles.

GRAPHS
Keyboard Shortcuts
Hotkey

Description

Hotkey

Description

Ctrl+F

Freeze traces

Ctrl+U

Clear frozen traces

Ctrl+M

Add marker

Ctrl+mouse wheel Zoom in (centers on the cursor) and out

Common Operations
• Save data from a graph to a text file by choosing Graph > Export Trace Data.
• Add a measurement on a graph by right-clicking the graph and choosing Add New Measurement.
• Modify a measurement on a graph by right-clicking the graph and choosing Modify Measurement.
• Change measurement order in a graph by selecting a measurement in the Project Browser and dragging it to the desired order
location, or pressing the Alt key and up or down arrow keys to move it.
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• Modify trace properties, modify or toggle the measurement, or view the source document by right-clicking measurements in
the graph legend.
• Modify optimization and yield goal properties by right-clicking the goals.
• Change multiple trace properties by selecting multiple traces when making edits on the graph Options dialog box Traces tab.

Tabular Graphs
• Change the display precision of tabular graph numbers by right-clicking a graph and choosing Options to display the Tabular
Graph Format dialog box to specify options.
• Change column header text by right-clicking a graph and choosing Options to display the Tabular Graph Options dialog box to
change the display for each measurement.
• Sort by clicking a column header.

Rectangular Graphs
• Limit the axes of a rectangular graph after a simulation by right-clicking and choosing Zoom Data, and then clicking and dragging
to define an area for magnification. Click and drag over the x-axis of the graph to zoom only in the x-direction.
• Reset the axis limits by right-clicking and choosing Restore Axis Setting.

Markers
To view marker options, right-click a marker. Marker options are dependent on the graph type. Most graphs support markers.
• Reference Marker: Any markers attached to the same trace show a delta value from the reference marker. Any markers on the
graph show a delta value when selecting Ref marker all traces on the graph Options dialog box Markers tab.
• Marker Search: Search for values of the trace.
• Marker→Max and Marker→Min: Search for min and max values of the trace and add horizontal and vertical line markers on
a Rectangular graph.
• Use markers as sweep indexes for other measurements by selecting the marker in the variable drop-down in another measurement.
• Add Auto Search Markers to track specific features of a trace by right-clicking on a graph and choosing Add Auto Search
Marker. Auto search markers can track maximums, minimums, and specific peaks or valleys, as well as a specific y-value or x-index.
• Move markers to the previous/next sweep point by selecting one and pressing Shift left/right arrow.

ELECTROMAGNETIC STRUCTURES
The NI AWRDE has both 3D planar EM simulators, EMSight and AXIEM, as well as a full 3D Finite Element Method simulator,
AnalystTM. See the Help for information on each simulator.

User Interface
• To access controls for drawing and viewing EM structure layout objects in the Layout Manager, in an EM structure window,
click the Layout tab.
• To see the simplified structure after shape pre-processing rules are applied, right-click an AXIEM or Analyst EM structure
and choose Preview Geometry.

Viewing Mesh, Currents, and E-fields
• Currents and E-fields are viewed in an EM structure 3D view, while mesh is viewed in a 2D or 3D view. These are added as
annotations.
•
Show 2D Mesh

or Show 3D Mesh toolbar buttons quickly turn mesh on or off in 2D or 3D views.
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• To add mesh, currents, and E-fields, right-click an EM structure in the Project Browser and choose Add Annotation.

Data Sets
• View results of previous iterations of a structure by right-clicking a data set and choosing Update Results, or by Shift-clicking
a data set.
• Force the use of a specific data set in simulations by right-clicking the data set and choosing Pin Results.
• View the geometry of the EM structure that created a data set by right-clicking the data set and choosing View Geometry.

EQUATIONS / VARIABLES
Equations
• Display the value of an equation by typing its name followed by a colon (":"). When you simulate or press F6, the variable updates
to display its evaluated value.
• Add multiple equations in one block by pressing Ctrl+Enter to add a new line.
• Equations and variables display matching values as you type. For equations, arguments are also listed.
• For Help on an equation, press F1.
Output Equations
• Create an output equation of a measurement by selecting and dragging the measurement into an Output Equations document.
• Create an output equation of the values on a marker by using the marker() function in an Output Equations document.
• Edit output equations in the Edit Equation dialog box by Shift-double-clicking the output equation.

Variables
• Set variables to pass down into lower levels of hierarchy by right-clicking the variable and choosing Properties, then the Pass
Down Mode in the Edit Equations dialog box.
• Pass variables up to be set at higher levels of hierarchy by using “<<” instead of “=”.

ANALYST 3D EDITOR
Accessing the 3D Editor
• Create, import, or link to an Arbitrary 3D EM structure in an NI AWRDE project.
• In the NI AWRDE Project Browser, right-click the Arbitrary 3D EM structure and choose Open in 3D Editor.

Online Help
3D Editor Help is available by clicking the Application button at the top left corner of the main window and choosing Help, or
by clicking the question mark button at the top right corner of the main window.
3D Editor Help is independent of the NI AWRDE Help.
Hotkey

Description

Hotkey

Description

F1

View context sensitive Help on the selected item

Space bar

Scroll down in the online Help

Shift+Space bar

Scroll up in the online Help

Search

tab

Search the Help. There are advanced search
options at the bottom of the pane.
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Navigator / User Interface
Keyboard Shortcuts
Hotkey

Description

Hotkey

Description

Ctrl+S

Save

Ctrl+C

Copy

Ctrl+V

Paste

Ctrl+Z

Undo

Ctrl+Y

Redo

Shift+U

Edit working units

To set or change keyboard shortcuts, on the Home ribbon in the Settings group, click the Hotkeys button.
Commands
• Command hints that include mouse and keyboard instructions often display at the bottom of the main window in yellow.

• Complete a command and specify the remaining input by pressing the Space bar.
• Specify the next command step in a command by pressing the Tab key.
•
Cancel a command by pressing the Escape key, clicking the Cancel button on the Structure view toolbar, or choosing Cancel
from the Structure View context menu.
Controls and Views
• Toggle visibility of a control by clicking Control Visibility and choosing an option on the Window ribbon in the Controls group.
• Show/Hide all controls by clicking Show All Controls or Hide All Controls on the Window ribbon in the Controls group.
• Load a default window layout by clicking Standard Layout on the Window ribbon in the Controls group. This is useful for reopening
a window.
•
Change window placement to floating, dockable, or tabbed document by right-clicking the window header to access the
context menu, or clicking the Window Position button on the window header. You can also float a window by dragging the window
by the header.
•
Auto Hide a window by clicking the push-pin button on the window header. To quit Auto Hide mode, click this button again.
Copying and Pasting
Geometric entities, materials and attributes can all be copied within and between instances of the 3D Editor.
• Copy an object in the Browser by dragging it to its parent node and dropping it. The new item uses the same root name appended
with "_1" so it displays next to the original item in the Browser. You can also right-click an item and choose Copy, then right-click
its parent node and choose Paste.
• Copy an entity in a 3D view by picking the entity and pressing Ctrl+C.
• Paste an entity in a 3D view by pressing Ctrl+V.
Navigator
• Add notes on your structure by clicking the Notes node.
• Restore your Structure view by clicking the Structure node.
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Structure View
Working Plane
The working plane is a grid used primarily for drawing entities; it represents the active coordinate system.
• View current grid spacing in the upper left corner of the Structure view.
•
Change grid spacing by clicking the Use Snap Grid button on the Structure view toolbar and selecting an option.
•
Change grid visibility by clicking the Working Plane Visibility button (default hotkey is V) on the Structure view toolbar.
• Change working plane orientation by clicking Plane on the Structure ribbon in the Working Coordinate System/Plane group and
choosing XY, YZ, or ZX.

• Change the working plane offset from the origin by specifying a value in Offset on the Structure ribbon in the Working Coordinate
System/Plane group.

Units
• Change the working units by clicking the Units button on the Home ribbon in the Settings group.
• Choosing an appropriate distance unit is essential. The 3D Editor supports geometric sizes and positions over a range of 1e-5
to 1e+4 working distance units. For example, if your working Distance units are set to cm, you should avoid geometry smaller than
1e-5 cm and larger than 1e+4 cm.
Common Operations
• The location of your cursor, expressed in working distance units in the active coordinate system, displays at the bottom of the
Structure view.
•
Measure distances by clicking the Calculations and Queries button on the Structure view toolbar, and choosing Distance
from the drop-down menu. Follow the command hint at the bottom of the main window.

Point, Point

•
Zoom in on an area of the view by clicking the Zoom Area button on the Structure view toolbar (default hotkey is W) or by
choosing Zoom Area from the Structure view context menu. Click and drag your mouse to define the zoom area.
•
Fit

Fit the view to your structure by clicking the Fit button on the Structure view toolbar (default hotkey is F) or by choosing
from the Structure view context menu.

Coordinate Systems
All entities are defined with respect to a coordinate system. The 3D Editor provides a default World coordinate system and you can
create two types of local coordinate systems.
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•
Create a new relative coordinate system by clicking the New Coordinate System button and choosing New Relative Coordinate
on the Structure ribbon in the Working Coordinate System/Plane group.

System

• Create a new face coordinate system by clicking the New Coordinate System button and choosing New Face Coordinate System
on the Structure ribbon in the Working Coordinate System/Plane group. Follow the command hint at the bottom of the main window.
• Specify an active coordinate system by choosing a coordinate system on the Structure ribbon in the Working Coordinate System/Plane
group. Your selection impacts subsequently drawn entities.

• Change an entity's coordinate system by selecting the entity in the Browser and using the Browser property grid to change the
Coordinate System parameter.

Entities
Creation and Deletion
• Draw an entity by clicking Draw Entity and choosing an option on the Structure ribbon in the Entity Creation group. Follow the
command hint at the bottom of the main window.
• Import entities (SAT, IGES, DXF, GDS2, etc) by clicking Import Entities and choosing an option on the Structure ribbon in the
Entity Creation group.
• Export entities by clicking Export Entities on the Structure ribbon in the Entity Creation group.
• Delete entities by selecting the entity node(s) in the Browser, right-clicking and choosing Delete from the context menu or pressing
the Delete key.
Picking
• Pick a single entity in the Structure view by clicking it.
• Pick more than one entity in the Structure view by Shift-clicking entities.
• Pick all entities in the Structure view by choosing Pick > All from the Structure view context menu, or by pressing Ctrl+A.
•
Pick all visible entities in the Structure view by clicking Pick All Visible on the Structure view toolbar or by choosing Pick
from the Structure view context menu.

> All Visible

• Pick all entities in a rubber band window in the Structure view by clicking and dragging the mouse to define the window.
•
Choose selective pick operations by clicking the Pick Filters button on the Structure view toolbar.
Modification
• To move an entity, on the Structure ribbon in the Entity Modification group, click Transform and choose Translate from the drop-down
menu. Follow the command hint at the bottom of the main window.
• To rotate an entity, on the Structure ribbon in the Entity Modification group, click Transform and choose Rotate from the drop-down
menu. Follow the command hint at the bottom of the main window.
• To scale, reflect, translate face, or array an entity, on the Structure ribbon in the Entity Modification group, click Transform and
choose the desired transformation from the drop-down menu. Follow the command hint at the bottom of the main window.
• To union, subtract, or intersect entities, on the Structure ribbon in the Entity Modification group, click Boolean and choose the
appropriate option from the drop-down menu. Follow the command hint at the bottom of the main window.
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• To fillet or chamfer an edge, on the Structure ribbon in the Entity Modification group, click Blend and choose the desired option
from the drop-down menu. Follow the command hint at the bottom of the main window.
• To simplify an entity by removing specific features from a face such as holes, protrusions, or depressions, on the Structure
ribbon in the Entity Modification group, click Defeature and choose Remove Faces. Follow the command hint at the bottom of the
main window.
Visibility
• Change the visibility of an entity by toggling the light bulb next to the entity in the Browser.

Materials, Boundary Conditions and Excitations
Materials
• Change an entity's material by selecting the entity in the Browser and using the Browser property grid to change the Material
parameter.
• Change the material of multiple entities by selecting multiple entities in the Browser (Shift or Ctrl-click) and using the Browser
property grid to change the Material parameter.
• Create a new material when editing an entity by choosing <New> from the Material drop down box in the property grid.
• Edit a material by selecting the material in the Browser and using the Browser property grid.
• Determine which entities use a material by selecting the material in the Browser. Only entities using that material display as
shaded.
• Hide all entities using a material by locating the material in the Browser and turning off the associated light bulb.
• Delete a material by selecting the material in the Browser and pressing Delete. All entities using the material revert to using Air.
Ports
• Apply a port to a face or edge by clicking New BC/Excitation and choosing Port on the Structure ribbon in the Attributes group.
• Modify port parameters by selecting the material in the Browser and using the Browser property grid.
• Delete a port by selecting the material in the Browser and pressing the Delete key.
Boundary Conditions
• Apply a boundary condition to a face by clicking New BC/Excitation and choosing the desired boundary condition from the
drop-down menu on the Structure ribbon in the Attributes group. Follow the command hint at the bottom of the main window.
• Modify boundary condition parameters by selecting the Material in the Browser and using the Browser property grid.
• Delete a boundary condition by selecting the boundary condition in the Browser and pressing the Delete key.

View Manipulation
Zooming and Scrolling
Hotkey

Description

Hotkey

Mouse wheel

Scroll up and down

Shift+mouse wheel Scroll right and left

Ctrl+Mouse wheel Zoom in (centers on the cursor) and out
Ctrl+Arrow

Rotate camera around rotation center by
amount in Camera Rotation Increment
environment variable.

Description

Arrow

Scroll in direction of arrow

Shift+Arrow

Rotate camera around rotation center by
90-degrees.
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Hotkey

Description

Hotkey

Description

Alt+Left or Right Spin camera around rotation center by
amount in Camera Rotation Increment
Arrow
environment variable.

Variables
A variable is an expression construct that represents a non-constant value. You can use variables in place of numerical values in most
parameters. The value of a variable may hold an expression made up of operators, operands and functions. The operators may be
unary or binary, and the functions can take arguments that may be variables, functions, or numeric expressions. Unit consistency is
enforced in units and parameters.

NOTE: After making changes in the Variables Control you must click the Apply button for the changes to take effect.
When there are pending variable changes, the rest of the 3D Editor user interface is disabled. You must apply or cancel the variable
changes to continue using the 3D Editor.
Creation and Deletion
•
Create a variable by clicking the Add Variable button in the Variables window.
• Create a variable when editing a parameter by entering a new variable in a property grid. The new variable(s) are created
automatically and you are prompted to define them if necessary.
•
Delete a variable by selecting it and then clicking the Delete Variable button in the Variables window.
Functions
The following functions can be performed on scalars.
Math Operation Functions

Function

Function

Function

abs(x)

acos(x)

acosh(x)

asin(x)

asinh(x)

atan(x)

atan2(y, x)

atanh(x)

ceil(x)

cos(x)

cosh(x)

exp(x)

floor(x)

ln(x)

log(x)

max(x, y)

min(x, y)

mod(x, y)

pow(x, exponent)

round(x, sigfigs)

sign(x)

sin(x)

sinh(x)

sqrt(x)

tan(x)

tanh(x)

Type Conversion Functions

Function
complex(real, imag)
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Conditional Functions

Function

Function

if(check, true, false)

assert(conditional expression) or
assert(conditional expression, phrase)

Unit Conversion Functions

Function
stripunit(x) or su(x)
Complex Number Functions

You can use the following complex number functions, where "z" is a complex number.
Function

Function

Function

Function

arg(z)

imag(z)

mag(z)

real(z)

Saving
Click the Application button and choose Save, press Ctrl+S, or choose Save from the Quick Access Toolbar at the top of the application.
Your geometry is exported to NI AWRDE and you can exit the 3D Editor.
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