Go to www.awrcorp.com
Back to search page Click to download printable version of this guide.

2.6. Importing a Project

You can import project items such as schematics, system diagrams, netlists, EM structures, graphs, Switch Lists, symbols, and others into the current (host) project.

To import another project into the current project, choose File > Import Project, then browse for the target project. As shown in the following figure, after you select the project, the Import Project dialog box displays a project tree to allow you to select the project items you want to import.

Items that display in red are conflicted (have the same name in the host project). For conflicted items, you can perform one of the following actions:

NOTES:

The following figure shows the project tree before (left) and after (right) the import specified in the previous figure.

2.6.1. Host and Import Project Differences

When there are differences between the host project and the import project, the following standards are in effect upon project import:

  • If the host project and the import project have different versions of the same PDK, the host project PDK version is used.

  • If the host project and the import project use different units, a warning displays for any schematics that use variables with a link, so you can locate them. Models with intelligent syntax such as W@1 typically do not prompt warnings because they get the correct values from elements connected to them.

  • Differences between the import project and the host project in the following layout options may cause the layout to differ after import:

    • Database unit size (choose Options > Layout Options > Layout tab)

    • Auto face inset (choose Options > Layout Options > Layout tab)

    • Number of points/circle (choose Options > Layout Options > Layout tab)

    • Fixed origin for subcircuits (choose Options > Layout Options > Layout tab)

    • Fixed origin for layout cells (choose Options > Layout Options > Layout tab)

    • Allow pCell's origin to float (choose Options > Layout Options > Layout tab)

    • Draw as polygons (choose Options > Layout Options > Paths tab)

    • Default Model (choose Options > Layout Options > iNet tab)

Legal and Trademark Notice