Go to www.awrcorp.com
Back to search page Click to download printable version of this guide.

Chapter 17. EM: External Solvers

The Cadence® AWR Design Environment® platform supports the automated flow of layout data from AWR Design Environment software into external solvers. Supported solvers include Cadence® Clarity™ 3D Solver, Cadence® Celsius™ Thermal Solver, and other 3rd party EM simulators.

17.1. Configuring External Solvers

Follow the standard installation procedure for installing external software. To connect the AWR Design Environment software to the external simulator:

  1. In the AWR Design Environment platform choose Tools > Configure External EM Solvers to display the Register External EM Solvers dialog box.

  2. Select the desired solver and then click the Register button.

  3. In the following dialog box, select the version of the simulator to which you are connecting, then click OK to close the dialog box.

  4. Click OK to close the Register External EM Solvers dialog box, and restart the AWR Design Environment program.

Only one connection to an external solver is allowed at any time. Repeat the preceding procedure to switch to another version.

To remove the connection to the external software:

  1. In the AWR Design Environment platform choose Tools > Configure External EM Solvers to display the Register External EM Solvers dialog box.

  2. Select the external solver you want to disconnect and then click the Unregister button.

  3. Click Yes in the dialog box that displays to confirm deletion of the external schema.xsd file.

  4. Click OK to close the Register External EM Solvers dialog box and restart the AWR Design Environment program.

17.2. Creating and Simulating Documents

The method for creating and editing EM structures is the same for external solvers as well as Cadence® AWR® AXIEM® 3D planar EM and Cadence® AWR® Analyst™ 3D FEM EM solvers in the AWR Design Environment platform. Geometry simplification rules are also applied to external solver documents. When creating a new EM structure, simply select the external solver as the simulator. You can simulate from the AWR Design Environment platform, and data sets are returned to it.

You can use extraction with external solvers. The general procedure for extraction is detailed in “Extraction Setup Basics”, and the general procedure for 3D EM extraction is detailed in “3D EM Extraction”.

17.2.1. Clarity 3D Solver

The AWR Design Environment platform connection to the Clarity 3D Solver is a limited release feature which enables EM structures created in the AWR Design Environment platform to be simulated with the Clarity 3D Solver, with simulation results returned to the AWR Design Environment platform as simulation data sets.

Creating and simulating with the Clarity 3D Solver is similar to creating an Analyst tool document. The procedure for drawing finite dielectrics and resolving material priority with overlapped shapes is the same for both simulators. See “Drawing Shapes in EM Structures” for details on using the EM Editor.

Geometry simplification using shape pre-processing rules is also supported for the Clarity 3D Solver, and you can use Preview Geometry to visualize the simplified geometry in the AWR Design Environment platform EM Editor. Viewing geometry in the Native Editor is also supported to allow viewing/validating/debugging/post-processing in the Clarity 3D Workbench layout editor.

Simulation data sets are automatically returned to the AWR Design Environment platform and contain S-parameter results, mesh, original input geometry, translated geometry, and simulation logs from the Clarity 3D Solver.

All 3D pCells supported by Analyst 3D FEM EM analysis are also supported by the Clarity 3D Solver.

Ports

The following configurations are not supported:

  • Wave ports

  • Waveguide ports

When converting a document from a solver that supports auto ports to the Clarity 3D Solver, auto ports are converted to lumped ports with explicit ground reference. Group settings (serial/mutual) on ports are ignored. Ports on boundaries are supported.

Hierarchy

The AWR Design Environment platform EM Editor supports using EM subcircuits to create hierarchical EM structures. See “Working with Hierarchy” for details. The Clarity 3D Solver supports EM hierarchical EM structures in the same manner as the Analyst tool does.

Viewing Geometry in Clarity

In the Project Browser, right-click the Clarity EM document and choose Open in Native Editor to view the converted geometry in the Clarity 3D Workbench. This command is used only for viewing geometry before or after simulation. You should not edit the geometry in the Clarity 3D Workbench layout editor as edits are not saved back to the AWR Design Environment platform.

Running the Clarity Solver

Clarity EM structures simulate the same way that Analyst EM structures simulate in the AWR Design Environment platform. After creating or editing a structure, simulate by clicking the Analyze button on the Standard toolbar, or by choosing Simulate > Analyze. Right-click an EM document in the Project Browser and choose Simulate to simulate only the selected document.

Running the Clarity Solver Remotely

Similar to Analyst 3D FEM EM and AXIEM 3D planar EM simulation, remote simulation with the Clarity 3D Solver is supported by the AWR Design Environment Job Scheduler. Real-time status feedback from the Simulation Status dialog box is also supported, and remote simulation via VPN is supported as well. See “Utilizing Remote Computing” for details on how to set up and use the Job Scheduler for remote computing. The Clarity 3D Solver is installed on the remote computer using standard installation procedures. Remote Clarity 3D Solver simulation is only supported for the Windows operating system. Support for the Linux operating system is for future implementation.

17.2.2. Celsius Thermal Solver

The AWR Design Environment platform connection to the Celsius Thermal Solver is a limited release feature which enables EM structures created in the AWR Design Environment platform to be simulated with the Celsius Thermal Solver, with temperature results returned to the AWR Design Environment platform.

The creation of a Celsius Thermal Solver document is similar to creating an Analyst 3D FEM or Clarity 3D Solver EM structure. The Celsius Thermal Solver is listed as a simulator option when creating a new EM document. The Celsius Thermal Solver is also listed as a simulator option on the EM EXTRACT block.

Viewing geometry in the Native Editor is also supported to allow viewing/validating/debugging/post-processing in the Celsius 3D layout editor.

Simulation data sets are automatically returned to the AWR Design Environment platform and contain temperature, mesh, original input geometry, translated geometry, and simulation logs from the Celsius Thermal Solver.

Celsius Setup

The following are additional setup requirements for the Celsius Thermal Solver:

  1. A thermal drawing layer(s) using the "HEAT_" naming convention

  2. A thermal power table to set how much power to apply to the thermal drawing layer(s). The table can be manually added or automatically generated from a simulation.

    • To manually add a thermal power table, add a new text data file. Enter the thermal power table in the data file. Add a row for each unique thermal drawing layer. The first column is the thermal drawing layer name and the second column is the power dissipation in watts. Multiple instances of the same drawing layer name in a layout only need one row for the drawing layer name and power dissipation. If you need a different power level, add another drawing layer.

    • To automatically generate the thermal power table, use the TOT_PWRF output files measurement. Select the Write into Project Data Files check box to write the thermal power table into a data file. The table is generated for one specific frequency and RF power level.

    • Any changes to the thermal power table require a forced re-simulation of the Celsius Thermal Solver EM structure to use the new power values. Right- click the Celsius Thermal Solver EM structure and choose Force Re-simulation.

    • On the Celsius EM Structure Options dialog box Celsius tab, specify the Thermal Power Table name.

  3. A thermal boundary condition for the bottom boundary

    • On the Celsius EM Structure Options dialog box Celsius tab, specify the bottom boundary temperature in C for the BC Temperature.

  4. An (optional) thermal materials properties file.

    • If a thermal materials property file is not specified, the default materials.cmx file that is included with the Celsius Thermal Solver installation is used.

    • When specifying the path to a thermal materials property file, use a relative path if using a PDK or an absolute path to the materials.cmx file. You can specify the path to the local materials.cmx file either on a STACKUP element used to initialize the Celsius EM structure, or directly on the Celsius EM structure itself.

    • To specify the path on the STACKUP element, open the STACKUP Element Options dialog box. On the Parameters tab enter the path to the local materials.cmx file for the ThermalMatProps parameter.

    • To specify the path on the Celsius EM structure, first open the EM schematic. With the Celsius Thermal Solver structure window active, open the EM schematic by either clicking on the View EM Schematic button, or choosing View > Schematic. In the EM schematic, edit the STACKUP element to enter the path to the local materials.cmx file.

Hierarchy

The AWR Design Environment platform EM Editor supports using EM subcircuits to create hierarchical EM structures. See “Working with Hierarchy” for details. The Celsius Thermal Solver supports hierarchical EM structures in the same manner as the Analyst tool and the Clarity 3D Solver do. Utilizing EM hierarchy makes it easy to simulate a chip on package by creating the package in a separate EM structure from the chip EM structure and combining them in a Celsius EM structure.

Running the Celsius Solver

Celsius Thermal Solver structures simulate the same way the Analyst tool EM structures simulate in the AWR Design Environment platform.

To simulate a Celsius Thermal Solver structure after creating or editing the structure:

  1. Click the Analyze button on the Standard toolbar, or

    Choose Simulate > Analyze, or

    Right-click the Celsius EM structure in the Project Browser and choose Simulate to simulate only the selected document. In the dialog box that displays, enter the name for the simulation data set or use the default name.

  2. Right-click the Celsius EM structure in the Project Browser and choose Open in Native Editor. From the Celsius menu, choose Simulation > Operation > Start. After the Celsius simulation is complete, expand the Results node in the Project Browser. Right-click on Field-Plot and choose Field Plot to see the 3D thermal temperature distribution. Select the Structure check box to see temperatures for all of the materials. Click the "X" in the upper right corner to close the Celsius native editor and send all material temperatures to the AWR Design Environment platform.

Running the Celsius Solver Remotely

Remote Celsius simulation is currently not supported by the AWR Design Environment Job Scheduler.

Legal and Trademark Notice