Go to www.awrcorp.com
Back to search page Click to download printable version of this guide.

Version 14.01 Updates

The NI AWR Design EnvironmentTM version 14.01 includes the following new features, enhancements, and user interface changes.

New Examples

  • Conformal_Antenna.emp

API

  • Restored previous API return values for TypeBits for backwards compatibility and added new TypeBits2 to return new values for Polygons, Paths, and Circles.

  • Fixed API events not firing for SchematicElementBeforeRemove and SchematicElementAfterRemove. Note that SchematicElementBeforeRemove does not currently support canceling.

  • The API now reports the correct trace colors for all measurement orderings.

  • Using the API to add a general polygon with a cutout to a schematic layout and then deleting the schematic document from the project no longer causes a potential crash.

Cell Libraries

  • The Artwork Cell Editor no longer crashes after using Edit in Place and then Ascend in Place.

  • Deleting a cell library while in Edit-in-Place mode on a cell from the library no longer potentially causes a crash.

Data Sets

  • Fixed an issue with the pinning of APLAC data sets.

DRC/LVS - Interface

  • DRC error arrows, highlights, and shapes now copy correctly to the Clipboard.

Geometry Simplification (SPP) Rules

  • Improved arc detection of the RESHAPE_CIRCULAR_ARCS_DIVS rule.

  • Improved operation of the RESHAPE_CIRCULAR_ARCS_DIVS rule with arcs that define cutouts with a cutline.

  • In the Simplification Properties dialog box (choose Layout > Copy to EM Structure) the Maximum radius fillets option is now applied independently of the Decimate cutouts option. When both options are selected, Maximum radius fillets simplification is applied before Decimate cutouts.

Graphs

  • Moving a graph marker in an unusual situation no longer potentially causes a crash.

Job Scheduler

  • Remote and/or parallel simulation of circuit schematics is now available as a Beta feature. See Remote and Parallel Circuit Simulation for more information on the capabilities in V14.01.

  • The Job Scheduler now detects version changes in remote hosts to which it is connected. You no longer need to restart the Job Scheduler when remote hosts are updated. This change applies to both user and scheduler nodes.

Layout

  • Fixed issue in iNet Minimal2 via mode that could cause a curved iNet bend to be drawn square if there was an via pin connection vertically above or below it.

  • Improved performance when slicing shapes with the Variable Browser open.

  • Improved the Add Cutlines command in cases where optimal cutlines have non-orthogonal connections.

  • Using coordinate entry to offset vertex when in layout Edit Points mode now gives the correct offset.

  • During iNet route entry on line types with large negative layer offsets, folding the current segment back over the previous no longer results in a crash.

  • Adding cutlines to or removing cutlines from a shape in layout no longer sometimes causes the shape to disappear from subcircuit placements.

Layout - EM

  • EM point ports now have selection priority over its underlying shape and are easier to select.

  • Editing an EM subcircuit that is instantiated multiple times in a parent EM structure no longer causes Analyst to crash.

  • The 3D mesh annotation no longer disappears when using cut planes.

  • The EM_FIELD_CUT annotation now consistently displays direction arrows.

  • The De-embed option no longer disappears from the Port Attributes dialog box when changing the port Type.

  • Cloaked drawing layers such as SPP EM Layers now display in the EM Drawing Layer pane and EM Mapping table.

  • The STACKUP element now displays the correct EM mapping when using an LPF that is named without the .lpf file extension.

Load Pull

  • Contours for multi-tone load pull data can now be graphed properly.

Measurements - Circuit

  • Measurement results now update correctly after modifying a Touchstone file and immediately saving before simulating. Previously, the immediate save operation prevented updates.

Models - System

  • The RF_PID block FBINPTYP parameter now supports real component and imaginary component voltage inputs.

Schematic Editor

  • Customized colors can now be specified for schematic and system diagram symbols.

  • Calculated schematic element parameters can now be hidden/unhidden.

Shape Modifiers

  • The Stretch Area shape modifier now correctly modifies polygon text objects.

Simulation - Analyst

  • Analyst no longer meshes interior edges formed by overlapping thin metal shapes of the same material.

  • Analyst mesh time is now reported correctly on the data set Properties tab.

  • Displaying E-field annotations no longer causes an occasional crash.

  • Analyst simulation with frequency-dependent materials now include a link in the Status Window to a text file which contains a table of material parameter values versus frequency used in the simulation.

  • References to missing EM subcircuits no longer cause Analyst to crash.

Simulation - AWR Connected EM Partners

  • Fixed an issue with the 3D View z-dimension scaling when changing the simulator type of an EM structure to HFSS.

Simulation - APLAC

  • APLAC Transient and Circuit Envelope simulation errors no longer occur with network blocks such as the S2P_BLK.

  • APLAC_PROC blocks that are used by subcircuits and located in a different Global Definitions document than the one referenced by the top level schematic are now netlisted.

Simulation - AXIEM

  • An AXIEM port error no longer occurs when there are multiple ports with extensions touching multiple shapes on different layers.

  • A mesher "extension down does not extend to the same local ground across the entire width of the port" error is no longer incorrectly issued in certain cases of ports over internal ground planes.

Simulation - Extraction

  • Using hierarchical Analyst extractions with extraction ports that specify a de-embedding distance no longer causes a crash.

Simulation - Systems

  • Simulation of NL_F data files that contain both IM_1_2 and IM_2_1 columns with different values is corrected. Sometimes the 3rd order coefficients calculated for the polynomial had the incorrect sign, resulting in incorrect compression.

Symbol Editor

  • Added an implementation for the Edit > Move command in the Symbol Editor.

Tuning, Yield Analysis and Optimization

  • In the Variable Browser, selecting a check box in the Tune column no longer resizes all columns to fit their contents.

  • The Tuner now remembers custom column sorting when it is closed and then re-opened in an AWR Design Environment session.

  • When running an optimization with the Tuner open, the Tuner now restores itself to its previous state after the optimization is complete.

  • Fixed a crash on project close that occurred after selecting Cancel in the Out of Range Warning dialog box that displays when starting the optimizer with the nominal value of an optimized variable set out of the specified range.

User Interface

  • Hovering the mouse over a PDK name in the File > New With Library list now displays the PDF version number in the tooltip displayed at the bottom of the main window.

  • Added support for using X-buttons for Edit in Place descend and ascend.

  • Improved property grid mouse wheel scroll operation when the OS option to scroll inactive windows is enabled.

Wizards - Network Synthesis

  • Multi-selection (Ctrl/Shift-click) in the Parameter Limits grid for constraint editing is now enabled.

  • Clicking the Abort button during synthesis now provides partial results.

PCB Import

  • The shape made by two arc segments in PCB import is no longer missing one of the arcs.

Wizards - Create New Process

  • The MoveUp/MoveDown arrows in the Create New Process tool now function correctly.

Please send email to awr.support@ni.com if you would like to provide feedback on this article. Please make sure to include the article link in the email.

Legal and Trademark Notice