Go to www.awrcorp.com
Back to search page Click to download printable version of this guide.

NI AWR Design Environment Features

The NI AWR Design Environment version 14 software includes the following new features, enhancements, and user interface changes. These changes are common to the Microwave Office, Visual System SimulatorTM (VSS), and Analog Office products.

AWR and Analyst Installer

The AWR and AnalystTM installer, awrde_14_<version_number>_64bit.exe, is the only installer now available. This installer includes the NI AWR Design Environment suite with the Analyst 3D EM simulator and 3D Editor, and the Analyst-MP (Analyst for Multiphysics) software.

Enhanced Data Processing and Display

You can now control multiple measurement data sources and parameters in a single location with variables and DOC_SETS. Easily create presentation-ready Data Reports to more efficiently visualize and interpret simulation results. Create Data Reports using the following new features and enhancements:

Additional Information:

Measurement Variables

Variables can be used to define measurement parameters. You can now edit groups of measurements together by using the same variable. To use the measurement variables, click the Use Vars >> button in the Add/Modify Measurement dialog box. The dialog box expands to show additional measurement parameters. In the Out Eq. Doc option drop-down, select the Output Equation document that is used to define the measurement variables, then select the measurement variable in the drop-down next to the corresponding measurement parameter.

Additional Information:

Document Sets

The concept of a Document Set, which represents a group of simulation documents, is introduced. Adding a measurement on a Document Set is equivalent to adding measurements on all of the individual documents inside the Document Set. Benefits of using measurements on a Document Set include:

  • Comparing the simulation results of all the documents inside the Document Set with one measurement.

  • The ability to change the data source of multiple measurements at once by changing the documents included in the Document Set.

You can define a Document Set using the new DOC_SET element or with a User folder set up as a data source folder.

DOC_SET

To make a measurement on a Document Set, click the Use Vars >> button in the Add/Modify Measurement dialog box. The dialog box expands to show additional measurement parameters. In the Out Eq. Doc option drop-down, select the Output Equation document that is used to define the DOC_SET element. In the Data Source Name option drop-down, select the Document Set defined by the <DOC_SET ID=> naming convention.

Additional Information:

Data Source Group

You can also define a Document Set with a User folder set up as a data source group. The Document Set consists of the documents inside the data source group. To make a measurement on a data source group, select <Folder Name> as the Data Source Name in the Add/Modify Measurement dialog box.

Measurements are automatically generated for each document inside the data source group.

Additional Information:

Window-in-window Insertion and Alignment

Window-in-window data displays are easily created using the new Insert Windows command. This command allows you to select multiple windows for insertion, and specify embedded window size, order, and spacing.

The result of the Insert Windows command is placement of equal-sized Window-in-window objects in an array.

After placement, you can rearrange Window-in-window objects with other objects that support the Draw > Align Shapes and Draw > Make Same Size commands.

Additional Information:

Updated Tuner and Element Options Dialog Boxes

The Tuner and the Element Options dialog boxes are updated with the same property grid format used in the Variable Browser. It is now easier to manage a large list of tuned parameters with a vertical list that you can sort or filter.

You can also sort and filter on primary and secondary element parameters in the new dialog box.

Additional Information:

AntSyn Antenna Synthesis

AntSyn automated antenna design and synthesis improvements include the ability to:

  • Synthesize antennas constrained to an arbitrary user-defined volume.

  • Quickly import synthesized antennas into the NI AWR Design Environment suite for further analysis.

  • Use over 100 new antenna geometries, including new electrically-small antennas and aperture-coupled and compact patches for 5G phased and MIMO arrays.

  • Find the antenna style you want more quickly with filtering and list views.

  • Synthesize high performance antenna arrays with fencing elements and shaped ground planes.

  • Understand antenna performance better before exporting it to the NI AWR Design Environment suite.

Additional Information:

Phased Array Generator Wizard

The new Phased Array Generator wizard lets you quickly put together a planar phased array or MIMO array design, and then generate system diagrams or schematics and an EM structure for simulating the design. The tool lets you interactively specify the layout, feed network settings, element antenna and RF link settings, gain tapers, and element failures.

As you change the design, you can view a 3D approximation of the array antenna pattern to quickly observe the effects of any changes on the antenna pattern.

Additional Information:

Scripting Resources

Additional resources are now available to help developers of Visual Basic scripts in the NI AWR Design Environment suite:

  • The Scripting Landing page in the Knowledge Base has been updated and now includes a new Scripting Getting Started guide.

  • The Sax Basic documentation is now available from the Help menu in the Scripting Editor.

  • The NI AWR Design Environment API Reference is now available from the Help menu in the Scripting Editor.

Minor Improvements

NI AWR Design Environment v14 software includes the following minor new features, enhancements, and user interface changes:

API

  • A new Schematic.TestPoints collection to the API allows access to test point names for a schematic design.

  • Added API access to the layer number and data type values for a GDSII export mapping defined in the LPF.

  • Added API access to layer configurations and simplified access from the layer map table.

  • Rich Text objects on schematics, system diagrams, graphs, and others can now be added, modified, and removed through the API.

  • Use Project.DesignNotes(1).PlainText to get and set the text in the Design Notes window.

  • Add API commands DrawingObjects.AddFilletedPolygon(), DrawingObject.SubObjects.AddFilletedPolygon, and GeomUtil.FilletVertices().

  • Per-shape meshing options can now be set through the API.

  • Added the ThreeDViews collection property as well as a Views collection property directly on the EMStructure object.

  • Added API to access the parent document of a Global Definitions document.

  • Added API access to the Layout Export options "Select Cells To Export As Instances" list.

Data Sets

  • You can now specify the Data Set Directory on the Environment Options dialog box File Locations tab.

Environment

  • You can now set background and grid colors for Global Definition and Output Equation documents.

  • You can customize mouse wheel operation on the new Environment Options dialog box Mouse tab.

Graphs

  • Graph traces can now be set to a custom color using a Color selection dialog box.

  • You can now directly edit a graph title by double-clicking on it.

  • The Simulate for Measurements command is now available in the graph context menu and graph legend context menu for all graph types except 3D Plot.

Output Files

  • The NPORTF output file measurement now writes out frequencies in project frequency units. This change applies to Touchstone, Touchstone V2.0, MDIF, and MATLAB files.

  • You can now generate multiple-frequency antenna pattern data files by selecting Plot all traces in the Sweep Freq drop-down list for AntPat_EF and AntPat_TPwrF output file measurements.

User Interface

  • You can now select/clear all check boxes in a column in the Measurement Editor and Variables Browser dialog boxes by clicking on the check mark symbol in the column header.

  • The width of the Add/Modify Measurement dialog box can now be resized.

  • Saved instances of Wizards can now be duplicated in the Project Browser by either dragging-and-dropping the node, or by right-clicking the node and choosing Duplicate.

Please send email to awr.support@ni.com if you would like to provide feedback on this article. Please make sure to include the article link in the email.

Legal and Trademark Notice