Go to www.awrcorp.com
Back to search page Click to download printable version of this guide.

Migration Issues

The following are issues you need to address when migrating from an AWR Design Environment v14 release to an AWR Design Environment v15 release. Not all topics apply to every user. If you are not familiar with a topic or program feature included here, it probably does not apply to your use of the software. You should read about all of the issues before developing your migration strategy. You can contact with any questions. The path to the <Appdatauser> files referenced in this document is operating system dependent. To view the directory path to your <Appdatauser> files, choose Help > Show Files/Directories to display the Directories dialog box, then double-click the Appdatauser folder.

AWR Design Environment v15 Specific Migration Issues

Licensing Changes

Generalized load pull measurements (measurements beginning with "G_") now require the LPL-100 Advanced Load Pull license feature. See Load Pull Licensing Change in Version 15 for details on enabling this feature.

Operating System

AWR Design Environment v15 software no longer supports Windows 7 and Windows Server 2008 R2 operating systems.

HSPICE

AWR no longer includes HSPICE in future purchases, maintenance renewals, or term deals. If you are using HSPICE, please work with your local Sales team to investigate alternative options.

APLAC

The default value for the Circuit Options dialog box APLAC Sim tab Stability Options > Impedance Points for Stability Envelope option is increased to 360. The previous default of 50 is insufficient in many cases.

Back-Saving to Previous Versions

Measurement Variables

Measurement variables, introduced in AWR Design Environment v14, are not compatible with v13 or earlier versions. Before saving a project as v13, you need to remove measurement variables from measurements.

VSS File-based Nonlinear Amplifier Blocks

The data file format for AMP_F and NL_F is expanded, and the two blocks are now interchangeable. Both blocks are backwards-compatible, but the newly added data file tags are not. When back-saving to an older version of AWR Design Environment software, see the documentation for that version for the correct data file format.

Version-Independent Migration Issues

The items in this section address moving files and settings from one software version to another. Some of these files and settings are automatically migrated. If the previous software version is not found, up to three major versions back are searched. For example, if migrating to AWR Design Environment v15, AWR Design Environment 14, AWR Design Environment v13, and AWR Design Environment v12 software are searched.

NOTE: Ensure that your Windows® Explorer program is set to show hidden and system files.

Files Automatically Migrated

The Appdatauser and Appdatacommon folders must be in their default locations for files or directories to auto-migrate. Changing their default locations would involve creating a redirect.ini file in the program directory, and is not common.

Files in Appdatacommon

The migration of Appdatacommon is triggered based on the existence of the mwoffice.ini file in the Appdatacommon folder for the newly installed version.

  • If there is an existing mwoffice.ini file, no files or folders are migrated.

  • If the mwoffice.ini file does not exist, it is copied from the previous location if found.

  • If the mwoffice.ini file does not exist and an older version is not found, a new file is created.

The path to each PDK is stored in the mwoffice.ini file and is available for any user of that computer. The installation location of foundry libraries is typically version-independent; the default installation locations are not dependent on the AWR Design Environment version. These paths are used when opening a project using a PDK or by choosing File > New with Library.

All additional files and directories at this location are not copied since they should not be used with the new version of the software.

Files in Appdatauser

The migration of Appdatauser is triggered based on the existence of the user.ini file in the Appdatauser folder for the newly installed version. If there is an existing user.ini file, no files/folder are migrated. No existing files or folders are overwritten.

The following files/folders are migrated:

  • All .ini files located at the top level directory of Appdatauser, including user.ini. The user.ini file contains environment settings, custom layout modes, and other environment defaults.

  • All XML files located at the top level directory of Appdatauser. This includes:

    • customizations.xml - contains your hotkey settings.

    • UICustomizations.xml - contains your menu settings. You can reset the menus to the AWR Design Environment v15 defaults.

    • UIDockingLayout.xml - contains settings for how different windows are docked in the AWR Design Environment suite.

    • UIToolBarLayout.xml - contains your toolbar settings. You can reset the toolbars to the AWR Design Environment v15 defaults.

    • materialdefs.xml - There are several pre-set materials such as FR4, alumina, and GaAs available in the EM interface. If you modify these settings, the changes are stored in materialdefs.xml.

  • These directories:

    • scripts - Global (available in any project) Visual Basic scripts.

    • models/model64 - Custom models used in the AWR Design Environment suite.

    • cells/cells64 - Custom cells used in the AWR Design Environment suite.

    • symbols - Custom symbol files created in the AWR Design Environment suite.

    • em_models - User-filled X-model tables.

    • XML - XML libraries installed in the default location.

All additional files and directories in this location are not copied since they should not be used with the new version of the software.

Files NOT Automatically Migrated

License File

TARGET: License Administrators

  • AWR Design Environment v15 software requires a new license file. You can request an updated license file by sending an email to with your company name and a copy of your current license file.

  • Your AWR Design Environment v15 license file is also backwards-compatible to AWR 2006. If you use a floating license server, your lmgrd.exe must be version 11.14.0 or later.

User-Defined XML Libraries

TARGET: Users who have local XML libraries (anything outside of the AWR web library)

  • Many users either choose to install a local copy of the XML libraries or add to the default installation with other vendor-specific XML libraries. The default location is the <Appdatauser> folder. If your XML is in this location it can be migrated automatically (see “Files Automatically Migrated ”).

  • Starting in v11, the correct location for these libraries is :\Users\UserName\AppData\Local\AWR\Design Environment\V11.0\XML. There are top level folders for 3D EM Elements, Circuit Elements and System Blocks. Any XML file located in these top level directories is automatically used in the AWR Design Environment suite WITHOUT the need to edit files in the installation folders.

    The best way to migrate these libraries is to open your current lib.xml and sys_lib.xml files in the Library folder of your old installation and search for any paths you added to this library (perhaps compare with v14). Find those libraries and move the top level XML file to the directory listed above to break the cycle of needing to edit these install XML files.

Other Concerns

Model Compatibility

TARGET: Designers

  • When model changes are identified, the project can use a model compatibility flag. When you open an old project in a newer version of the AWR Design Environment software, the simulation results from the previous version do not change. You can change the model compatibility setting to see simulation results with the old and new model implementation. A dialog box similar to the following displays when you open your design in a newer version if there are models with a compatibility setting in your design.

    You can switch between model versions in the Circuit Options dialog box by choosing Options > Default Circuit Options, then clicking the AWR Sim tab, clicking the Show Secondary button, and then selecting the desired modeling version in Model compatibility version.

Multiple AWR Design Environment Versions

TARGET: AWR software installers

  • Most users keep AWR Design Environment v14 software installed when upgrading to AWR Design Environment v15 to ensure their designs upgrade properly before converting permanently to the latest version.

  • When you install AWR Design Environment v15 software, both versions run. Uninstalling any version may result in registry problems; therefore, when you uninstall, AWR recommends that you also repair your active installation. One way to repair your installation is to open the Control Panel and then click on the Apps group. Under Apps & features, locate your AWR Design Environment installation and select it. Click the Modify button to display a dialog box with options for repairing or uninstalling the software. Select the Repair/Modify option and follow the prompts.

Redirection

TARGET: Users of any type of file redirection (changing the default locations for any of the folders used by the AWR Design Environment suite)

  • In networked environments, some users may choose to change the default location for certain files.

  • Complete information on redirection is available in the Installation Guide under "Configuring Program File Locations". If you use this capability, ensure that you make the same changes in AWR Design Environment v15 software that you set up for AWR Design Environment v14.

Please send email to awr.support@cadence.com if you would like to provide feedback on this article. Please make sure to include the article link in the email.

Legal and Trademark Notice