Go to www.awrcorp.com
Back to search page Click to download printable version of this guide.

3.1. Working With Data Files

You can add new data files to a project, or you can import existing data files for use as subcircuits, or simply link to a data file without importing it. All data files are editable; you can view, edit, delete, rename, and export the files.

3.1.1. Importing Data Files

You can import data files to use as subcircuits in schematics, for comparison purposes, or for any other purpose. (See “Importing Data Files Describing Subcircuits”.)

Imported data files are typically S-parameter files or another type of file that contains frequency domain N-port parameters. For more information on data file formats see “Data File Formats”.

Each data file that you import is represented as a subnode under Data Files in the Project Browser, and exhibits the following naming scheme.

NOTE: The path to the data file displays only after you link to the file.

To import a data file into a project:

  1. If you are adding a raw data file format, you must first set up the proper options for importing the file. Right-click the Data Files node in the Project Browser and choose Options. The Data File Options dialog box displays. Click the Raw Data Format tab to specify the format of the data, then click OK. For more information about this dialog box, see “Data File Options Dialog Box: Raw Data Format Tab ”.

  2. Perform one of the following:

    • Choose Project > Add Data File > Import Data File.

    • Right-click Data Files in the Project Browser, and choose Import Data File to display the Open dialog box.

  3. Select the desired data file, specify the format of the file in Files of Type , and then click Open. The data file displays as a subnode of Data Files in the Project Browser.

You can also import a data file through the Windows Explorer by displaying both the Windows Explorer and NI AWR Design Environment program windows. In the Windows Explorer, click on a data file (for example, a *.s2p file) and drag and drop the file into the open NI AWR Design Environment program window. The file is automatically added to the project. You can import multiple files by pressing the Ctrl or Shift keys while performing this operation. When data files are added to the project using this method, the file extension determines the file format. If the file extension does not correctly indicate the format, you should add the data files by choosing Project > Add Data File > Import Data File as previously described.

A data file must have the proper file extension to be imported as a certain format. You may need to change a file extension to properly import the file. For the required file extension for each format type see the following file format sections.

3.1.2. Linking to Data Files

You can link to a data file instead of importing it. All of the details discussed in “Importing Data Files” apply except for a few items.

  • Choose Project > Add Data File > Link To Data File.

  • Right-click Data Files in the Project Browser, and choose Link To Data File.

The data file is not saved with the project when linked.

You can right-click a linked data file and choose Read Only to toggle on and off read-only properties for the file. When a file is read-only, you can view the file but you cannot edit it.

3.1.3. Adding New Data Files

You can add a new, empty data file to a project by choosing Project > Add Data File > New Data File, or by right-clicking Data Files in the Project Browser and choosing New Data File. You specify the data file type in the New Data File dialog box.

You can copy and paste text into these new files or type in the text.

3.1.4. Editing Data Files

After you add, import, or link to data files you can perform the following operations:

Operation Action
View a data file Double-click the Data Files node in the Project Browser to open the Data File Options dialog box with options for viewing and editing the data file.
Edit a data file You can edit the text in the Data File window using standard Windows editing commands such as Select, Cut, Copy, and Paste. The Data File Editor functions the same as the Windows Notepad. For imported data files, edits are implemented at the next simulation. For linked data files, you must save the data file before the change is effective after simulation. When you edit a linked data file and close the window, you are prompted to save the edits to the file on disk.
Delete a data file Select the Data Files node in the Project Browser and choose Edit > Delete or press the Delete key. You can also right-click Data Files and choose Delete Data File. You are prompted to confirm deletion unless you press the Shift key while choosing Delete Data File.
Rename a data file Right-click the Data Files node and choose Rename Data File.
Close a data file Click the X button at the upper right of the window.
Export a data file Right-click the Data Files node and choose Export Data File. In the Save As dialog box specify the name and location of the exported file.

Please send email to awr.support@ni.com if you would like to provide feedback on this article. Please make sure to include the article link in the email.

Legal and Trademark Notice