Go to www.awrcorp.com
Back to search page Click to download printable version of this guide.

13.10. PCB Import Wizard

The PCB Import Wizard allows you to import 3Di, ODB++, and IPC-2581 standard files into the NI AWR Design Environment software.

13.10.1. IPC-2581 and ODB++ File Import

In addition to importing .3Di files, the PCB Import Wizard can also import IPC-2581 and ODB++ (archived file or unarchived directory) standard files. To use the PCB Import Wizard to import an ODB++ or IPC-2581 file, open the wizard and set the Import Format to the correct standard, then browse to the file using Filename. For more information about this dialog box, see “PCB Import Wizard Dialog Box: Options Tab”.

13.10.1.1. Supported ODB++ and IPC Formats

  • IPC-2581 - supports files conforming to the IPC-2581 (A and B) standard. Common enterprise tools that support this format are Cadence Allegro and Zuken CR-8000.

  • ODB++ (file) - supports files conforming to the ODB++ (V7 and V8) standard. These files are typically produced from Mentor Graphics tools.

  • ODB++ (dir) - same format as ODB++ (file) except it operates on already uncompressed archives.

13.10.1.2. Exporting IPC-2581 from Allegro

When you export from Allegro by choosing File > Export > IPC2581 the Functional Mode must be set to USERDEF for import into the NI AWR Design Environment software.

13.10.1.3. PCB Import Layers Options

After the correct format and file are selected on the Options tab, the import creates a new .lpf file containing the layer definitions that are specific to the imported PCB. If there is more than one STEP in the associated file, a unique .lpf is generated for each. You can view the layers on the PCB Import dialog box Layers tab.

By default, only layers that contribute to the electrical portion of the design are imported. This selection is based on the Type of the layer. For IPC-2581, layers of type "CONDUCTOR", "PLANE", "SIGNAL", "MIXED", and "DRILL" are imported. For ODB++, layers of type "SIGNAL", "POWER_GROUND", "MIXED", "DIELECTRIC", and "DRILL" are imported. Selecting or clearing the Import check box next to the layer name determines whether or not it is imported. Type is for informational purposes, and Negative shows you which layers are negative layers. If you clear the check box, the layer is imported as positive.

All columns can be sorted by clicking the column title to toggle between no sorting, ascending, or descending. You can filter rows in the grid by typing a search string into the cell below the column title. The grid supports multi-selection using Shift + Click for range selection, Ctrl + Click for discontinuous selection, and Ctrl + A to select all cells in a column. See “Using Property Grids” for details on sorting, filtering, and selection within NI AWR Design Environment property grids.

13.10.1.4. PCB Import Nets Options

The Nets tab shows all of the electrical nets specific to the PCB design.

Individual electrical nets are included or excluded from import by selecting or clearing the associated Import column check box. Once selected, pressing the Space bar toggles the state. The grid supports multi-selection using Shift + Click for range selection, Ctrl + Click for discontinuous selection, and Ctrl + A to select all cells in a column. See “Using Property Grids” for details on sorting, filtering, and the selection within NI AWR Design Environment property grids.

13.10.1.5. PCB Import Stackup Options

The Stackup tab displays stackup information found in the design file or synthesized from the file.

Not all files contain accurate stackup layer information like thickness, dielectric constant, or conductivity. If data is not found, N-1 dielectric layers, where N is the number of conductive layers imported, are added between the conductors and default values are used for missing data. All data can be edited, including multi-select editing support. This information is used to create a STACKUP element in the schematic. The STACKUP will have AIR dielectric layers added above and below the core. The thickness of these layers of AIR is equal to 1/4 of the total dielectric thickness of the core. Finally, the top and bottom boundaries are set to approximate opens.

13.10.1.6. PCB EM Setup Tool

The following sections describe the manual steps you can follow using the PCB EM Setup tool to import a PCB, select a region of the PCB, and copy that region to an EM structure. See PCB EM Setup help page for download and use instructions.

13.10.1.7. EM Structure Creation

After the PCB design is imported, you can select net names individually or as a group. All shapes with the same net name are considered to be part of the same electrical net, and the NI AWR Design Environment software can preserve these net names. Currently, net names do not drive connectivity but rather are present to aid selection by name. In a Layout View, choose Edit > Select By Name to display the following dialog box.

Choose one or more nets to select and click OK. Click Preview to zoom/pan to the selected net(s).

Alternatively, you can right-click a shape with a net name and choose Select By Name to select all other shapes with the same net name. This mode also supports multiple selected objects.

After you select the net(s) of interest, you can create an EM Clip Region and copy it to an EM structure.

  1. Select the shapes or clip regions, and choose Layout > Copy to EM Structure.

    The New EM Structure dialog box displays.

  2. Select a simulator and desired Initialization Options, then click Create.

  3. In the Simplification Properties dialog box, select the Decimation Options to apply, and click OK. See “Simplification Properties Dialog Box ” for more information.

13.10.1.8. Trimming with EM Clip Region

EM Clip region allows you to trim a layout to manage its size and complexity for EM simulation. You can apply EM Clip region to only paths and polygon shapes in a schematic or EM layout.

To draw an EM Clip region in a schematic or EM document:

  1. Select one or more shapes and choose Draw > Create EM Clip Region.

    The Create EM Clip Region dialog box displays.

  2. Select Convert Selected to convert a polygon shape to an arbitrary clip region, as shown in the following figures.

  3. Select Bounding Box to draw a rectangular bounding box around the selected shapes. In Offset from Selected, specify the distance of the clip wall from the edge of the selected polygon(s), as shown in the following figures.

  4. Select Bounding Polygon to create a clip region by following the outermost vertices of the polygon with a defined offset.

  5. Select Outlines to joins the individual clip regions around the selected shapes if possible.

13.10.1.9. Clipping Shapes in Schematic Layout and Creating an EM Structure

To create an EM structure from a schematic layout, choose one of the following ways to send the shapes to the EM Structure:

Select shapes only: Select only the shapes and copy them to the EM structure.

Select clip regions only: Select the clip regions only and the resulting shapes are copied to EM structure. You can select more than one clip region.

Select both clip regions and shapes: Select both the clip regions and shapes inside to copy the resulting shapes to the EM structure. Only the selected shapes inside the clip region are clipped.

13.10.1.10. Editing EM Structure with Clip Region

You can trim EM structures by adding clip regions and then performing a simulation of the desired shapes only.

  1. Clip regions in EM structure are drawn as described in “Trimming with EM Clip Region”. Clip regions in EM structures operate in both X-Y and Z planes.

  2. To clip the shape, choose Draw > Modify Shapes > Clip Shapes. You do not need to select a shape or clip area while performing this operation because it accounts for all the clip regions in the EM structure.

  3. If necessary, set the Z dimension of the clip region by selecting the clip region, right-clicking and choosing Shape Properties to display the Properties dialog box. On the Extrusion tab, set the top and bottom Z position as desired. This is helpful when there is a multilayer EM structure but you only want to simulate a few layers.

  4. Preview the EM structure to ensure the desired clipping is performed along with the geometry simplification rules. Preview geometry can be performed without the Clip Shapes operation.

  5. Perform an EM simulation if everything looks as desired.

13.10.1.11. Selecting PCB Pin Ports in an EM Structure

After the EM structure is created, if the copied geometry contained any pads identified as PCB pins, you can change them to EM ports by choosing Draw > Create Ports from PCB Pins. The Select EM Ports dialog box displays to allow you to add EM ports to existing PCB pins.

13.10.2. 3Di Import

Imported 3Di files have a number of benefits:

  • A schematic is created with placeholders for components.

  • A layout is created using iNets to connect component footprints.

  • Drawing layers and colors match the original database.

  • A STACKUP element is created with all available dielectric information from the original database.

  • The output document is ready to use the AWR extraction flow (see EM: Automated Circuit Extraction (ACE)).

The following figures show examples of an imported schematic, layout, drawing layers, and EM STACKUP.

With the proper software license, you can run the PCB Import Wizard after downloading it from the NI AWR website "Download Site" Products tab (www.awrcorp.com/download/login). After installation, to access the wizard, open the Wizards node in the Project Browser and double-click PCB Import. The PCB Import - Options dialog box displays.

To import a .3Di file, set the Import Format to 3DI and browse to the file using Filename. For more information about this dialog box, see “PCB Import Wizard Dialog Box: Options Tab”.

The following figures show commonly selected options.

Example circuit and layout with Highlight selected nets selected:

Example of whole component outlines, with Package Outlines selected:

13.10.3. Dielectric and Conductor Information

The imported STACKUP has the dielectric and conductor information from the original database. You should verify these numbers for accuracy. The following figure shows the STACKUP material definitions.

The following figure shows the STACKUP materials.

13.10.4. EM Boundaries

The imported STACKUP always has Approx Open set for both the top and bottom boundaries. You should verify this setting. The following figure shows the STACKUP boundaries.

13.10.5. Using ACE

If you are using Automated Circuit Extraction (ACE), you should define the location of ground planes for conductor layers on the Element Options: STACKUP dialog box Line Type tab.

13.10.6. Schematic Components

The schematic created in the NI AWR Design Environment software has the correct connectivity, but the actual components are unknown. To properly simulate the design you must add the component models to the subcircuits that are created. As a place holder, the model subcircuits simply contain PORT and LOAD elements. The following figure shows a schematic instance.

The following figure shows a default schematic instance model.

13.10.7. Adding Stimulus

Commonly, you must add another node to the schematic subcircuit that represents the circuit stimulus (this is not necessary if the stimulus is a fully contained SPICE netlist file). The following figure shows a simple example circuit.

You can achieve this setup by modifying the top level subcircuits as shown in the following figures. Note that the third port added to the stimulus circuit appears as an additional pin on the top level schematic, which allows any desired voltage or current sources to be applied. The following figures show the stimulus circuit, receiver circuit, and the new top level schematic.

13.10.8. Extraction

The following sections include information about layout shapes and extraction ports.

13.10.8.1. Layout Only Shapes

You can use any available EM simulator to simulate the .3Di layout shapes imported by the PCB Import Wizard. By default, layout shapes associated with nets on the schematic (iNets) are sent to the EM document. To add other shapes to the EM simulation (such as ground planes) simply select the shapes in the layout, right-click and choose Shape Properties, select the Enable check box under Em Extraction Options, and ensure that the Group name matches the Name parameter on the EXTRACT block on the schematic (the default value after import is "EM_Extract").

13.10.8.2. Ports

NI AWR Design Environment EM engines support a variety of port types. See “Extraction Ports” for information on setting up and selecting the appropriate extraction ports.

13.10.8.3. EM Pin Locations

During extraction, ports are placed on the primary face of area pins. Because pins in PCB tools are points (usually in the center of the footprint geometry) the PCB Import Wizard does not have sufficient information to put the primary face anywhere but the first footprint geometry edge that is drawn. This can result in EM pins placed in less than ideal locations during extraction. The following figure shows the default EM pin placement.

You can correct this by editing the appropriate component footprint and moving the primary face from the default location to the desired location. In the previous example, the primary face needs to be relocated from the "top" of the footprint geometry to the "bottom" of the footprint geometry. The following figure shows the original primary face location.

The following figure shows the modified primary face location.

As shown in the following figure, the extraction pins are now in the correct location.

13.10.9. Errors and Warnings

Errors and warnings from the PCB Import Wizard display in the Status Window. If the Status Window is not open, you should open it after importing to check the contents.

13.10.10. Solder Balls and Bumps

Contact NI AWR Technical Support for more information about importing and simulating solder balls and bumps using the PCB Import Wizard.

Please send email to awr.support@ni.com if you would like to provide feedback on this article. Please make sure to include the article link in the email.

Legal and Trademark Notice