Go to www.awrcorp.com
Back to search page Click to download printable version of this guide.

2.2. Working With Projects

In the AWR Design Environment platform, you use projects to organize and manage related designs in a tree-like structure.

A project encompasses any desired set of designs and can include one or more schematics, netlists, EM structures, data files, or system diagrams. A project also includes anything associated with the designs, such as imported files, layout views, graphs, output files, and data sets. When you save a project, everything associated with it is automatically saved as well. AWR Design Environment platform projects are saved as *.emp files.

After you create a project, you can create your designs. In the AWR Microwave Office design suite you can generate layout representations of these designs, and output the layout to a DXF, GDSII, Gerber, or PADs file. You can perform simulations to analyze the designs and see the results on a variety of graphical forms that you specify. Then, you can tune or optimize parameter values and variables as needed to achieve the response you want. Since all parts of the AWR Microwave Office program are fully integrated, your modifications are automatically reflected in both the schematic and the layout representation.

2.2.1. Using the Project Browser

The Project Browser (located on the left side of the main window when docked) is active when you click or hover the cursor over the Project tab along the edge of the main window. The Project Browser is always active when the program starts, and contains the entire collection of data that defines the current project, including schematics, system diagrams, EM structures, graphs, and others. This data is organized in a tree-like structure of items, as shown in the following figure.

2.2.1.1. Project Browser Contents

The Project Browser contains the following nodes:

Item Description
Design Notes Displays a rich text editor in which you can make design-related notes.
Project Options Allows you to specify default frequencies used for project simulations, default schematic/diagram display options, default global units, interpolation/passivity defaults, and yield options.
Global Definitions Allows you to define, import, embed, link, and export global variables and/or functions to be used as parameter values in schematics created within a project. You can also add substrate materials to this node and reference them from any schematic. For more information, see Variables And Equations.
Data Files Allows you to import data files for use as subcircuits in schematics (typically S-parameter data) or for use in equations to retrieve row or column data from the file. The imported data files display as subnodes under Data Files. Data files imported for use as subcircuits can be Touchstone or MDIF (classical and generalized) format or raw data files. These files can also be directly used as the data source of a measurement. For example, you may import a two-port Touchstone file and create an S(2,1) measurement that uses it without first instantiating the data file as a subcircuit in a schematic. Also allows you to import data files to be used for performance comparison purposes. Data files imported for comparison purposes can be DC-IV format, text data or raw data files. (DC-IV is a AWR Microwave Office format for reading DC-IV curves that measure a transistor or diode.) For more information, see “Importing Data Files”.
System Diagrams Allows you to create system diagrams within a project. These diagrams display as subnodes under System Diagrams. For more information, see Schematics and System Diagrams.
Circuit Schematics Allows you to create circuit schematics and netlists within a project. These schematics and netlists display as subnodes under Circuit Schematics. For more information, see Schematics and System Diagrams and Netlists.
Netlists Allows you to create netlists within a project. These netlists display as subnodes under Netlists. For more information, see Netlists.
EM Structures Allows you to create EM structures within a project. These structures display as subnodes under EM Structures. For more information, see “Creating EM Structures without Extraction”.
Output Equations Allows you to specify equations used to post-process measurement data prior to displaying it in tabular or graphical form. For more information, see “Using Output Equations”.
Graphs Allows you to create graphs to display the output of simulations performed within a project. Graphs display as subnodes under Graphs. You can create the following graph types: rectangular, Smith Chart, polar grid, histogram, antenna plot, tabular, constellation, and 3D. For more information, see Graphs, Measurements, and Output Files.
Optimizer Goals Allows you to specify optimization goals for a project. The goals display as subnodes under Optimizer Goals. For more information, see “Optimization”.
Yield Goals Allows you to specify yield goals for a project. The goals display as subnodes under Yield Goals. For more information, see “Yield Analysis”.
Output Files Allows you to specify output files to contain the output of simulations performed within a project, as an alternative to graphical output. The output files display as subnodes of Output Files. Output files can be Touchstone format (S, Y, or Z-parameters, for circuit and EM simulations), SPICE Extraction files (for EM simulations), AM to AM, AM to PM, or AM to AM/PM files (for nonlinear circuit simulations), spectrum data files (for nonlinear circuit simulations), or antenna pattern files (for EM simulations). For more information, see “Working with Output Files ”.
Data Sets Allows you to view and edit data sets in the project. Data sets are saved simulation results. See the Data Sets chapter for more information.
Circuit Symbols Allows you to view, edit, and create custom circuit element and system block symbols that are stored in the project. See the Circuit Symbols chapter for more information.
Simulation Filters Allows you to view, edit, and create simulation filters. Simulation filters give you control over what types of simulations are performed when you choose Simulate > Analyze. See “Simulation Filters” for more information.
Switch Lists Allows you to view, edit, and create Switch Lists. A Switch List is a named list of switch views that a measurement can use to dynamically alter the schematic hierarchy. See “Switch View Concepts ” for more information.
Wizards Allows you to run AWR- or externally-authored wizards that add advanced functionality to the AWR Design Environment platform. The wizards display as subnodes under Wizards. For more information, see Wizards.
User Folders Allows you to create your own folder structure. At any folder level, you can add any of the previously listed objects to custom organize your folders. For more information, see “User Folders”.

2.2.1.2. Expanding and Collapsing Nodes

To expand a node in the Project Browser, do one of the following:

  • Shift-right-click the node, and choose Expand All, or

  • Click the + symbol to the left of the node.

To collapse a node in the Project Browser, do one of the following:

  • Shift-right-click the node, and choose Collapse All, or

  • Click the - symbol to the left of the node.

2.2.1.3. Speed Menus

To access speed menus from Project Browser nodes, simply right-click the node. You can access the most commonly used commands from speed menus, such as Options (properties), Rename, or Delete.

Not all commands are shown on the default speed menu. To access the full list of commands, Shift-right-click the node to view a full list.

The following figure shows an example of the difference between the simplified speed menu and the full speed menu for schematics.

2.2.1.4. Copying Project Items

To copy project items such as schematics, system diagrams, netlists, EM structures, text data files, and others, select the item node in the Project Browser and drag and drop it on the target project node. For example, to copy a schematic, drag the individual schematic node to the Circuit Schematics node in the Project Browser. A subnode named "schematicname_1" is created for the first copy. The object name is incremented by one (_2, _3 and so on) for each additional copy. After the new item is created, the name is directly editable.

You can also copy project items by right-clicking the item in the Project Browser and choosing Duplicate (the default hotkey is Ctrl+D). The naming operation is identical to the drag and drop copy method.

Measurements are not copied in this manner as you do not control a measurement name. See “Copying Measurements” for more details.

2.2.1.5. Renaming Project Items

To rename project items such as schematics, system diagrams, netlists, EM structures, text data files and others, right-click the item in the Project Browser and choose Rename , or press the F2 key. A Rename dialog box displays for entering the new name and includes a 'Synchronize' option (if applicable) that propagates the name change throughout the project. If you press Shift+F2 the item name is directly editable in the Project Browser without prompting from the Rename dialog box ('Synchronize' defaults to selected in this mode).

2.2.1.6. Deleting Project Items

To delete project items such as schematics, system diagrams, netlists, EM structures, text data files, and others, right-click the item in the Project Browser and choose Delete . A dialog box displays confirming that you want to delete this item. Deleting an item cannot be undone. You can also select the item and press the Del key for the same behavior. If you press Shift+Del the item is deleted without the confirmation dialog. The next item in the list is selected after an item is deleted. This means you can use the Shift+Del many times in a row to quickly delete many items for a specific type.

2.2.1.7. Accessing Submenus

To access a menu of relevant commands for a node, right-click the node in the Project Browser. An extended menu is often available by pressing Shift-right-click.

2.2.1.8. Scrolling in Windows

You can use your mouse scroll wheel/button in the AWR Design Environment platform windows in three scrolling modes:

  • Standard: scrolling pans vertically

  • Shift+scroll: scrolling pans horizontally

  • Ctrl+scroll: scrolling zooms the display in and out

2.2.2. Creating, Opening, and Saving a Project

Creating a project is the first step toward building and simulating your designs.

When you start the program, a default empty project ("Untitled Project") opens. Only one project can be open at a time, although you can run more than one instance of the program. The name of the open project displays in the title bar.

To create a new project, choose File > New Project. Name the new project by choosing File > Save Project As. The project name displays in the title bar.

To create a new project with a foundry library, choose File > New with Library , then choose Browse to locate the *.ini file for a specific foundry. The name of the foundry displays in the title bar. For more information about using foundry libraries see “Working With Foundry Libraries”.

To open an existing project, choose File > Open Project or File > More Projects to display the Open Project dialog box. When you start typing, the list is immediately filtered to display only those projects that match the text you type. You can filter the list by project name, use frequency (rank), date of last file opening, or file path.

To clear the current project from view, choose File > Close Project. You are prompted to save your changes, and the project is saved (if specified) and closed.

To save the current project, choose File > Save Project. The file is automatically compressed using a compression algorithm and saved as an *.emp file.

2.2.2.1. Opening Example Projects

AWR software provides a number of project examples (*.emp files) in the C:\Program Files\AWR\AWRDE\16\Examples or C:\Program Files (x86)\AWR\AWRDE\16\Examples directory to demonstrate key concepts, program functions and features, and show use of specific elements. You can filter project examples by keyword or search for an example by file name. A funnel icon in the column header indicates the column on which your search is filtered.

To search for and open a specific example project:

  1. Choose File > Open Example.

    The Open Example Project dialog box displays with columns for the project name and keywords associated with each example project.

  2. To filter the list by name, Ctrl-click the Name column header and begin typing an example project name in the text box at the bottom of the dialog box.

    The example list is filtered to display only those projects that match your input, or

  3. To filter the list using a keyword, Ctrl-click the Keywords column header and begin typing a keyword in the text box at the bottom of the dialog box.

    The example list is filtered to display only those projects that have the input keyword associated with them.

    For example, to list all example projects that include the keyword "modulation", Ctrl-click the Keywords column header if necessary and type "modulation". The list of project examples is filtered to display only those having the "modulation" keyword associated with them.

Filtering Examples

The Open Example Project dialog box filtering capability is quite powerful. The following are some tips for entering filters:

  • Type part of a keyword and watch the matches filter as you type.

  • Type part or all of a keyword, use a space and then type another word to filter both words. For example, if you type "mwo mixer" all the mixer examples for the AWR Microwave Office program are listed.

  • Use the "video" keyword to see all available videos.

  • Use the "new" keyword to see all examples that are new or have new functionality added. Typing "new mwo" lists all new AWR Microwave Office examples, and "new vss" lists all new VSS examples.

  • Use the "mwo", "vss", or "ao" keywords to filter by products.

  • Use the "install" keyword to see all examples in the program installation. Use the "web" keyword to see all examples in the Cadence AWR Knowledge Base.

  • Use the "design_guide" keyword to see all examples set up as design guides or measurement templates.

  • Use the "model_tester" keyword to see all examples set up to help you characterize specific types of models.

  • Each example has additional keywords added. These keywords include simulator types (such as Cadence® AWR® AXIEM® 3D planar EM or Cadence® AWR® APLAC® HB), design types (such as amplifier or mixer), the unique measurements used in the example, and the unique models used in the example. For example, to locate examples that use a BIASTEE model, type "BIASTEE" to list all the examples.

For more information on this dialog box see “Open Example Project Dialog Box ”.

2.2.2.2. Autosaving Projects

To automatically save your project and create backup files at set intervals:

  1. Choose Options > Environment Options.

  2. In the Environment Options dialog box, click the Project tab and select the Autosave check box.

  3. Specify in Minutes how frequently you want to save your project.

The Autosave feature creates a backup file with an .autobackup.emp extension in the project file directory. Autosave automatically restores a project from the backup file if it detects that a project file closed without specifying Yes or No to the prompt to save it.

You can also select the Save before Simulating check box to automatically save your projects before simulations.

2.2.2.3. Saving Project Versions

To automatically save multiple versions of your project:

  1. Choose Options > Environment Options.

  2. In the Environment Options dialog box, click the Project tab and select the Save revisions check box.

  3. Specify in Previous versions the number of project versions you want to retain.

This feature allows you to save up to nine versions of your project on disk; one each time you save a project. Each successive version is saved with a file extension that represents its currency. For example, when my_circuit.emp is the current version, my_circuit.emp.bk1 is the previous version, my_circuit.emp.bk2 is the version saved before it, and so on.

2.2.3. Displaying Document Windows

When you create a design in the AWR Design Environment platform, you create different types of documents such as schematics, layouts, and graphs. Each of these document types displays in its own window. You can double-click the item in the Project Browser to open its window. There are two types of windows:

  • Multiple Document Interface (MDI) window: This window displays completely within the AWR Design Environment platform main window and is the default window type.

  • Floating window: This window displays anywhere on the current computer display, including multiple monitors.

2.2.3.1. Multiple Document Interface (MDI) Windows

Document windows open as MDI windows by default, as shown in the following figure.

MDI windows have the following features:

  • Controls on the upper right of the window title bar to minimize, maximize, or close the window.

  • An icon on the upper left of the window title bar that indicates the document type. This icon can be double-clicked to close the window.

  • A double-click of the title bar maximizes the window.

  • A tab for each open MDI window displays at the top of the main AWR Design Environment platform window, as shown in the following figure. Tabs show at a glance all open windows and allow you to bring to the front any window that may be hidden behind other open windows.

    When you click on a tab to display the associated window, an "X" displays on the tab to allow you to close that window.

  • At the far right side of the tabbed toolbar there are two additional controls. Click the "down arrow" for a list of all open windows, as shown in the following figure.

    Click the X at the far right to close the currently active window.

  • Pressing the Ctrl + Tab keys cycles through all open windows. Pressing Shift + Ctrl + Tab keys cycles in reverse order.

  • The Window menu Cascade, Tile Vertical and Tile Horizontal display commands apply to MDI windows only.

  • Minimized MDI window title bars display near the bottom of the AWR Design Environment platform main window, as shown in the following figure.

  • Choosing Window > Arrange Icons reorganizes any minimized MDI windows. The following figure shows the minimized window title bars from the previous image rearranged.

  • All of the commands in the Windows dialog box apply to MDI windows (to access this dialog box choose Window > Windows).

2.2.3.2. Floating Windows

You can change an MDI window to a floating window by right-clicking its title bar and choosing Floating, as shown in the following figure. To toggle back to an MDI window, repeat this action.

Alternatively, you can press the Ctrl key and double-click the window title bar to toggle between the MDI window state and floating window state. When switching between window states, the size and location of the window when it was last in that state is restored.

NOTE: Artwork cell windows are not restored to their previous size or MDI/floating state when you reopen them.

Floating windows have the following features:

  • Double-click the window's title bar to toggle between full screen and the previous size. If you press the ALT key while double-clicking the title bar in the center, the window is maximized. Double-click to the left of center to place the window on the left half of the screen, or double-click to the right of center to place the window on the right half of the screen.

  • They always display on top of the main screen.

  • Size and location are remembered when shutting down and reopening the program.

  • Close the window by clicking the X icon in the upper right corner.

  • When using the cascade or tiling commands (including commands in the Windows dialog box accessible by choosing Window > Windows), floating windows retain their current size and location.

  • They hide when the main AWR Design Environment platform window is minimized.

  • When changing the number of monitors in use (such as switching from two monitors to one monitor), the next time the floating window opens it is in the visible current display. You may need to first close the window from the Windows dialog box and then reopen the window.

  • Right-click the window title bar to view options and hotkeys for resizing the window to full screen, or to the left, right, top, or bottom of the screen.

2.2.3.3. Windows Dialog Box

You can access the Windows dialog box by choosing Window > Windows, as shown in the following figure.

The Windows dialog box includes the following features:

  • Clicking on either column header sorts by that column.

  • Pressing the Ctrl key and clicking on multiple items selects those items.

  • Clicking the command buttons on the right performs that operation for the selected windows.

  • Floating windows only respond to the Show and Close Window(s) buttons.

2.2.3.4. Open Project Item

In large projects, it can be difficult to locate specific project items in the Project Browser.

To open a specific project item (for example, a schematic, system diagram, data file, or output equation), Shift-right-click anywhere in the Project Browser and choose Open Project Item. An Open Project Item dialog box displays with a list of items included in the project.

Select the item you want to open and click OK.

The Open Project Item dialog box includes the following features:

  • Clicking on either column header sorts by that column.

  • Typing in the text field at the bottom of the dialog box filters the display based on your text.

  • Ctrl-clicking a column header changes which column's text is used to filter.

  • Ctrl-clicking multiple items selects those items. Shift-clicking selects a range of items.

2.2.4. .vin files

When you close a project, a .vin file with the same stem name as the project file is created. The .vin file contains information about which windows are open, including their size and location. It also contains information about the collapsed and expanded state of the Project Browser. When a project that has an accompanying .vin file is opened, the project interface set up when the project was closed is restored. If a .vin file does not exist, when a project is loaded no windows are opened and the entire design hierarchy in the Project Browser is expanded.

2.2.5. Saving Projects As Project Templates

The AWR Design Environment platform allows you to save any project as a project template.

A project template is essentially a project that is saved with its options, LPFs, artwork cells, design notes, global definitions, frequency, graph, and measurement information, but not its simulated documents (for example, EM structures, data files, netlists, system diagrams or schematics, or single source measurements). Project templates provide an easy method for specifying sets of graphs, measurements, and outputs that are independent of any schematics, EM structures or data files. This information can be used in other projects or to perform comparisons between various data files. Project templates also include all the options and format information for a project. When a project template is opened, the graphs, measurements, options and outputs associated with that project template are read into the project.

To save a project as a project template, choose File > Save As, and select Project Template (*.emt) from the Save as type drop-down list. The project template is saved as an *.emt file.

To specify a path to a project template choose Options > Environment Options and click the File Locations tab. In Default Project Template, browse to the location of the desired template. Every time you open a new project, the designated template is used.

For examples of using project templates, see “Using Project Templates with Template Measurements”.

2.2.6. Specifying Global Project Settings

All options accessible under the Options menu apply per project, except for Environment Options, which apply to all projects under the current user. Options prefaced with "Default" can be overridden on each type document (for example, circuit schematic or graph). The remaining sections discuss details of several common settings to consider.

You can specify global settings for the units used within all schematics in a project, and for the simulation frequency used by all simulations performed within a project. In addition, you can specify global interpolation settings to employ during simulations.

2.2.6.1. Configuring Project Units

When running the AWR Design Environment software with the Layout feature license, units are configured per-LPF:

  1. Choose Options > Drawing Layers. The Select LPF file dialog box displays.

  2. Select the desired LPF, then click OK to display the LPF Options dialog box.

  3. Under the General folder in the left pane, click Units and specify the desired units, then click OK.

When running the AWR Design Environment software without the Layout feature license, global units are configured for the project:

  1. Choose Options > Project Options to display the Project Options dialog box.

  2. Click the Global Units tab.

  3. Select the desired units for each item, then click OK. Note that you can choose to set all items to use base units by clicking the Use Base Units button.

2.2.6.2. Configuring Global Project Frequency

To modify global project frequencies:

  1. Choose Options > Project Options. The Project Options dialog box displays. Click the Frequencies tab to specify global frequency values. See “Project Options Dialog Box: Frequencies Tab ” for more information about the dialog box.

  2. To specify a frequency sweep, enter values for Start, Stop, and Step. To specify a frequency point, select the Single Point check box, and enter a Point value.

  3. Click Apply and then OK.

You can always override global project frequency settings for a particular schematic, system diagram, netlist, or EM structure by specifying a local frequency. You do this in the Project Browser by right-clicking the individual schematic, netlist, or EM structure, choosing Options, and then deselecting the Use Project Defaults check box on the Frequencies tab.

2.2.6.3. Configuring Global Interpolation Settings

To modify the global interpolation settings:

  1. Choose Options > Project Options. The Project Options dialog box displays. Click the Interpolation/Passivity tab to specify global interpolation settings. The Project Options dialog box displays. See “Project Options Dialog Box: Interpolation/Passivity Tab ” for more information about the dialog box.

  2. Modify the settings as desired, and click OK.

2.2.7. Working With Foundry Libraries

Often the AWR Design Environment software is used with Process Design Kits (PDKs) from various foundries. See the Cadence website for available foundries, or contact your local sales manager.

AWR Design Environment platform projects store the name of the process library with the project, so when the project is opened, the library is loaded with the project and the library name displays in the program title bar. If the current PDK .ini file is missing, you are prompted to browse for a replacement.

2.2.7.1. Adding and Removing Process Libraries

You can create a new project with a process library by choosing File > New With Library. A list of previously used libraries displays, as well as a Browse option to allow you to locate a foundry *.ini file on your computer, and an AWR Example Libraries option that provides a selection of sample libraries for Silicon, GaAs and PCB technologies.

Choose File > New with Library > Purge to remove libraries with invalid file paths from the list of available libraries, or you can also manually add or remove process library references by choosing Project > Process Library > Add/Remove Library. An Add/Remove Process Library dialog box displays with the name and path to the *.ini file for all the foundry libraries stored for your project. You can have more than one process library loaded at once. You would use this method if:

  • You started a project without a process library and need to use the process library models, layouts, or other.

  • You are migrating from one version of a library to another.

  • You did design work with multiple process design kits.

When manually adding a PDK to a project, the LPFs, Global Definitions documents, and Artwork Cell Libraries from the new PDK are imported into the project. If layout options of the new PDK do not match existing layout options in the project, a Layout Options Mismatch Warning dialog box displays with a list of the mismatched options. You should understand the implications of changing layout options for the added PDK. See “Layout Options Dialog Box: Layout Tab ” for details.

The PDK .ini file also allows you to reference other PDK .ini files. This is useful if you want to reference one file but use all the information from various PDKs, as common in multi-technology designs. The general structure of a PDK .ini file for this format is:

[Foundry]
Name=Sample Project PDK
Description=My multipdk 
Version=1.0.0.0
 
[Child Libraries]
C:\Program Files (x86)\AWR\Foundry\Foundry1\Process1\1.0.1.0\process1.ini
C:\Program Files (x86)\AWR\Foundry\Foundry1\Process1\1.0.2.0\process2.ini
C:\Program Files (x86)\AWR\Foundry\Foundry2\Process1\1.1.0.0\process1.ini
    

2.2.7.2. Using Multiple PDKs and Multiple Versions of a PDK

When you add a new schematic to a project that has more than one process library loaded, the New Schematic dialog box allows you to choose which library to associate with the schematic. The library name and version (if there are multiple versions loaded) display in the title bar of the schematic. The associated PDK name and version display under Process Library on the “Options Dialog Box: Schematic Tab”. You cannot modify the PDK name once a library is associated with the schematic. You can change the library Version using the pull-down list, and if the LPF and Global Definitions settings are synchronized with the initial library version setting, they auto-update when the PDK version changes. The PDK displayed in the schematic options is the primary library used by the schematic. Electrical models from other process libraries can be used in the schematic, but if two libraries loaded in the project contain a model with the same name, the schematic uses the one defined in its primary library. The same applies to layout cells used in the layout associated with the schematic, and to schematic symbols—preference is given to cells and symbols defined in the primary process library.

The AWR Design Environment platform does not prevent the schematic from using elements from other libraries. You can freely copy and paste elements between schematics, regardless of library association. The one restriction is that you cannot drag from the Elements Browser an element from a particular version of a library onto a schematic that is associated with another version of the library. Similarly, the Replace Selected Element command will not replace an element in a schematic associated with one version of a library with an element from another version of the same library.

Normally when a project that uses a process library is opened, the AWR Design Environment platform checks to see if there is a newer version of the library available and asks whether to switch to the newer one. However, if a project uses multiple versions of a library, then this check is not performed. The AWR Design Environment platform will continue to use whichever versions the project calls for. You can manually change the versions through the Add/Remove Process Library dialog box.

Legal and Trademark Notice