Go to www.awrcorp.com
Back to search page Click to download printable version of this guide.

4.5. Working with Elements on a Schematic

This section includes information on how to add elements to a schematic, how to manipulate elements on a schematic, and how to edit or use variables and equations for element parameters. Information about both Schematic and Layout Views is also included.

4.5.1. Adding Elements Using the Elements Browser

The Elements Browser allows you to browse through a comprehensive database of hierarchical groups of electrical entities such as lumped elements or microstrips, and select the desired model to include in your schematics.

For a complete description of all the elements in the Elements Browser, see the AWR Microwave Office Element Catalog. For a description of the XML Libraries, see Appendix A, Component Libraries. For special notes regarding microstrip iCells, linear models for transmission line systems, and EM-based discontinuity models, see Appendix A, Supplemental Model Information. The following figure shows the Elements Browser.

To add an element to a schematic:

  1. Click the Elements tab on the main window to display the Element Browser.

  2. If necessary, double-click Circuit Elements to open the group. Click the + and - symbols to expand and contract the groups of elements, and click the desired subgroup, such as Active or Passive. The available models display in the lower window pane.

  3. To place a desired model, click and drag it into the schematic window, release the mouse button, position the element, and click to place it. When positioning the element right-click to rotate it, Shift+right-click to flip it horizontally, and Ctrl+right-click to flip it vertically.

You can also copy element information to another instance of the AWR Microwave Office software by selecting the element and choosing Edit > Copy. In the Project Browser of the second application, select the target and then choose Edit > Paste.

To add a shape to a schematic, choose the desired shape from the Draw menu and then click in the schematic window to begin drawing the shape. For information on drawing shapes, see “Schematic/EM Layout Draw Tools ”.

4.5.2. Adding Elements Using the Add Element Command

The Add Element command allows you to add elements from a list dialog box that supports filtering by element name, description, or library path. In a Schematic View, choose Draw > More Elements, press Ctrl + L, or click the Element button on the Schematic Design toolbar to display the Add Circuit Element dialog box.

The Add Circuit Element dialog box provides several ways to filter elements:

  • To filter the list by name, Ctrl-click the Name column header and begin typing an element name in the text box at the bottom of the dialog box.

    The element list is filtered to display only those elements that match your input.

  • To filter the list by description, Ctrl-click the Description column header and begin typing a description in the text box at the bottom of the dialog box.

    The element list is filtered to display only those elements whose description includes the typed text.

    You can type more than one match word. For example, typing micro bend when matching on the Description column displays only microstrip bend elements.

  • To filter the list by path, Ctrl-click the Path column header and begin typing a directory path in the text box at the bottom of the dialog box.

    The element list is filtered to display only those elements whose directory path includes the typed text.

Click a column header to sort by that column. Click again to reverse the sort order for that column.

After filtering to find the desired element, select the element and click OK to add the element to the active schematic.

If you work with Process Design Kits (PDKs), this dialog box includes elements available in the PDK you are using. You can easily filter to show only parts from that PDK. Typically, all PDK models begin with the foundry name, so you can filter by foundry name after selecting the Name column. You can also filter by the Path column and use Libraries as the filter.

Unless you install a local copy of the web libraries (available as a download from the Cadence website), this dialog box does not display parts available in the Libraries > *AWR web site category of the Elements Browser.

4.5.3. Moving, Rotating, Flipping, and Mirroring Elements

To move an element in the schematic, click the element then drag it to a new position, as shown in the following figures.

Connection wires are automatically added to keep the element connected, as shown in the following figure. If the element already has connecting wires, the wires stretch. If wires are stretched such that the wire segments fall on top of other nodes in the circuit, the wires connect to those nodes also (they exhibit "sticky" behavior).

If you press the Ctrl key while moving the element, no connecting wires are added, as shown in following figure. If there are already connecting wires on the element, pressing the Ctrl key while moving the element removes the wire connections.

If you press the Shift key while moving the element, the movement is restricted to only horizontal or vertical from the original location.

You can rotate or flip elements by selecting the element, right-clicking, and choosing Rotate or Flip. When elements are rotated or flipped, the wire connections are automatically broken unless the node points of the rotated or flipped element end up at the same location as the original element, as shown in the following figure. For instance, a two-node element can be reversed by starting the rotate command, clicking on the midpoint between the two nodes, and then dragging the mouse to rotate the element 180-degrees. The rotated element's nodes then fall on the same points as the original node positions, and any connecting wires remain connected.

4.5.3.1. Element Mirroring

You can also create a mirrored image of an element in a schematic.

To access Mirroring, in a schematic window select the desired element and choose Edit > Mirror. The cursor changes to reflect the mirroring operation. Click in the schematic to position the new element. The following figure shows a mirroring operation.

4.5.4. Editing Element Parameter Values

To edit an element's parameter values:

  1. Double-click the element graphic in the schematic window. The Element Options dialog box displays. For more information about this dialog box, see the screens starting with “Element Options Dialog Box: Parameters Tab”.

  2. Make the necessary parameter modifications, and click OK.

You can also edit parameter values directly on a schematic by double-clicking the parameter value in the schematic window. An edit box displays to allow you to modify the value. Press the Tab key to quickly move to the next parameter entry. Press Shift+Tab to move to the previous parameter.

You can use the following standard unit modifiers to simplify entry of model parameters:

f 1e-15
p 1e-12
n 1e-9
u 1e-6
m 1e-3
c 1e-2
mil 25.4e-6
k 1e3
meg 1e6
g 1e9
t 1e12

For example, if you are working in base units you can enter "1p" instead of "1e-12" for a capacitor. You can also use modifiers in equations.

These modifiers follow SPICE rules; they are not case sensitive, they must follow the number directly without a space in between, and any characters directly following the modifier are ignored. Note that the suffix "d" (deci) is not supported since it is reserved for use as an alternative to "e" in scientific notation.

4.5.4.1. Selecting Multiple Elements

There are various ways to select multiple elements. All elements in your current selection group display with selection boxes around them and their parameter text outlined.

  • Press the Shift key while individually clicking on elements to add them to a selection group. Click on them again to remove them from the selection group.

  • Click and drag the mouse to define a selection area, then release the mouse button. All elements completely enclosed in this area are selected.

  • Shift+click and drag the mouse to define a selection area, then release the mouse button. All elements completely or partially enclosed in this area are selected.

  • Shift+Ctrlclick on elements to cycle through elements that overlap. By default, the smallest object is selected first and then larger items are selected as you cycle through them.

  • With a schematic window active, choose Edit > Select Tool to display the Selection Tool dialog box and select all items that match certain criteria. The dialog box displays the number of items found. When you close the dialog box the items are still selected so you can then edit them. See “Element Selection Tool Dialog Box” for more information.

4.5.4.2. Editing Multiple Elements

To edit multiple elements simultaneously, select multiple elements, right-click one of them and choose Properties or choose Edit > Properties. The Element Options: Multiple Element Type Properties dialog box displays to allow you to edit any common element parameters. If the parameter values are identical, the value is displayed in the dialog box. If the parameter values are different, the value displays as "***".

4.5.4.3. Editing Element IDs

The first parameter for each element is the ID of the element. You can edit the ID to make it more meaningful. The following special characters are not allowed in element IDs:

  • (

  • )

  • , (comma)

  • =

  • \

  • " (double quote)

  • ' (single quote)

  • ` (back tick)

  • (space)

4.5.5. Using Variables and Equations for Parameter Values

AWR Microwave Office software allows you to define variables and equations to express parameter values within schematics. To assign a parameter value to a variable, create the required variables and equations as described in Variables And Equations, then edit the parameter value as described previously, specifying the variable name as its new value.

Another type of syntax supported by parameters allows you to refer to other parameters of the same element, different elements connected to a node of the element, or elements specified by the element name and ID. The following table shows these three syntax forms.

Parameter Syntax Description
P1=P2@ P1 uses the value of parameter P2 from this element
P=P@1 P uses the value of parameter P from an element connected to node 1 of this element
W=W@MLIN.TL1 W uses the value of parameter W from an MLIN element whose ID=TL1

4.5.6. Using Elements With Model Blocks

Some elements in the AWR Design Environment platform have parameter settings for model blocks. A common example is for transmission lines. The individual elements define the transmission line geometry and then have a parameter for the substrate element used to define the substrate parameters for this transmission line.

The type of model block needed is the parameter name listed for the element. For example, an MLIN model has an MSUB parameter, meaning that an MSUB element is required for this element to be used in simulation.

To add a model block to a schematic, right-click an element that requires a model block and choose Add Model Block.

4.5.6.1. Model Block Concerns

By default, the model block element entries are blank. You can identify specific model blocks by selecting the model block from the drop-down menu in the Element Options dialog box.

If the parameter is empty, the AWR Design Environment platform uses any model block found after searching the following:

  • the same schematic as the element using the model block

  • the Global Definitions

If more than one model block is defined at one location when the model block parameter is empty, the AWR Design Environment software issues an error and simulation stops. You can double-click the displayed error message to go to the problem model.

4.5.7. Swapping Elements

The Swap Element command allows swapping one or multiple elements, swapping with an element that has a different number of nodes from the original, and swapping with elements from XML libraries. It also provides the option to preserve or replace the swapped element's electrical parameters.

To swap one or more elements, select the element(s) in the schematic, right-click and choose Swap Element. In the Swap Element dialog box, choose the element with which you want to replace the selected element.

For extended capabilities when swapping elements, select the element(s) in the schematic, and in the Elements Browser, right-click on the element with which you want to replace the selected element(s). Choose Replace Selected Element > Preserve Parameters or Replace Selected Element > Replace Parameters to replace the selected element with the specified element and preserve or replace its parameters.

For any element in a schematic, you can also edit an element name by double-clicking it. Changing the name of the element is equivalent to swapping with parameter preservation.

4.5.8. Restricted Object Selection

Restricted object selection is added in Schematic Views to prevent objects from being selected. To use this feature, right-click in the schematic window, choose Restrict Selection and then select the item types to restrict. Selecting an item type prohibits it from being selected in the schematic. If you find you cannot select certain items in a schematic, you should verify that they have not been restricted from selection. See “Restrict Selection (Schematics) Dialog Box” for more information.

4.5.9. Viewing the Layout for a Schematic

The Schematic View and the Layout View are two views of a single intelligent database that manages the connectivity between the circuit components. To view the layout for a specific element in a schematic, select the element in the schematic window, right-click and choose Select in Layout. The layout window displays the schematic layout with the specified element's layout or artwork cell highlighted (if it has an assigned cell). For more information about these two views see “The Layout as Another View of the Schematic Database”. For more information on interaction between the schematic and the layout see “Schematic and Schematic Layout Interaction ”.

Legal and Trademark Notice