Go to www.awrcorp.com
Back to search page Click to download printable version of this guide.

2.5. Customizing the Design Environment

The NI AWR Design Environment suite provides a number of ways to customize your design environment, including its appearance, tabbed workspace, dockable windows, hotkeys, menu and toolbar content, and use of scripts to automate repetitive tasks.

2.5.1. Customizing Workspace Appearance and Tabs

The Environment Options dialog box (Options > Environment Options) has a number of tabs with options that apply to every project you create. The most common settings are the Save Options on the Project tab for specifying project file saving options; all settings on the Colors tab for specifying schematic, layout, and other object colors; and all settings on the File Locations tab for specifying default directories.

The Design Environment Options dialog box (Tools > Options) contains options to customize the display of the design environment such as theme, workspace tab display, and docked window options. For more information about this dialog box see “Design Environment Options Dialog Box ”.

2.5.1.1. Docking Workspace Windows and Toolbars

The Project, Elements, Layout, and Status windows can be docked (displayed as tabs along the main window frame) or floating (fully displayed within the workspace). While docked, you can place these windows in auto-hide mode by clicking the "push pin" (Auto Hide toggle) icon in the upper right corner of the window. Auto-hiding windows disappear from view (and resume as tabs) shortly after you click elsewhere on the screen. By clicking the header of an unhidden window and dragging the window, you can dock the window on any edge of the main window, or float it anywhere in the workspace. During the move, a docking target displays to assist you in placing the window in the desired location. While dragging, position your cursor over the docking target arrow of the desired orientation, wait for the screen to highlight in that area and then release the mouse button to dock. To display a hidden window, click on or hover the mouse cursor over that window's tab. You can also access hidden windows using the associated View menu commands.

To close a docked or floating window click the "x" (Close) icon in the upper right corner of the window. To reopen a closed window, choose View and the appropriate window option.

You can also float (fully display in the workspace) or dock (display inline along any edge of the main window frame) toolbars. To re-dock a floating toolbar, just double-click the toolbar title bar. To dock a toolbar in other than its default (top of the workspace) location, click on the dotted gripper that displays at the left side of the toolbar and drag the toolbar to another edge of the main window until it aligns with the frame, then release the mouse button.

2.5.2. Customizing Toolbars and Menus

The Customize dialog box (Tools > Customize) has tabs for customizing and configuring the content of toolbars and menus in the NI AWR Design Environment suite. Note that all customizations apply only to the current menu and toolbar, they are not globally applied. The Customize dialog box must be open for the following customization steps to work.

2.5.2.1. Customize Dialog Box: Menus Tab

If not currently displayed in the program, to display a menu you want to customize, click the Menus tab in the Customize dialog box and select the desired menu. The menu set displayed in the menu bar at the top of the NI AWR Design Environment workspace area changes to reflect your selection. Click the Reset button to restore the selected menu to its defaults and remove any changes. With the Customize dialog box open, you can right-click on any menu name in the menu bar to display a list of customization options for that menu. To customize options within a menu, display the menu and then right-click on a menu option:

  • Reset: Resets all changes made to the menu/option.

  • Delete: Removes the menu/option from the menu/bar.

  • Name: Allows you to change the default menu/option name. To create menu/option hotkeys, precede the hotkey (underlined) letter with an ampersand. For example, to access the Project menu using its hotkey Alt + P, the menu is named "&Project".

  • Copy Button Image: Allows you to copy the corresponding toolbar button image for use in a program that supports this operation. Not all menu options have corresponding toolbar button images.

  • Paste Button Image: Allows you to replace the default corresponding toolbar button image with an image copied from a program that supports this operation. Not all menu options have corresponding toolbar button images.

  • Reset Button Image: Resets a revised button image to its default image.

  • Edit Button Image: Opens a simple button editor to allow you to make changes to the current corresponding button image.

  • Change Button Image: Provides a number of images from which you can choose to replace the current corresponding button image.

  • Default Style: For menu items with corresponding button images, displays both the menu/option name and image on the toolbar.

  • Text Only: Displays the menu/option name only (no image) on the toolbar.

  • Image and Text: For menu items with corresponding button images, displays both the menu/option name and image on the toolbar.

  • Begin a Group: Places a divider bar to the left of the menu on the menu bar or above an option in a menu for customized menu/option group organization.

2.5.2.2. Customize Dialog Box: Toolbars Tab

If not currently displayed in the program, to display a toolbar you want to customize, click the Toolbars tab in the Customize dialog box and select the desired toolbar. Click the New button to create and name a new toolbar. Click the Reset button to restore a selected toolbar to its defaults and remove all changes. With the Customize dialog box closed, you can also view this list of toolbars by right-clicking anywhere on a toolbar in the main window. With the Customize dialog box open, you can right-click on any toolbar icon to display a list of customization options for that command button:

  • Reset: Resets all changes made to the command button.

  • Delete: Removes the command button from the toolbar.

  • Name: Allows you to change the default button name.

  • Copy Button Image: Allows you to copy the button image for use in a program that supports this operation.

  • Paste Button Image: Allows you to replace the default button with an image copied from a program that supports this operation.

  • Reset Button Image: Resets a revised button image to its default image.

  • Edit Button Image: Opens a simple button editor to allow you to make changes to the current button image.

  • Change Button Image: Provides a number of images you can choose to replace the current button image.

  • Default Style: Displays the command button as an image on the toolbar.

  • Text Only: Displays the command button name only (no image) on the toolbar.

  • Image and Text: Displays both the command button name and image on the toolbar.

  • Begin a Group: Places a divider bar to the left of the button on the toolbar for customized button group organization.

Adding a Custom Toolbar and Button

The following example shows how to add a new toolbar with a random customized button. You can add multiple buttons to new or existing toolbars using these steps.

  1. Choose Tools > Customize, and on the Customize dialog box Toolbars tab, click the New button.

  2. In the New Toolbar dialog box, type a name for your new toolbar and click OK. The new toolbar name displays at the bottom of the toolbar list in the dialog box, and an empty toolbar is created on the toolbar in the main window.

  3. On the Customize dialog box Commands tab, under Categories, select "CircuitElements" and then under Commands search for and select the MLIN element.

  4. Drag the MLIN element to the new empty toolbar at the top of the main window, and drop it.

  5. Right-click the new MLIN button for options to change its name or other characteristics, including using a stock image (Change Button Image) or opening the Button Editor to create a custom image (Edit Button Image).

  6. Click Close to save your toolbar and close the Customize dialog box.

2.5.2.3. Customize Dialog Box: Commands Tab

The Customize dialog box Commands tab contains groups of categorized commands as well as elements, libraries, and macros that you can drag to menus or toolbars to customize their content.

To add a command to a displayed menu set, select the command category in Categories, then click on the desired command in the associated Commands list. Drag the command to the menu of choice and drop it to add it. You can add commands directly to the menu bar or hold the mouse over a menu while dragging to display that menu and add the command as an option. To view all available commands, select All Commands.

To add a command to a toolbar, select the command category in Categories, then click on the desired command in the associated Commands list. Drag the command to the visible toolbar of choice and drop it to add it.

When the combined width of all docked toolbars exceeds the width of the main window frame, some toolbars are "compressed" and a chevron button displays at the end of the toolbar. Click this button and choose Customize as an alternate way to display the Customize dialog box, or choose Add or Remove Buttons to view a list of buttons/commands included in the toolbar. Select or clear the check boxes for the individual commands to include or remove them from the toolbar. Click Reset Toolbar at the bottom of this list to restore the toolbar to its default command list.

Split Buttons

Split buttons combine a single command with an arrow you can click to access other similar commands in a menu format. A split button consolidates commands and saves space on the toolbar, while remembering and displaying the last command you used from the group. For example, on the Draw Tools toolbar, clicking the rectangle icon at the left of the following split button allows you to draw a rectangle.

Clicking the down arrow at the right of this split button displays a drop-down menu of all commands associated with the button.

In this example, if you choose a command other than Rectangle, the icon for that command replaces the rectangle icon on the button face when the drop-down menu closes.

You can edit existing split buttons or add split buttons to any toolbar to make your own groups of commands. The following figure shows the split button on the Schematic Design toolbar that combines all the dynamic sources.

To create a split button, choose Tools > Customize. In the Customize dialog box, click the Commands tab and then select Menus in the list of Categories. Select Split Button under Commands, and then drag this item to the desired toolbar and drop it. Click the new button to display a blank drop-down menu, and then drag and drop Commands from any of the Categories onto this menu to add them to the group. The following figure shows three commands added to the menu of a new split button.

Adding a Custom Menu and Command

The following example shows how to add a new menu with customized commands. You can add multiple commands to new or existing menus using these steps.

  1. Choose Tools > Customize, and on the Customize dialog box Commands tab, under Categories, select "New Menu".

  2. Under Commands, drag the "New Menu" to the menu bar at the top of the main window, and drop it.

  3. Right-click the new menu to change its name, then press the Enter key.

  4. In the Customize dialog box, add commands to the menu by choosing a category under Categories, and a command under Commands, and then dragging and dropping the commands onto the new menu.

  5. Click Close to save your menu and close the Customize dialog box.

2.5.3. Assigning and Configuring Hotkeys

The Customize dialog box (Tools > Hotkeys) allows you to assign and configure hotkeys for a wide variety of program elements and commands. NOTE: Menu command shortcuts override hotkey assignments.

Select a category in Categories to display associated commands. Select a command and then type the desired hotkey or key combination at the top of the Hotkeys tab. Apply the hotkey(s) to an editor in the drop-down list, or choose Standard to apply the hotkey universally, then click Apply. You can change a default hotkey assignment by selecting it in the Current keys list and typing an alternate hotkey, and you can remove an assignment from this list by clicking Remove. To reset a command to its default hotkey, select it and click Reset.

2.5.4. Script Utilities

The NI AWR Design Environment suite includes many useful user utilities accessible on the Scripts menu. You do not need to know a scripting language or development environment to use the scripts.

Scripting is a great way to automate repetitive tasks. If you are interested in scripting, NI AWR provides a scripting development environment, a full description of the API objects available, and many examples of how to use each object. For more information, see the API Scripting Guide.

Please send email to awr.support@ni.com if you would like to provide feedback on this article. Please make sure to include the article link in the email.

Legal and Trademark Notice