Go to www.awrcorp.com
Back to search page Click to download printable version of this guide.

Chapter 11. EM: Creating EM Structures with Extraction

The term extraction is often used when discussing Electronic Design Automation (EDA) software. In this chapter, extraction is the general process of providing physical data input (in the form of shapes with conductor properties on dielectric layers) to a physical simulator that produces output to be used with circuit simulation. The output depends on the physical simulator. In silicon design, extraction is used for traditional parasitic extraction. In microwave design, extraction is used to ease the process of setting up for EM simulation, or to use Automated Circuit Extraction (ACE).

This chapter presents general concepts regarding the AWR Design Environment® extraction flow and includes sections that discuss issues specific to each type of physical simulator.

While extraction is a significant advancement in the automation of including an EM simulation in another electrical analysis, the quality of the simulation results is a direct result of the configuration of the extraction. Extraction does not guarantee accurate results just because it is relatively simple to set up and use, but it effectively removes a large portion of the tedious and error prone tasks required to perform this task manually. You should consider extraction set up as if performing manual set up of the EM analysis, overriding the default behavior of the extraction where appropriate.

11.1. Extraction Overview

You can select element(s) in a schematic that you want to associate with an extraction. A separate model parameter allows you to define this association. When you select this mode of simulation, an EM structure is automatically generated using the schematic layout for all elements associated with the extraction. The physical simulation runs, and the EM results automatically replace that element's built-in model(s) in any simulations using the schematic. The extraction process is generic in operation, the major difference being the type of simulator you use. The following figure shows a diagram of the extraction flow.

The geometry to be simulated in the extraction comes directly from the Layout View of the commanding schematic. This concept is essential to the methodology of the extraction process; the contents of the Layout View are modeled using a physical simulator.

11.1.1. Physical Simulators

Physical simulator is a generic term for a simulator that uses layout geometry and a physical stackup to produce a network that electrically represents the physical structure that can be used with a circuit simulator. AWR® uses this generic term because the AWR Design Environment platform has several types of physical solvers (either AWR technology or third-parties integrated through the EM Socket):

  • EMSight - an AWR electromagnetic solver; the results are in the form of network parameters.

  • AWR® AXIEM® - an AWR electromagnetic solver; the results are in the form of network parameters.

  • AWR® AnalystTM - an AWR 3D electromagnetic solver; the results are in the form of network parameters.

  • ACE - an AWR transmission line extractor; the results are in the form of a netlist of transmission line elements.

  • Parasitic Extractors - third-party solvers, currently OEA from NetAn; the results are in the form of RLCK netlists.

  • Other EM solvers - Other vendors using the EM Socket for full EM analysis; the results are in the form of network parameters.

11.1.2. Why Use Extraction?

  • An iNet can only be simulated using the extraction process.

  • Allows for an easy way to account for coupling that is not included in models (for example, coupling of two transmission lines due to proximity in layout, coupled spiral inductors, etc.).

  • The physical simulation is used for simulation results only, not as a layout cell in your design.

  • Significantly reduces the sources of error for performing physical simulation versus the manual process of doing the same, such as: copying layout or drawing EM structures layout by hand, adding ports and wiring up into a schematic as a subcircuit. For simple structures the advantage is significant, for large structures (over a few ports) the manual process is not manageable.

11.1.3. When Not to Use Extraction

  • If the physical geometry does not come from a schematic element's layout. This includes geometry from artwork files (GDSII or DXF files) or non-standard geometry (for example, an ellipses).

  • You want to use a physical simulation as a design element and get the layout from the physical simulation layout.

11.2. Extraction Setup Basics

There are four basic requirements for using the extraction process in the AWR Design Environment suite. Each is explained in further detail:

  1. A schematic with a layout that is properly snapped together. DO NOT attempt extraction unless you have ensured your layout is correct. See “State of Layout” for more details.

  2. An EXTRACT block placed in a schematic to control the physical simulator used and the settings for the physical simulator. See “EXTRACT Block” for details.

  3. Each schematic element and/or schematic layout shape must be configured to use extraction. See “Selecting Models and Shapes for Extraction” for details.

  4. A STACKUP element used to define the physical environment for your process including dielectric layers and conducting materials with a vertical position and thickness for each. See “STACKUP Block” for details.

11.3. Extraction Flow

After setup is complete, all you must do is simulate; the AWR Design Environment software performs the rest. New documents are created under the EM Structures node in the Project Browser. Don't be misled by the EM name, these documents contain the input for ANY of the physical solvers you use. The name "EM Structures" is only used for historical reasons. When the EM simulation is complete, these results are automatically used in any simulations of your schematic using extraction.

NOTE: The design can create the EM documents before simulating to allow you to visually confirm they contain what you expect, to view the mesh, etc. See “Viewing EM Structures Before Simulation” for details.

11.4. Schematic Layout

11.4.1. State of Layout

You should use caution with your layout when using extraction. Depending on the physical simulator type you use, if your layout is not properly connected you can get open circuit responses or short elements together. For example, if your layout has rat lines, you can get open circuits. If you have elements with overlapping layouts, those elements can be shorted. The AWR Design Rule Check engine (see “Design Rule Checking (DRC) ”) can search for rat lines and shorts (for iNets only). You must decide how to ensure the layout is correct before running extraction.

The physical solvers available are in two generic classes: shape based and path based extractors. For shape based extractors (such as EMSight and OEA) a meshing operation must occur to determine the connectivity of the entire structure. In this case, any rat line or touching shapes affect the results, as if the circuit was fabricated this way. For path based extractors (such as ACE) the layout objects simulated are paths. Since a path is a connection from point A to point B with some width, the path contains the connectivity information and so no meshing operation is needed. In this case, any rat lines or touching shapes do not create open circuits or shorts.

If you are unsure of what your physical solver will do in either of these situations, AWR recommends that you create some simple test structures to test these issues, or always ensure your layout has no shorts or rats lines.

11.4.2. Issues with Hierarchy

See “Extraction Through Hierarchy” for details on hierarchy issues.

11.4.3. EM Extracting Elements with Grounds

Some elements with layout in the AWR Design Environment program have a built-in ground connect, for example the MLSC (short-circuited microstrip line). If these elements are used for EM extraction, the extraction process doesn't understand how to ground one end of this line and so won't be extracted properly. For example, see the following schematic and the resulting EM structure for EMSight that is generated.

Notice in the EM structure that the right end of the structure is not touching the enclosure outline nor has any sort of via to the top or bottom of the structure. In this case this line simulates as an open rather than a short.

The correct approach is to use an MLIN element in the schematic and then use a separate ground element on one end of the line as follows.

Notice that the EM structure created has two edge ports, one on each side. With the extraction flow, this EM result replaces the MLIN in the schematic, and since one end of the MLIN is grounded, one end the EM structure gets grounded in the schematic simulation.

Vias to ground are another case where extraction can be difficult. The following figure shows a via to ground in a schematic.

Since the via is a two-node model, the extraction flow needs to add a second port at the bottom of the via. There should not be a port here, however, because the via is connected to the bottom of the enclosure.

There are two solutions to this problem. The simplest is to use the VIA_1P model which is a one-port model with ground included in the model. The second work-around is to place the via in a schematic where the via is grounded and one port is added.

You can then use this schematic as a subcircuit where you want your vias, as shown in the following figure.

The final step is to set up the subcircuit to extract, instead of the via model itself.

11.4.4. Extraction Ports

By default, auto ports are used for AXIEM and Analyst extraction. For AXIEM, auto ports automatically determine port settings based on geometry and stackup. See “Auto Ports” for more information on this port type. For Analyst simulation, auto ports map to edge ports with Connect to lower as the Type. In some cases it is best to manually specify port settings or numbering. You can disable auto ports on a per port basis by adding extraction ports to the schematic layout and specifying port settings on the extraction port.

To add an extraction port, select the item in your schematic layout to which you want to add the port, choose Draw > Extraction Port and then place the port on an edge of the selected shape. This is the same as adding ports in an EM structure. In the following figure an extraction port is added to the schematic layout.

You can now set port properties that are transferred to the EM document created during extraction. For example, you can change the ground type, the mutual group type, or de-embedding. You can also change the reference plane distance. Double-click the extraction port to display the Properties dialog box. On the Port Attributes tab, enter the value you want to de-embed in Ref. Plane Distance. When you do this, the reference plane draws outside of the shape to which it is connected. For example, the previous structure has a reference plane extension of 100um.

Note that the EM structure created from extraction adds this length to the shapes extracted.

The extraction ports are only suggestions. They are only used if the EM structure created with extraction needs a port where the extraction port is located in the layout; for example, when you have two MLINs in a schematic connected together and you are extracting both. If you place an extraction port between the two MLINs, the settings from the extraction port are not used since there is not a port in this location in the EM structure.

You can place extraction ports at any level of your hierarchical design. If there are ports at the same location but at different levels of hierarchy, the extraction port at the higher level of hierarchy is used. The extraction ports created at one level of hierarchy are unique in the extracted document, there are not any settings that are shared (such as port number or mutual groups). For example, see the following figure where two of the schematics created above are used through hierarchy, so the layout looks as follows,

and the extracted EM structure looks as follows.

Notice that there is a port 1 and 2 and not two ports with number 1. It is valid in AXIEM to have two ports with the same number, but you could only achieve that with extraction ports when using them at the same level of hierarchy.

Hiding Extraction Ports

To turn off display of extraction ports in the schematic layout view:

  1. From the menu, select Options > Drawing Layers

  2. In the General section, click on Drawing Layer 2d.

  3. For the drawing layer EMSymbols, clear the Visible check box.

11.4.5. Area Pins

Area pins are layout objects where an area is used to define the allowed connection location. There are several cases where you will want area pins included in the EM structures generated from extraction. There are two classes of area pins for extraction. Ports that have layouts that are area pins are the first case, and any other area is the second case. The main reason to have a port with layout is when using iNets. Often you need your port to have layout to define where to connect to a layout through hierarchy. Also, you often need a port to have a layout so you can get a rat line (between the port and whatever it is connected to) so you can route an iNet.

By default, if an extracted element is connected in the schematic to a port with an area pin, that area pin's layout is extracted. Area pins that are not connected to extracted elements are not extracted. On the EXTRACT block, you can change the Extract_PinShapes parameter to "Yes" and then area pins (on p-cells) that are touching other extracted elements are included in the EM structure generated from extraction. You can override this behavior per area pin. Select the shape that has the area pin in layout, right-click and choose Shape Properties to display the Cell Options dialog box, then select the Faces tab. In Face, select the face number of interest. In the Area Pins section, change Extract pins connected to extracted objects to either Default, Yes, or No. See “Cell Options Dialog Box: Faces Tab ” for more information about this dialog box. Default is the behavior previously described regarding the different types of area pins. Yes and No override any other settings that control how area pins are extracted.

11.5. EXTRACT Block

The EXTRACT block controls the physical simulator and options for that simulator. You should place this block at the top level of your design hierarchy if not using hierarchical extraction, or at any level lower down if using hierarchical extraction. See “Extraction Through Hierarchy” for details about working with hierarchy. The element Help for the EXTRACT block has details for each of the parameters on this block; see “Extraction Control Block: EXTRACT”.

The EM_Doc parameter is the exact name of the EM structure that is automatically generated in the project. This name should be different from all other names on extract blocks or other EM structures.

The Name parameter connects individual models and shapes from the schematic layout to the specific EM structure specified. You enter the name by typing it between quotes. For models or shapes using this name, it is available in the drop-down menu. You can also include more than one group with an EXTRACT block by typing all of the names separated by a comma and between the {} characters. For example, if groups a, b, and c are used for various models or shapes in the design, you can type "{a,b,c}" to include all of those groups in the one EM structure.

11.5.1. EXTRACT Block Enable

You can enable or disable the EXTRACT simulation control in the controlling schematic by selecting the EXTRACT control, right-clicking and choosing Toggle Enable.

When the EXTRACT control is enabled, the simulation proceeds as documented in the previous sections. When the EXTRACT control is disabled, each of the elements associated with the extraction group reverts to the behavior they would have if the extraction group did not exist. This provides a convenient way to see the electrical effect of an extraction on your simulated results.

Note that disabling the EXTRACT simulation control does not disable the associated EM document. If the simulation results of the EM document are not valid, this document is resimulated. You must disable the EM document if it is not used. This is not done automatically, because it is possible to configure the measurements directly upon the EM document or to have another EXTRACT simulation control with the same EM document name specified.

11.5.2. Simulator Defaults

The EXTRACT block has tabs to control simulator options so you can make changes here rather than directly on the EM structure. You can set options directly on the EM structure. This is not recommended since the EM structure is generated from a schematic with an EXTRACT block that can override the options on the EM structure. If you must set options directly on the EM structure, make sure to set the EXTRACT Override_Options parameter to "No".

11.5.3. Extraction EM Frequencies

When an extraction is first performed (or the EM structure is first created) the set of frequencies from the Frequencies tab are used. Once the EM structure is set up with these frequencies, no further automatic update of the frequencies is done, unless the structure is deleted and recreated. From this point, you can modify the EM structure simulation frequencies and they remain unchanged. When a schematic is simulated the EM results may have to be interpolated or extrapolated if the frequencies for the schematic are different than those of the extracted EM structure.

Often, to speed the electromagnetic simulation process, you may want to reduce the frequency set if the port parameters do not vary quickly over frequency. Depending on the simulator associated with the EM structure, this may or may not reduce the simulation time.

Because the simulation frequencies are not altered after creation of the EM structure some common errors can occur. If the simulation frequencies of the controlling schematic are altered after the extraction EM structure is created, these changes are not forwarded to the EM structure. This is to allow the customization of the frequencies as previously mentioned.

Another common error in the EM structure simulation frequencies occurs when you perform a nonlinear simulation on the schematic using a harmonic balance or time domain simulator. In either case, the EM structure is asked to supply port parameter information from DC to some higher multiple of the simulation frequency. For harmonic balance simulations this is at DC, harmonics of the fundamental and possibly mixing products of a multi-tone analysis. You must configure the EM structure frequencies in a manner appropriate to the analysis being performed.

For a time domain simulation, a rational function expansion is performed on the EM structure to create a time domain model. To create this function, the EM structure is asked to supply additional frequency domain data.

You must ensure that the set of simulation frequencies applied to the EM structure is appropriate for the simulation performed on a parent schematic.

11.5.4. Multiple Extractions in a Single Schematic With Different Group Names

You can apply multiple extractions within the same schematic to different EM structures and different group names. You should use this technique if two sections of the schematic are physically separated such that you expect minimal coupling between the extraction groupings. All that is required to enable multiple extractions is to have multiple EXTRACT blocks to the schematic. In this case, each EM_Doc and Name should be unique. This is the main reason that when setting up for extraction you must specify a name for the extract group.

11.5.5. Multiple Extractions in a Single Schematic With the Same Group Names

You can apply multiple extractions within the same schematic to different EM structures and the same group names. In this case, each EM_Doc should be unique and the Name should be same. The frequencies for all the EXTRACT blocks must be unique. The application of this feature is to allow different simulator settings or even different simulators for different frequency ranges, yet allowing the extraction flow to manage creating all of the EM structures and merging all of the data together after all the simulations are complete. For example, you might want AXIEM with thin metal for your DC point, AXIEM with thick metal for your in-band frequencies (and meshed at your highest in-band frequency), and then AXIEM with thin metal for your harmonic frequencies (and mesh at your highest harmonic frequency), or you might want to use ACE for DC and then EMSight for the rest of your frequencies, etc.

11.6. STACKUP Block

You must add a STACKUP substrate element to the top level schematic or to the global definitions. This element is used to set up the EM structure's dielectric stack-up and conductor properties. If you use PDKs, these blocks are typically configured for you and are in the global definitions. AWR suggest only placing STACKUP blocks in the global definitions for several reasons:

  1. There is only one in the project, so you know all your extractions use the same STACKUP.

  2. If you create EM structures without extraction, the new structures can use the STACKUPs in the global definitions as the default settings.

STACKUPS added to a schematic automatically use the schematic's LPF.

See “Configuring Stackup” for details on the STACKUP settings.

11.6.1. Multiple STACKUPs

For some processes, you may want several STACKUPs for your simulation needs. This is common when using full-wave EM simulations since you can make simulations more efficient by collapsing dielectric layers. The correct approach is to create as many STACKUP elements as necessary. For each, you should define a unique Layer Mapping, then for the EXTRACT block, you can use any of the defined STACKUP elements.

11.7. Selecting Models and Shapes for Extraction

To associate schematic circuit elements for extraction, in the Schematic View, double-click the element or right-click it and choose Properties to display the Element Options dialog box. Click the Model Options tab. In the EM Extraction Options area, click the Enable check box and in Group name, you can either type in a new name or use the drop-down menu to choose any name already set up on an EXTRACT block. See “Element Options Dialog Box: Model Options Tab” for more information. You can select multiple elements in the schematic and turn on extraction for all selected elements at once. For iNets, you select the wire in the schematic for that iNet.

You can also associate elements with an EXTRACT control from the Layout View. This is often more convenient, as this view allows you to identify elements that are in close physical proximity. With iNets, layout is much simpler than the schematic for setting up extraction. Select the shape you want to extract, right-click and choose Element Propertiesto display the Element Options dialog box. Click the Model Options tab. In the EM Extraction Options area, click the Enable check box and in Group name, you can either type in a new name or use the drop-down menu to choose any name already set up on an EXTRACT block. You can select multiple elements in the schematic layout and turn on extraction for all selected elements at once.

When working in schematic layouts, you can also have "dumb" shapes, which are shapes that don't have a schematic element. These are drawn by hand in the schematic layout and they can also be used in extraction. Select the shape you want to extract, right-click, and choose Shape Properties. In the EM Extraction Options area, click the Enable check box and in Group name type in the group name.

11.8. Viewing Items for Extraction

After making associations, you can visually see the associations in both the layout and schematic. If you select the extraction simulation control within the schematic, all elements associated with that extraction are marked as shown in the following figure.

Similarly, in the layout, the layout cells associated with that extraction are marked as shown in the following figure.

In this mode, the highlight color is always red. The highlight turns off when you click elsewhere.

Alternatively, right-click the EXTRACT block and choose Highlight. A Color dialog box displays to allow you to specify a color for the extraction group highlight. After highlighting, right-click the EXTRACT block again and choose Highlight Off. This mode takes a few more mouse clicks to turn on but has several advantages:

  • You can use the color you want.

  • The highlight stays on until turned off. This allows you to select subcircuits, right-click and choose Edit Subcircuit to push into the subcircuit while the highlight remains on. This allows you to find items through hierarchy.

  • If you have more than one EXTRACT block, this mode can highlight items in different extract groups at the same time.

For example, the following circuit has two different extraction groups, one is highlighted in green and the other is highlighted in orange.

11.9. Viewing EM Structures Before Simulation

When performing extraction, you can view the EM structure before the physical simulation is run. With your extraction properly configured, right-click the EXTRACT block in your schematic and choose Add Extraction. Alternatively, you can select the schematic name in the Project Browser and choose Add Extraction. Either command creates the EM structure generated with the name set on the EXTRACT block. If nothing is created, there are no EXTRACT blocks in that schematic, the EXTRACT block is disabled, or there are no elements added to the group controlled by the EXTRACT block.

You should do this every time you start a new group of extraction problems. Once you are sure the layout is extracting reasonably for your layout, you can expect that it will continue to work for small changes of layout. You should always check the connectivity in the layout and ensure it still functions correctly.

11.10. Extraction Through Hierarchy

The Extraction flow supports extraction through hierarchy. When a schematic has an EXTRACT block, the extraction process looks for models or shapes to extract through all levels of hierarchy. There are several ways to change this behavior.

11.10.1. EXTRACT Blocks Through Hierarchy

The default behavior is for the top level EXTRACT block to override all lower level EXTRACT blocks, causing all extraction to be performed as one flat simulation. You may want an EXTRACT block at lower levels of hierarchy for when you simulate that level. See “3D EM Extraction” for exceptions related to 3D EM simulations.

The Hierarchy parameter on the EXTRACT block controls how extraction is executed throughout the design hierarchy

When Hierarchy is set to "Off" for any EXTRACT block at a lower level other than the top level being simulated, any shapes associated with the lower level EXTRACT block are only extracted by the top level EXTRACT block. Hierarchy is being flattened, and any lower level shapes are included as part of the top level extraction. If there is no top level EXTRACT block, then nothing is extracted.

When Hierarchy is set to "On" for any EXTRACT block at a lower level than the top level being simulated, any shapes associated with the lower level EXTRACT block are extracted in the lower level document and the top EXTRACT block extracts any shapes not associated with the lower level block. Hierarchy is being preserved, and any lower level shapes are extracted at the lower level, and are included in top level simulations as a separately extracted subcircuit. If there is no top level EXTRACT block, the lower level is extracted.

11.10.2. Extracting Subcircuits

Hierarchy is created in a design by using a SUBCKT model and specifying the name of the subcircuit. By default, the extraction process pushes into each subcircuit looking for items to extract. However, if you set the SUBCKT block itself to extract, the process will not push any lower into hierarchy. There are several situations where you would want to extract the SUBCKT model. The first situation is when you assign an artwork cell to your subcircuit. For example, you could create a transmission line model from lumped RLC elements. Since this model has no layout, you could use this model as a subcircuit and then assign an artwork cell to the layout cell for the subcircuit.

The second situation is when you are using an EM structure as a subcircuit in your design (not created with extraction) and you want to extract the layout from this EM structure into a larger EM simulation. For example, if you need to use EMSight to simulate several discontinuity models and you are using these EMSight results in your overall design, then you wanted to simulate the complete design using AXIEM. In this case, you would set up your EM subcircuits to use extraction, just like any other model.

When extracting EM subcircuits, you might end up with the metal used for any de-embedding distance undefined. This occurs when an EM subcircuit is connected directly to a port, because the extraction process doesn't know what is connected to the EM subcircuit. You can fix this problem by setting the connect type for the ports in the EM document. To do this, select the port in the EM layout, right-click, choose Shape Properties, and click the Cell Port tab. See “Properties Dialog Box: Cell Port Tab ” for more information about this dialog box. You then select the connection type for this port.

11.11. EM Optimization, Tuning, and Yield Analysis

You can tune, optimize, and perform yield analysis using EM simulators, extractors, or ACE. To do so, the shapes being extracted by an EXTRACT block must be controlled by variables that are being tuned or optimized. The following figure shows a schematic with an MLIN element with W and L parameters set up for EM tuning.

For EM optimization, tuning, and yield analysis to operate correctly, you must set the layouts to automatically snap together so that each time a parameter changes the layout is automatically updated, and correctly represents what needs to be simulated. (Choose Options > Layout Options and on the Layout tab under Layout Cell Snap Options set Snap together to Auto snap on parameter changes.) See “Layout Options Dialog Box: Layout Tab ” for more information.

Tuning and optimizing on parameters that affect the layout results in resimulation as the layout changes. Tuning and optimizing swept variables (SWPVAR blocks) is NOT supported, however, since swept values do not affect layout (their value for layout is derived from the default swept parameter equation value). Currently, only variation on model geometry is allowed; you cannot vary dielectric height or dielectric constants using the extraction flow.

11.12. Extraction and Switch Views

EM extraction and Switch Views are two different ways the simulator uses an electrical model different than the default model. EM extraction simulates the model's shapes in an EM simulator and uses the EM result for the model. Switch Views can switch between different ways of modeling a specific component of the design (for example, linear model or S-parameters). For more information about switch views, see “Switch View Concepts ”. You cannot use both switch views and EM extraction at the same time because the software has no way of knowing which model you want. Currently, if you set up simulations with both configured an error message displays.

11.13. Extraction and Swept Variables

Swept variable analysis does not change layouts during the swept analysis. If you want to do an extraction with swept variables where the swept variables affect the layout of the items being extracted, special consideration is required. To update layouts with extraction and swept variables for AXIEM and Analyst simulations only, you must add the name of the swept variable to the EXTRACT block SweepVar_Names parameter.

These concepts are demonstrated with an example. The following schematic shows a simple setup of a swept length of transmission line.

When simulated without extraction and looking at the phase of the line, the phase should increase as the length is increased, as shown in the following figure.

If the same schematic is set up for extraction by adding a STACKUP, adding an EXTRACT block, and assigning the MLIN to the proper extract group, the schematic would display as shown in the following figure.

When you run the simulation the Simulation dialog box displays only one EM simulation.

The simulation results are shown in the following figure.

As shown in these simple results, it is obvious that the extraction did not properly handle the swept variable.

The proper setup is to add "L" to the EXTRACT block SweepVar_Names parameter. After this change, the schematic displays as shown in the following figure.

When you run the simulation, the Simulation dialog box displays only three EM simulations.

The simulation results in the following figure now show the expected behavior.

11.14. Extraction and Shape/Layer Modifiers

Shape and layer modifiers allow additional manipulation of layout shapes outside of layouts snapping together from schematic elements. See “Shape/Layer Modifiers” for details on using shape modifiers. When using either the Stretch Area shape modifier or any of the layout modifiers, changes to the modifier do not change the schematic layout. When you generate the EM document from extraction, however, the shapes are changed.

The following layout shows a simple transmission line 20um wide and 100um long. A Layer Resize modifier is set to oversize the shape by 20um.

When the EM document is created, the line is oversized in each direction by 20um, so the total size is 60um wide and 140um long. The following figure shows the extracted AXIEM document.

11.15. EMSight Layout Issues

When using EM extraction, the extraction process attempts to add edge ports when the EXTRACT block's PortType setting is "Default" when it can, and use via ports when it cannot.

The following cases are situations where edge ports are not possible:

Case 1. In the AWR Design Environment program, any edge ports on the same edge of the structure must have the same de-embedding length. For extraction, this means that for more than one edge port to be on the same side, the connection locations must be lined up exactly. For example, see the following figure for the schematic layout.

The following figure shows the extracted EMSight extraction document.

Notice that port 2 is not an edge port but rather a via port.

If the two edges are lined up exactly, then both will have edge ports.

Case 2. Using extraction where connections cannot be made on the outside of the structure. For example, two lines with a chip capacitor between them with only the lines set for extraction. Two of the connections are external to the structure; these can use edge ports. Two connections, however, are internal and must use via ports.

Case 3. Using extraction where an EM port is required on a non-orthogonal edge. For example, if the only extracted element is a line that is rotated even slightly, so that its edges are not at exact multiples of 90-degrees, edge ports cannot be placed on it. Via ports are used instead. In the schematic layout, right-click on any shape, choose Shape Properties to display the Cell Options dialog box, then click the Layout tab to see if it has been rotated.

A via port in EMSight is a port that extends vertically from the layer it is on down one layer, and then a source is attached at the bottom of the via. Via ports and EMSight must be considered very carefully before deciding if using them is acceptable.

  • Via ports have some inductance due to the vertical metal simulation that is not de-embedding from your simulation. You need to determine if this inductance is significant or not at your simulation frequencies.

  • Via ports only go through one level of dielectric. If the via port does not go to the bottom of the structure, the excitation of this port is not correct.

NOTE: AXIEM has different types of ports that are more suitable for connections that cannot use edge ports. If EMSight's port issues are significant, you might consider using AXIEM.

11.16. 3D EM Extraction

In addition to other schematic elements, 3D EM Extraction supports extraction of BWIRES elements and hierarchical designs using different technology LPFs. Therefore, structures such as MMIC-bond wire-Board transitions can be extracted and simulated using a 3D EM solver such as the Analyst 3D Electromagnetic simulator.

The following are limitations of 3D EM Extraction:

  • The BWIRES pCell is the only 3D EM pCell recommended for use with Analyst Extraction. All other 3D pCells do not have schematic layout representations appropriate for 3D EM Extraction.

  • Artwork cells cannot be extracted.

  • EM structures used as subcircuits in schematics cannot be extracted.

  • When extracting through hierarchy:

    • A SUBCKT block cannot be added to an extraction group, in order to be extracted as one flat structure. The elements to be extracted in each subcircuit schematic must be added to the desired extraction group.

    • The extracted EM structures can preserve the hierarchy of the schematics-- each schematic with an EXTRACT block has its own EM structure. The EXTRACT block is required if the stackup of the subcircuit is not the same as the higher level schematic.

    • If a lower level schematic does not have an EXTRACT block, the extracted elements in it will use the EXTRACT block in the higher level schematic, and will be part of that EM structure.

11.16.1. 3D EM Extraction Setup

This material assumes familiarity with the general Extraction procedure. See “Extraction Setup Basics” for details on the general procedure. For 3D EM Extraction, there are three additional steps described in more detail in the following sections.

  1. Synchronize the schematic 3D view with the EM 3D view.

  2. Define the z-position of elements.

  3. Define the boundary in the schematic layout

11.16.2. Synchronizing the 3D Layout

In the AWR Design Environment suite, there are two independent 3D layout views: the schematic 3D layout view and the EM 3D layout view. Each schematic has an associated LPF that defines the drawing layers for that schematic. For schematic 3D layout, the Drawing Layer 3d Properties settings determine how shapes draw in the schematic 3D view with respect to z-position and thickness. See “Options - Drawing Layer 3D Dialog Box ” for details. The schematic 3D view is a visual aid only and has no effect on simulation results, or extracted EM structures. How shapes draw in the EM 3D view, however, is determined by the STACKUP element used to generate the EM structure. The material thicknesses and the EM Layer mappings in the STACKUP directly control how the 3D geometry is constructed for simulation.

In order to use the schematic 3D layout as a visual aide for setting up the 3D EM Extraction, the z-position and thickness settings for schematic drawing layers must match the material thickness and EM Layer mapping in the STACKUP used for extraction. Otherwise, the two 3D views are different. When the extracted EM structure is generated, a warning is issued in the Status Window if there are any differences between LPF and STACKUP settings. You can resolve these differences by running the Sync LPF with Stackup command.

  1. In the Layout Manager, under Layer Setup, right-click the LPF and choose Sync LPF with Stackup.

  2. In the Update LPF from Stackup dialog box that displays, select the STACKUP element that you want to use for Extraction.

  3. Select the Update 3D attributes of mapped drawing layers check box, and then click OK.

These steps modify the 3D properties of thickness and z-offsets for all drawing layers that have EM mappings in the STACKUP. In addition, the z-offset for the Bond Wires drawing layer (used to display the BWIRE element) is reset to z=0, so the z-position of BWIRE elements can be set directly in the schematic, on a per instance basis. Unmapped drawing layers are not modified; you may need to manually modify them in the Drawing Layer 3d Properties settings. The Update LPF from Stackup dialog box also includes an Update 2D attributes of mapped drawing layers check box. Select this check box to update the fill color and pattern for mapped drawing layers in the LPF to match the settings defined in the STACKUP Material Definitions.

11.16.3. Z-Position

The z-position of all extracted elements must be correctly set to ensure connectivity in the Extracted EM structure.

  • For a schematic pCell element (MLIN, for example) and dumb shapes, the z-position in the Extracted EM structure is determined in the EM Layer Mapping table in the STACKUP used for extraction. See “Configuring Stackup” for details on the STACKUP settings.

  • For a 3D EM pCell (BWIRES, for example), z-position is set per instance.

  • For schematic subcircuits, z-position is set per instance.

For 3D EM pCells and schematic subcircuits, you can set the z-offset as an absolute distance, or relative to the EM layer. The position z=0 refers to the bottom boundary of the EM structure. In order to set z-offsets relative to an EM layer, the schematic must contain an EXTRACT block that references a STACKUP. To set z-offset, in the schematic layout view:

  1. Select an element in the layout.

  2. Right-click the element and choose Shape Properties. The Cell Options dialog box displays.

  3. Click the Layout tab.

    • If the EM layer drop-down list is grayed, there is not yet an EXTRACT block associated with the schematic, and the z-position must be set as an absolute value in Offset. An Offset of "0" references the bottom boundary of the EM structure.

    • If the EM layer drop-down list is enabled, select an EM layer to set the z-position. The Offset is now relative to the selected EM layer.

11.16.4. Boundary Shape

The default boundary conditions for extracted 3D EM structures is Perfect Conductor for the bottom boundary, and Approx Open for all other boundaries. To add a boundary shape to the schematic layout to control exact boundary size and conditions:

  1. On any drawing layer, draw the Boundary shape. This shape must be a closed polygon.

  2. Select the shape, then right-click and choose Draw > Create Simulation Boundary. The shape transforms into a Boundary shape.

  3. Select the Boundary shape, then right-click and choose Shape Properties.

  4. In the Properties dialog box, click the Boundary Conditions tab and set the boundaries. See “Specifying Simulation Boundaries” for details.

  5. Click the Layout tab. In the Em Extraction Options section, select the Enable check box and enter a Group name. This step includes the shape as part of the extraction group.

11.16.5. EM Hierarchy

3D EM Extraction supports EM hierarchy, in which schematic subcircuits are extracted as EM subcircuits. Using EM hierarchy allows subcircuits to be defined with a different LPF and STACKUP from the parent schematic. You can place each instance of the subcircuit at a different z-position in the parent schematic.

To set up EM hierarchy:

  1. Place an EXTRACT Block in the subcircuit schematic. The EXTRACT block should reference the STACKUP representing the subcircuit.

  2. In the schematic layout of the parent schematic, set the z-position for each instance in the Cell Options dialog box.

The following example illustrates the concept of EM Hierarchy. It consists of a chip connected to a board using bond wires. The chip is defined as a subcircuit with its own LPF and STACKUP. It is selected for extraction along with bond wires and board elements. In the schematic layout, the chip subcircuit is positioned to sit on top of the board.

In order to extract the chip subcircuit as an EM subcircuit, place an EXTRACT block in the chip schematic and reference the STACKUP representing the chip. In the following figure, only the GSG pads are selected for Extraction.

When the Extracted EM structure is created, the chip subcircuit is extracted as an EM subcircuit.

It is critical to preview the extracted EM structure before simulation to ensure that the geometry is correct. See “Viewing Items for Extraction” for steps to generate the Extracted EM structure before simulation. The following is the Preview Geometry view of this example, with the chip sitting on top of the board. The chip is defined with a different STACKUP than the board.

This concept of EM hierarchy is not the same concept as Extraction hierarchy. Extraction hierarchy is also supported for 3D EM Extraction. See “Extraction Through Hierarchy” for details.

Please send email to awr.support@cadence.com if you would like to provide feedback on this article. Please make sure to include the article link in the email.

Legal and Trademark Notice