Go to www.awrcorp.com
Back to search page Click to download print version MWO,VSS,AO,MMIC,Analyst

Chapter 1. Introduction

For users that are already familiar with the different NI AWR Design Environment Getting Started Guides, the following are direct links to specific content in these guides:

To set up the NI AWR Design Environment software for PCB style design, choose Tools > Create New Process to display the Create New Process dialog box, then click the Help button for details on using this tool.

Introducing the NI AWR Design Environment

Welcome to the NI AWR Design Environment suite!

This suite comprises three powerful tools that can be used together to create an integrated system, RF, or analog design environment: Visual System Simulator (VSS), Microwave Office, and Analog Office software. These powerful tools are fully integrated in the NI AWR Design Environment suite and allow you to incorporate circuit designs into system designs without leaving the design environment.

VSS software enables you to design and analyze end-to-end communication systems. You can design systems composed of modulated signals, encoding schemes, channel blocks and system level performance measurements. You can perform simulations using VSS software's predefined transmitters and receivers, or you can build customized transmitters and receivers from basic blocks. Based on your analysis needs, you can display BER curves, ACPR measurements, constellations, and power spectrums, to name a few. VSS software provides a real-time tuner that allows you to tune the designs and then see your changes immediately in the data display.

Microwave Office and Analog Office software enable you to design circuits composed of schematics and electromagnetic (EM) structures from an extensive electrical model database, and then generate layout representations of these designs. You can perform simulations using any of NI AWR's simulation engines, such as a linear simulator, an advanced harmonic balance simulator for nonlinear frequency-domain simulation and analysis (the APLAC harmonic balance simulator), a 3D-planar EM simulator (the AXIEM tool), a 3D-FEM simulator (the Analyst tool), transient circuit simulators (the APLAC transient simulator or an optional HSPICE simulator) -- and display the output in a wide variety of graphical forms based on your analysis needs. You can then tune or optimize the designs and your changes are automatically and immediately reflected in the layout. Statistical analysis allows you to analyze responses based on statistically varying design components.

Analog Office provides a single environment to fully interact with a comprehensive and powerful set of integrated tools for top-down and front-to-back analog and RFIC design.

The tool set spans the entire IC design flow, from system-level to circuit-level design and verification, including design entry and schematic capture, time- and frequency-domain simulation and analysis, physical layout with automated device-level place and route and integrated design rule checker (DRC), 3D full field solver-based extraction with industry gold standard high-speed extraction technology from OEA International, and a comprehensive set of waveform display and analysis capabilities supporting complex RF measurements.

OBJECT ORIENTED TECHNOLOGY

At the core of the NI AWR Design Environment software capability is advanced object-oriented technology. This technology results in software that is compact, fast, reliable, and easily enhanced with new technology as it becomes available.

About This Guide

This Getting Started Guide is designed to familiarize you with the software by demonstrating Microwave Office, VSS, Analog Office, Analyst, or MMIC capabilities through working examples.

Prerequisites

You should be familiar with Microsoft® Windows® and have a working knowledge of basic circuit and/or system design and analysis.

This document is available as a PDF file on your Program Disk (*_Getting_Started.pdf, depending on your product), or you can download it from the Knowledge Base at NI AWR Knowledge Base.

If you are viewing this guide as online Help and intend to work through the examples, you can obtain and print out the PDF version for ease of use.

Contents of this Guide

Chapter 2 provides an overview of the NI AWR Design Environment suite including the basic menus, windows, components and commands.

In the Microwave Office Getting Started Guide the subsequent chapters take you through hands-on examples that show you how to use Microwave Office software to create circuit designs including layout and AXIEM 3D planar EM layout and simulation.

In the Visual System Simulator Getting Started Guide the subsequent chapters take you through hands-on examples that show you how to use VSS software to create system simulations and to incorporate Microwave Office circuit designs.

In the Analog Office Getting Started Guide the subsequent chapters take you through hands-on examples that show you how to use Analog Office to create circuit designs and display various measurements in graphical form.

In the MMIC Getting Started Guide the subsequent chapters take you through hands-on examples that show you Monolithic Microwave Integrated Circuit (MMIC) features and designs.

In the Analyst Getting Started Guide the subsequent chapters take you through hands-on examples that show use of the Analyst 3D Electromagnetic simulator for 3D EM simulation within Microwave Office software. Use of 3D parametric layout cells and a 3D Layout Editor is included.

Conventions Used in This Guide

This guide uses the following typographical conventions:

Item Convention
Anything that you select (or click) in the program, like menu items, button names, and dialog box option names

Shown in a bold alternate type. Nested menu selections are shown with a ">" to indicate that you select the first menu item and then select the second menu item:

Choose File > New Project

Any text that you enter using the keyboard

Shown in a bold type within quotation marks:

Enter "my_project" in Project Name.

File names and directory paths.

Shown in italics:

C:\Program Files\AWR\AWRDE\14 or C:\Program Files (x86)\AWR\AWRDE\14 is the default installation directory.

Keys or key combinations that you press

Shown in a bold alternate type with initial capitals. Key combinations are shown with a "+" to indicate that you press and hold the first key while pressing the second key:

Press Alt + F1.

Getting Additional Information

There are multiple resources available for additional information and technical support for NI AWR products.

NI AWR Knowledge Base

www.awrcorp.com/support/help.aspx?id=9

  • Application Notes - Technical papers on various topics written by NI AWR or our partners.

  • Examples - Pages explaining examples available both in the installed software and those only available for download.

  • Licensing - Step by step guide to resolving most licensing problems.

  • Questions - Questions and answers for common customer issues.

  • Scripts - Scripted utilities to help solve specific problems.

  • Documentation - Complete copy of the latest released documentation.

  • Videos - Short technical videos on how to accomplish specific tasks.

Documentation

Documentation for the NI AWR Design Environment suite includes:

  • What's New in NI AWR Design Environment 14? presents the new or enhanced features, elements, system blocks, and measurements for this release. This document is available in the Help by clicking the Windows Start button and choosing All Programs > AWRDE 14 > AWR Design Environment Help and then expanding the NI AWR Design Environment node on the Contents tab , or by choosing Help > What's New while in the program.

  • The Installation Guide describes how to install the NI AWR Design Environment suite and configure it for locked or floating licensing options. It also provides licensing configuration troubleshooting tips. This document is available on your Program Disk as install.pdf, or downloadable from the Knowledge Base at NI AWR Knowledge Base.

  • The User Guide provides an overview of the NI AWR Design Environment suite including chapters on the user interface; using schematics/system diagrams; data files; netlists; graphs, measurements, and output files; and variables and equations in projects. In addition, an appendix providing guidelines for starting a new design is included.

  • The Simulation and Analysis Guide discusses simulation basics such as swept parameter analysis, tuning/optimizing/yield, and simulation filters; and provides simulation details for DC, linear, AC, harmonic balance, transient, and EM simulation/extraction theory and methods.

  • The Dialog Box Reference provides a comprehensive reference of all program dialog boxes with dialog box graphics, overviews, option details, and information on how to navigate to each dialog box.

  • The API Scripting Guide explains the basic concepts of NI AWR Design Environment scripting and provides coding examples. It also provides information on the most useful objects, properties, and methods for creating scripts in the NI AWR Script Development Environment (NI AWR SDE). In addition, this guide contains the NI AWR Design Environment Component API list.

  • The Quick Reference document lists keyboard shortcuts, mouse operations, and tips and tricks to optimize your use of the NI AWR Design Environment suite. This document is available within the program by choosing Help > Quick Reference or on your Program Disk as Quick_Reference.pdf. This is an excellent document to print and keep handy at your desk.

  • Context sensitive Help is available for most operations or phases of design creation. To view an associated Help topic, press the F1 key during design creation.

Documentation for Microwave Office and Analog Office software includes:

  • The Microwave Office Layout Guide contains information on creating and viewing layouts for schematics and EM structures, including use of the Layout Manager, Layout Process File, artwork cell creation/editing/properties, Design Rule Checking, and other topics.

  • The Microwave Office Element Catalog provides complete reference information on all of the electrical elements that you use to build schematics.

  • The Microwave Office Measurement Catalog provides complete reference information on the "measurements" (for example, computed data such as gain, noise, power, or voltage) that you can choose as output for your simulations.

Documentation for VSS software includes:

  • The VSS System Block Catalog provides complete reference information on all of the system blocks that you use to build systems.

  • The VSS Measurement Catalog provides complete reference information on the measurements you can choose as output for your simulations.

  • The VSS Modeling Guide contains information on simulation basics, RF modeling capabilities, and noise modeling.

Documentation for the 3D Editor and Analyst-MP product(stand-alone product for multi-physics types of EM problems) includes:

  • The What's New in Analyst-MP 14 (Analyst_Whats_New.pdf) presents the new or enhanced features for both the 3D Layout Editor and Analyst-MP software.

  • The Analyst Installation Guide (Analyst_Install.pdf) describes how to install Analyst software and configure it for locked or floating licensing options. It also provides licensing configuration troubleshooting tips.

  • The Analyst-MP Getting Started Guide (Analyst_Getting_Started.pdf) provides step-by-step examples that show you how to use Analyst-MP software.

  • The Analyst User Guide (Analyst_User_Guide.pdf) provides an overview of the 3D Editor and Analyst-MP software; including chapters on the user interface, structures, simulations, post processing, variables, data files, and scripting.

Online Help

All NI AWR Design Environment documentation is available as on-line Help.

To access online Help, choose Help from the menu bar or press F1 anywhere in the program. Context sensitive help is available for elements and system blocks in the Element Browser and within schematics or system diagrams. Context sensitive Help is available for measurements from the Add/Modify Measurement dialog box.

Website Support

Support is also available from the NI AWR website at www.ni.com/awr. You can go directly to this site from the NI AWR Design Environment suite Help menu. The Support page provides links to the following:

  • the current software version

  • the Knowledge Base, which contains Frequently Asked Questions (FAQs) from users, Application Notes, Tutorials, and project examples

  • All Microwave Office, VSS, and Analog Office documentation

Technical Support

Technical Support is available Monday - Friday, 7 a.m. - 5 p.m., PST.

Phone: 888.349.7610 / Fax: 310.726.3005 / E-mail: .

Please send email to awr.support@ni.com if you would like to provide feedback on this article. Please make sure to include the article link in the email.

Legal and Trademark Notice