Go to www.awrcorp.com
Back to search page Click to download print version MWO,VSS,AO,MMIC,Analyst

Chapter 3. Microwave Office: Importing Data Files

This chapter includes an example that demonstrates how to import a Touchstone format data file and use it in simulations.

The basic procedures in this example include:

NOTE: The Quick Reference document lists keyboard shortcuts, mouse operations, and tips and tricks to optimize your use of the NI AWR Design Environment suite. Choose Help > Quick Reference to access this document.

Importing an S-parameter Data File

In this example you import a Touchstone data file. You can also import other file formats using this procedure.

Creating a New Project

The example you create in this chapter is available in its complete form as datafile.emp. To access this file from a list of Getting Started example projects, choose File > Open Example to display the Open Example Project dialog box, then Ctrl-click the Keywords column header and type "getting_started" in the text box at the bottom of the dialog box. You can use this example file as a reference.

To create a project:

  1. Choose File > New Project.

  2. Choose File > Save Project As. The Save As dialog box displays.

  3. Navigate to the directory in which you want to save the project, type "datafile" as the project name, and then click Save.

Importing Data Files

To import a data file:

  1. Right-click Data Files in the Project Browser and choose Import Data File.

  2. In the dialog box that displays, browse to the C:\Program Files\AWR\AWRDE\14\Examples\ or C:\Program Files (x86)\AWR\AWRDE\14\Examples\ directory. Select Touchstone Data Files as the file type, select the N73068a.s2p file, and then click Open. The data file is added under the Data Files node in the Project Browser as shown in the following figure.

Plotting a Data File Directly

  1. Choose Project > Add Graph or click the Add New Graph button on the toolbar. The New Graph dialog box displays.

  2. Type "S21 Data File" as the graph name, select Rectangular as the graph type, and click Create.

  3. Right-click the "S21 Data File" graph in the Project Browser, and choose Add Measurement. The Add Measurement dialog box displays. You can also click the Add New Measurement button on the toolbar. Add the measurement as shown in the following figure.

  4. Choose Simulate > Analyze. The simulation response as shown in the following figure displays.

  5. Right-click the "S21 Data File" graph in the Project Browser, and choose Duplicate as > Smith. A new Smith Chart named "S21 Data File 1" displays in the Project Browser.

  6. Right-click "S21 Data File 1" in the Project Browser and choose Rename. In the Rename Graph dialog box enter "S11 Smith" as the new graph name and then click OK.

  7. Double-click the measurement under the "S11 Smith" chart in the Project Browser to display the Modify Measurement dialog box. Change To Port Index to "1" and click OK.

  8. Choose Simulate > Analyze. The simulation response as shown in the following figure displays.

  9. Choose Window > Tile Vertical to tile the workspace windows.

Adding a Data File to the Schematic

Creating a Schematic

To create a schematic:

  1. Choose Project > Add Schematic > New Schematic. The New Schematic dialog box displays.

  2. Type "Amp" as the schematic name and then click Create.

Placing a Data File in a Schematic

To place a data file in a schematic:

  1. Choose Draw > Add Subcircuit. The Add Subcircuit Element dialog box displays. Select the data file listed, select Explicit ground node, and then click OK.

    Note that if you don't select Explicit ground node the data file shows two pins. You can expose the ground node by right-clicking the subcircuit in the schematic and choosing Properties > Ground.

  2. Click inside the schematic window to place the data file as a subcircuit. Note the port names "G" and "D" instead of "1" and "2". The names are defined in the data file header. Double-click the "N76038a" data file in the Project Browser to view or edit it.

  3. Choose Draw > Add Port or click the Port button on the toolbar.

  4. Add a port on the G pin side of the SUBCKT, as shown in the following figure. A dashed wire line displays from the port pin to the G pin when the port aligns to the pin.

  5. Shift-click to place the port. The port is automatically wired to the G pin as shown.

  6. Add another port on the other side of the SUBCKT block as shown in the following figure. This time simply click to place the PORT element.

  7. Place the cursor over the pin of the PORT element. The cursor displays as a wire coil symbol as shown in the following figure.

  8. Click, then drag the wire to pin D of the SUBCKT and click to place it. Complete the wiring of the circuit as shown in the following figure.

  9. Choose Draw > Add Ground or click the Ground button on the toolbar. Add a ground as shown in the following figure.

Specifying the Simulation Frequency

To specify the simulation frequency:

  1. Choose Options > Project Options or double-click the Project Options node in the Project Browser.

  2. Click the Frequencies tab.

  3. Type "2" in Start, "10" in Stop, and "0.1" in Step, and then click Apply. The frequency range and steps you specified display in Current Range.

  4. Click OK.

Simulating a Schematic with a Data File

  1. Right-click the "S21 Data File" graph in the Project Browser and choose Add Measurement, or click the Add New Measurement button on the toolbar. The Add Measurement dialog box displays. Add the measurement as shown in the following figure.

  2. Choose Simulate > Analyze. The simulation response as shown in the following figure displays. Notice that the simulation result from the schematic looks coarse and doesn't match that of the direct data file measurement.

  3. Choose Options > Project Options.

  4. Click the Interpolation/Passivity tab and select Polar as the Coordinate System, then click OK.

  5. Choose Simulate > Analyze. The simulation response shown in the following figure displays. Notice the change in trace from the schematic simulation.

Renormalizing the Data File to a Different Impedance

To renormalize the data to different impedance:

  1. In the AMP schematic, double-click the PORT1 Z parameter value to activate edit mode, as shown in the following figure.

  2. Type "25" as the Z parameter value for PORT1 and PORT2.

  3. Choose Simulate > Analyze and view the results in the graph.

  4. Save and close the project.

Please send email to awr.support@ni.com if you would like to provide feedback on this article. Please make sure to include the article link in the email.

Legal and Trademark Notice