Go to www.awrcorp.com
Back to search page Click to download print version MWO,VSS,AO,MMIC,Analyst

Chapter 8. ANA: Using the Analyst 3D Electromagnetic Simulator

While the "Microwave Office: Using the Electromagnetic Simulator" chapter covers 3D Planar EM simulations using AXIEM, an important assumption for the AXIEM 3D planar EM simulator is that each dielectric layer extends to infinity. There are many types of circuits where this assumption is false and a full 3D EM simulator is needed, for example with a bond wire going from a PCB substrate to a GaAs chip. The GaAs chip dielectrics do not extend to infinity and the bond wires do not go through the GaAs substrate.

Three-dimensional (3D) electromagnetic (EM) simulation within Microwave Office software uses the AnalystTM simulator. Analyst is a field simulator based on the finite element method that you can use to solve for port parameters and EM fields within arbitrary 3D structures. In addition to truly 3D components such as connectors, waveguides, cavity resonators, and RF packages, many “planar” problems have 3D aspects that can be more accurately/efficiently simulated using a 3D solver, for example:

Creating a Simulation for a Simple EM Structure

This example demonstrates how to set up a simulation for an Analyst 3D EM document. Basic setup concepts already covered in previous chapters are not included, so you should familiarize yourself with these before starting.

This example includes the following main steps:

  • Installing the Analyst 3D EM simulator

  • Converting an AXIEM structure to an Analyst structure

  • Properly configuring ports and the enclosure

  • Viewing the initial mesh

  • Running a simulation

To minimize simulation times while working through this example, download the simulation datasets from www.awrcorp.com/support/help.aspx?id=44.

NOTE: The Quick Reference document lists keyboard shortcuts, mouse operations, and tips and tricks to optimize your use of the NI AWR Design Environment suite. Choose Help > Quick Reference to access this document.

Opening an Existing Project

The example you create in this chapter is available in its complete form as Analyst_Basic_Finish.emp. To access this file from a list of Getting Started example projects, choose File > Open Example to display the Open Example Project dialog box, then Ctrl-click the Keywords column header and type "getting_started" in the text box at the bottom of the dialog box.

To create a project:

  1. Choose File > Open Example to locate and open the Analyst_Basic_Start.emp file.

  2. Choose File > Save Project As. The Save As dialog box displays.

  3. Navigate to the directory in which you want to save the project, type "Analyst_GS_basic" as the project name, and then click Save.

NOTE: Simulation results may vary slightly from the images in this guide. Finite Element Method (FEM) simulations require a convergence based on a mesh refinement sequence. Slight changes in the mesh refinement between versions of the solver can cause results to vary slightly. While the default convergence tolerance is sufficient for most geometries, if you find results shift you can decrease the convergence tolerance to ensure that the results are accurate.

Converting the AXIEM Structure to Analyst

To convert the AXIEM structure to an Analyst structure:

  1. Simulate the project to see the "AXIEM_Line" structure simulate. After simulation, view the data on the "S Parameters" Smith chart.

  2. Select the "AXIEM_Line" document in the Project Browser and choose Edit > Copy and Edit > Paste or press Ctrl + D to duplicate the structure. The new structure displays in a new window. Make sure you close this window.

  3. In the Project Browser, right-click the copied EM document and choose Rename. Type "Analyst_Line" as the new name and then click the Rename button.

  4. In the Project Browser, right-click "Analyst_Line" and choose Set Simulator. In the Select a Simulator dialog box select AWR Analyst 3D EM - Async and then click OK.

Double-click the "Analyst_Line" EM structure. The Analyst structure displays as shown in the following figure.

Like most finite element simulators, Analyst software requires well-defined boundary conditions and a 3D bounding box. Analyst software also requires that you configure the top, bottom, and side enclosure boundary conditions for the structure. A shape in the 2D layout defines the boundary size, then you edit the shape properties to specify the boundary condition for each side of the boundary. Each Analyst structure has a default 2D rectangular boundary shape drawn with the approximate open boundary conditions on each edge; you can edit the existing shape or add a new shape of any size. This example draws a new boundary shape to replace the default boundary shape. The default height of this boundary shape is specified in the enclosure and is defined in the stackup for this structure.

To draw a shape as the boundary:

  1. With the "Analyst_Line" document window active, choose Draw > Rectangle.

  2. With the cursor in the window, press the Tab key to display the Enter Coordinates dialog box, then type the values show in the following figure and click OK.

  3. Press the Tab key again and type the following values, then click OK. Note the Rel setting.

    The layout displays as shown in the following figure.

    The new shape is automatically selected.

  4. Choose Draw > Create 3D EM Simulation Boundary or click the Create Simulation Boundary button on the toolbar to create a new boundary shape in the layout.

  5. The layout displays as shown in the following figure.

    Notice that there are two boundary shapes. Select the original boundary shape (which extends in the x-direction beyond the end of the line) and press the Delete key.

  6. Select the remaining boundary shape, right-click and choose Shape Properties to open the Properties dialog box. Ensure that the boundary conditions match this figure.

The layout displays as shown in the following figure.

You can view the boundary conditions of the structure in the 3D view of the structure to verify that they are correct.

  1. Open the 3D layout of the structure by choosing View > View 3D EM Layout or by clicking the View EM 3D Layout button on the EM 3D Layout toolbar.

  2. Click the Show Boundary Conditions button on the EM 3D Layout toolbar. The layout displays the boundary conditions as shown in the following figure.

  3. Click the Layout tab to open the Layout Manager, then click the arrows on the right of the Visibility By Material/Boundary pane to open it.

    You can turn off the visibility for specific materials. For example, when turning off the Approx Open material, the 3D layout displays without those boundary conditions visible.

  4. Click the Show Boundary Conditions button on the EM 3D Layout toolbar to turn off this display for the next several steps.

Analyst software supports wave ports and lumped ports. Wave ports are generally preferred. You can attach wave and lumped ports to shapes on or inside the simulation boundary.

To configure wave ports for this structure:

  1. With the 2D Layout View window active, double-click a port.

  2. In the Properties dialog box on the Port Attributes tab, make sure that Type is set to Wave and then click OK.

  3. Repeat these steps for the other port.

Running the Simulation

The Analyst structure is ready for simulation from 0.1 to 10 GHz in 1 GHz steps.

Before simulating, you can view the mesh in the 3D view of the structure. The first mesh you see is the initial solver's mesh. As each additional Adaptive Mesh Refinement (AMR) step continues, the view of the mesh updates.

To view the mesh:

  1. Open the 3D layout of the structure by choosing View > View 3D EM Layout or by clicking the View EM 3D Layout button on the EM 3D Layout toolbar.

  2. Click the Show 3D Mesh button on the EM 3D Layout toolbar. The layout displays as shown in the following figure. This is the initial mesh of the structure with Perfect Conductor material turned off.

    Additionally, the display for the Air layer is turned off by default. You can turn it on in the Layout Manager by opening the Visibility By Material/Boundary pane. The mesh is visible in the Air layer as shown in the following figure.

To simulate the structure:

  1. Choose Simulate > Analyze or click the Analyze button on the toolbar. NOTE: Typically this simulation takes a few minutes to run with no other programs competing for resources.

  2. The Simulation dialog box displays the status during simulation.

    Click the down arrow icon on the right of the dialog box to display details about the simulation progress. The following figure shows the output log from this simulation. You can watch each AMR sequence and see how close the simulation is to converging. Simulation times and memory use vary by computer.

  3. As the simulation progresses, the mesh is refined. If the 3D layout is visible after viewing the mesh, you see the mesh update after each AMR sequence. The following figure shows the mesh after the AMR sequence converges with the Air layer visibility turned off.

NOTE: While the simulation is running you can continue this exercise as Analyst software is an asynchronous simulator, like AXIEM.

It is useful to know how to use cut planes when viewing information such as mesh, boundary conditions, and E-fields in the EM structure 3D view.

To use a cut plane:

  1. Open the 3D layout of the structure by choosing View > View 3D EM Layout or by clicking the View EM 3D Layout button on the EM 3D Layout toolbar.

  2. Click the Use Cut Plane button on the toolbar and ensure that the Show Cut Plane button is also pressed. The following figure shows a plane that cuts the structure where the information is drawn on one side and removed from the other side.

  3. Click and drag on the cut plane to move its position. Click and drag on the arrows at the end of the line through the cut plane to change the orientation. Use the x, y, or z keys to move the cut plane in that orientation and make the plane orthogonal to that plane. If this is not obvious, move the cut plane to an odd angle by moving the arrow that extends beyond the plane, and then use these keys to observe the cut plane.

To view simulation results:

  1. In the Project Browser, right-click the "AXIEM_Line:S(2,1)" measurement on the "S Parameters" graph and choose Duplicate to display the Modify Measurement dialog box.

  2. Change the Data Source Name to "Analyst_Line" and then click OK.

  3. Repeat these steps for the "AXIEM_Line:(S(1,1)" measurement.

  4. After the simulation is complete you might need to resimulate the project to update the graph data. Note that the structure does not resimulate because nothing has changed.

Double-click the "S Parameters" graph in the Project Browser. When the graph data is updated, the graph displays similar to the following figure.

Some structures with iterative solvers (like FEM solvers) might have two sets of S-parameters between AMR iterations that can be close enough to one another to satisfy the convergence criteria. In actuality, the mesh may not have refined enough to catch certain behaviors. If this occurs, you can lower the convergence criteria to force the simulator to take more AMR iterations to try to capture this behavior, although this restarts the simulation from AMR iteration 1.

Another possibly more efficient way than lowering the convergence tolerance and simulating the entire structure again, is to force the simulator to run one more AMR iteration to ensure that the simulation did converge. This simulation starts where the last simulation ended and does not need to simulate the prior AMR iterations.

To run one more AMR iteration, right-click the "Analyst_Line" EM structure and choose Refine Solution. A simulation starts on the next AMR iteration.

You can refine the solution multiple times if the results shift. This potentially saves a lot of time re-running full simulations after lowering the convergence tolerance.

For this particular structure the results don't really change so you know the solution has converged.

Please send email to awr.support@ni.com if you would like to provide feedback on this article. Please make sure to include the article link in the email.

Legal and Trademark Notice