Go to www.awrcorp.com
Back to search page Click to download print version MWO,VSS,AO,MMIC,Analyst

Chapter 23. VSS: VSS Examples

This chapter includes additional useful examples such as FSK, Phase Noise and I/Q Imbalance, End-to-End QAM system, and mixer modeling. It also includes steps for displaying measurements such as ACPR, EVM, and others.

FSK Example

In this example you build and simulate a complete transmitter-channel-receiver chain for a Binary Frequency Shift Keying (BFSK) transmission. The example shows how to generate a frequency shift keying (FSK) source using elementary blocks or a "black box" FSK modulator (called FSK_SRC) in Visual System SimulatorTM (VSS). It is not always necessary to construct a receiver and transmitter using elementary blocks. For many common modulation methods, corresponding black boxes already exist in VSS software. This exercise, however, is intended to show that using the black box or creating one using the elementary blocks produces identical results. You will also construct an FSK demodulator using basic blocks, and verify the performance of the system by setting different parameters. For more information and application notes on FSK modulation visit our website at www.ni.com/awr.

The procedures in this example include:

  • Verifying the BFSK waveform generated using different methods

  • Channel and noise scaling and system performance

  • Monitoring the BER and sweep statistics in a text window.

NOTE: The Quick Reference document lists keyboard shortcuts, mouse operations, and tips and tricks to optimize your use of the NI AWR Design Environment suite. Choose Help > Quick Reference to access this document.

Prior to starting the following projects, ensure your system options are correctly set by right-clicking the System Diagrams node in the Project Browser and choosing Options. On the System Simulator Options dialog box Basic tab, under Simulation Bandwidth Options set the Sampling Frequency Span to "8 GHz" and the Oversampling Rate to "8".

Using a "Black Box" FSK Modulator

In this section you create a project and BFSK system diagram, then use the FSK modulator (FSK_SRC) and plot the power spectrum of the modulated signal. The complete example is available as BFSK.emp. To access this file from a list of Getting Started example projects, choose File > Open Example to display the Open Example Project dialog box, then Ctrl-click the Keywords column header and type "getting_started" in the text box at the bottom of the dialog box. You can use this example file as a reference.

To generate an FSK source using a "black box" FSK modulator:

  1. Create a project named "bfsk".

  2. Add a system diagram named "CP_BFSK" to the project.

  3. In the Element Browser under System Blocks, expand the Modulation category, then click the FSK group. Select the FSK_SRC block and place it on the system diagram. Verify that its parameters are set to the following values, then click OK.

  4. Add and connect a Test Point (TP) as shown in the following figure.

  5. Add a rectangular graph named "Spectrum".

  6. Add a System > Spectrum measurement to the graph using the settings in the following figure, then click OK.

  7. Run the System Simulator and then stop it after a few moments. The power spectrum of the FSK signal generated by the block displays as shown in the following graph.

Creating an FSK Modulator Using Elementary Blocks

In this section you create a BFSK modulator using elementary blocks, then compare the results with those of the previous method. These two distinct transmitters are behaviorally identical.

  1. In the Element Browser, expand the Sources category, then click the Random group. Select the RND_D block and place it on the CP_BFSK system diagram as shown in the following figure.

  2. Double-click the RND_D block and set the RATE parameter to "1000" and the RSEED parameter to "{0}" (with the brackets).

  3. Expand the Converters category, then click the Analog-Digital group. Select the DAC block and place it on the system diagram as shown in the following figure. Leave the SMPSYM parameter set to _SMPSYM. SMPSYM is automatically set to 8. Eight samples per symbol is the default setting defined in the System Simulator Options dialog box on the Basic tab. Thus, output of the DAC is a real signal with 8 samples per bit and at a rate of 1KHz.

  4. Expand the Modulation category, then click the Analog group. Select the FM_MOD block and place it on the system diagram as shown in the following figure.

  5. Set the FM_MOD block KF parameter to "353.5" = (0.707/2*1000).

  6. Expand the Sources category, then click the Waveforms group. Select the SINE block and place it on the system as shown in the following figure.

  7. Set the SINE block AMPL parameter to "5". Leave the FRQ parameter at 1GHz.

  8. Add a second Test Point (TP) named "BFSK" to the system as shown in the following figure.

  9. From the System > Spectrum category, add a power spectrum measurement (PWR_SPEC) at test point BPSK to the "Spectrum" graph.

  10. Run the System Simulator. Note that there is no change in the graph since the waveform from the cascade of these blocks is identical to the waveform of the FSK_SRC block, hence the overlap.

    To view the spectrum of each setup separately, you can display them in separate graphs or toggle the measurements one at a time under Graphs in the Project Browser (right-click and choose Toggle Enable). These steps confirm that the two methods for setting up the transmitter create identical BFSK waveforms.

  11. Add a third Test Point (TP) named "Data" between the RND_D block and the DAC block.

    To observe the behavior of the transmitted phase:

  12. Add a rectangular graph named "TX Waveforms".

  13. Add a time domain waveform measurement to the graph using the settings in the following figure, then click Add.

  14. Add a measurement to the graph for the phase produced by the FSK modulator using the settings in the previous step, but select BFSK as the Test Point and Angle as the Complex Modifier, then click OK.

  15. Select the "TX Waveforms" graph and click the Options button on the toolbar or right-click the graph and choose Options.

  16. Click the Axes tab and select Left 1. Clear the Auto limits check box and enter "-1" as the Min and "2" as the Max. Under Divisions, clear the Auto divs. check box and enter "1" as the Step.

  17. Select Right 1. Clear the Auto limits check box and enter "-200" as the Min and "200" as the Max, then click Apply.

  18. Click the Measurements tab and under Select Measurement to edit, select BFSK:Ang(WVFM(TP.BFSK,20,3,1,0,0,0,0,0)], then under Choose axis, select Right 1 and click Apply.

  19. Click the Traces tab and under Style, select measurement 1, then under Weight select a heavier line from the corresponding drop-down box at the bottom of the dialog box. Select measurement 2, then select a square as the Symbol style from the corresponding drop-down box at the bottom of the dialog box.

  20. Run the System Simulator. Observe that the transmitted phase behaves exactly as expected in a binary FSK transmission scheme with rectangular frequency shaping pulse.

    Your simulation response should look similar to the following graph, which shows that the phase of the modulated waveform increases in a ramp when the input bit is "1", and decreases in a ramp with the same slope when the input bit is "0". The phase remains continuous between different bit intervals, and the phase jumps in the plot are only the effect of the wrap-around when the phase exceeds +/- 180-degrees. The data waveform (binary 1's and 0's) is plotted on the left axis while the phase waveform is shown on the right axis.

Receiver and Demodulation

In this section you complete the channel-receiver chain for BFSK. The receiver is built from elementary VSS blocks for demonstration purposes and is shown to outperform even the coherent BFSK demodulator. The modulated signal out of the transmitter is passed through an AWGN channel and then demodulated by a discriminator receiver, consisting of a filter (PLSSHP), an FM discriminator (FM_DSCRM), an integrate-and-dump block (INTG_DMP), and an ADC block. In this exercise you also scale the channel and noise parameters and analyze the system performance.

To complete the channel-receiver chain for BFSK (using the following figure as a reference):

  1. In the Element Browser, click the Channels category. Select the AWGN block and place it on the CP_BFSK system diagram.

  2. Click the Filters category, then select the PLSSHP block and place it on the system diagram.

  3. Expand the Modulation category, then click the Analog group. Select the FM_DSCRM block and place it on the system diagram.

  4. Click the Signal Processing category, then select the INTG_DMP block and place it on the system diagram.

  5. Expand the Converters category, then click the Analog-Digital group. Select the ADC block and place it on the system diagram.

  6. Add a 4th, 5th and 6th test point at the outputs of the FM_DSCRM, INTG_DMP and ADC blocks respectively, and label them (in order) "Discrim", "INT_Dump", and "ADC" as shown in the following figure.

  7. Click the Signal Processing category, then select the ALIGN block and place it on the system diagram. Connect node 2 to the ADC test point.

  8. Expand the Meters category, then click the BER group. Select the BER_EXT block and place it on the system diagram.

  9. Add the following equation to the system diagram:

    Eb_No = sweep(stepped(1,13,2))

  10. Set the AWGN block PWR parameter to "-Eb_No" and its PWRTYP parameter to Normalized N0/2(dBW/Hz).

  11. Set the PLSSHP block PLSTYP parameter to Gaussian (BT), NRMTYP parameter to Unit Pulse Gain, and its ALPHA parameter to "0.5".

  12. Set the FM_DSCRM block GAIN parameter to "1/353.5".

  13. Set the INTG_DMP block N parameter to "8". Recall that the DAC is set to 8 samples per symbol.

  14. Set the ADC block M parameter to "2".

  15. On the Parameters tab of the ALIGN block, set GAINCOMP to None, PHSCOMP to Reversal only, and leave DLYCOMP set to Basic. The ALIGN block is used to align the original data with the received data prior to the BER detector.

  16. Verify that the BER_EXT block parameters match those in the following figure.

Adding Graphs and Analyzing Results

To add and analyze an RX waveform graph:

  1. Add a rectangular graph named "RX Waveforms".

  2. Add a measurement to this graph using the settings in the following figure, then click Add.

  3. Repeat step 2 but select TP.INT_DUMP as the Test Point.

  4. Repeat step 2 but select TP.ADC as the Test Point, then click OK.

  5. Run the System Simulator and then stop it after a few moments. A snapshot of the simulator response is shown in the following graph. Your graph should look very similar after making the appropriate trace and axis property changes in the Graph Options dialog box. Set the waveform at testpoint TP.INT_DUMP to display on the right axis.

  6. Analyze the graph. The bold waveform is the output of the FM discriminator in low noise. The sample output of the integrate-and-dump block at every 1 msec or 1e6 nsec (sample at the symbol rate of 1000 samples/sec) is displayed with a triangular mark. As expected, this curve is positive when the FM discriminator output is increasing, and negative otherwise. Also observe the output of the ADC block, which slices the output of the integrate-and-dump block for digital output data. The scale for integrate-and-dump output is on the right y-axis, and that of the FM discriminator and ADC is on the left y-axis.

  7. Add another rectangular graph named "BER".

  8. Add a measurement to this graph using the settings in the following figure, then click Add.

  9. Add another measurement to this graph to represent the performance of a non-coherent receiver, using the settings in the following figure, then click Add.

  10. Repeat step 9 but select Coherent as Demodulation Type. This represents the performance of a coherent linear (correlation) receiver.

  11. Repeat step 9 but select Discriminator as Demodulation Type, then click OK. This represents the performance of the nonlinear discrimination receiver, under an ideal assumption.

  12. Set the BER_EXT block TXTOUT parameter to Trial statistics.

  13. Run the System Simulator. A text window displays with the statistics of BER simulation.

  14. Select the BER graph window, then right-click and choose Options or click the Options button on the toolbar. Click the Traces and Axes tabs and make the appropriate changes to your graph so it looks similar to the following graph. Make sure you select Log scale for the left axis, and set Min to "1e-7" and Max to "1".

  15. Run the System Simulator again.

  16. Save and close the project.

I/Q Imbalance Example

In this section you observe the effect of amplitude and/or phase mismatch (I/Q imbalance) of a complex signal. For more information, search for "IQ Imbalance" in the NI AWR Knowledge Base at www.awrcorp.com/support/help.aspx?id=9.

The procedure in this example analyzes the effect of I/Q imbalance in a QAM signal. The complete example is available as 16QAM_IQ_Imbalance.emp. To access this file from a list of Getting Started example projects, choose File > Open Example to display the Open Example Project dialog box, then Ctrl-click the Keywords column header and type "getting_started" in the text box at the bottom of the dialog box. You can use this example file as a reference.

I/Q Imbalance and Phase Imbalance vs. Error Vector

Any digital transmitter-receiver communication system which comprises analog and digital sections is plagued by "in-phase to quadrature-phase" (I-Q) imbalance, causing the signal to distort. I-Q imbalance occurs when the quadrature-phase signal components of the modulated signal are not perfectly in quadrature (separated in-phase by 90-degrees), or are otherwise processed unequally, such as the application of differing gain to in-phase and quadrature signals when equal gain is desired. I-Q imbalances typically occur at least in the analog sections of the communication system, particularly in connection with upconversion and downconversion. In this section you study the I-Q imbalance in a QAM signal by the effect of either a dirty input signal or a dirty local oscillator (LO). You also measure the image rejection ratio (IRR).

To view the I-Q imbalance in a QAM signal:

  1. Create a new project named "16QAM_IQ_Imbalance" and add a system diagram named "QAM System".

  2. In the Element Browser under System Blocks, expand the RF Blocks category. Click the Impairments subgroup, then select the IMBAL_IQ block and place/connect it on the "QAM System" system diagram as follows. Set the DCOFFSET parameter to "20e-3", the AMPIMBAL parameter to "0.6", and the PHIMBAL parameter to "6".

  3. Expand the Modulation category, then click the QAM group. Select the QAM_SRC block and place it on the system diagram as shown in the following system diagram figure. Set the MOD parameter to 16-QAM (Gray), the OUTLVL parameter to "-10", the OLVLTYP parameter to Avg. Power (dBm), and the PLSTYP parameter to Raised Cosine. Set the RATE parameter to "1e9" and the secondary parameter SMPSYM to "10". To see secondary parameters, click Show Secondary in the lower right hand corner of the Parameters tab. The sampling frequency of the system is now set to 10 GHz. Note that sampling frequency = data rate * samples per symbols.

  4. Expand the RF Blocks category, then click the Mixers group. Add a MIXER_B block and set the parameters as shown in the following figure. Click the secondary parameters button to show the secondary parameters, then scroll to the bottom of the dialog box and set LOHMAX and INHMAX to "5", and IMPROD to "{1,1}", leaving other unpictured parameters at their defaults. Note that when the secondary parameter IMPROD is set to "{1,1}" the mixer in this configuration only generates the m=n=1 product; higher order products are not generated. See the online Help for further details on the MIXER_B block.

  5. Expand the RF Blocks category, then click the Sources group. Select the TONE block and place it on the system diagram as shown in the following figure.

  6. Set the TONE block FRQ parameter to "5.2 GHz" and the NOISE parameter to "RF Budget Only".

  7. Expand the Modulation category, then click the QAM group. Select two QAM_RX blocks and place them on the system diagram as shown in the following figure.

  8. Add three test points, as shown, to complete the system diagram.

Adding Graphs and Analyzing Results

In this section you view the signal constellation with and without adding noise to the system.

To add and analyze a constellation graph:

  1. Add a constellation graph named "IQ".

  2. Add two System/IQ measurements to the graph to display the constellations at test points TP1 and TP2. Set the Block Diagram to QAM System and the Time Span to "200" and leave Units set to Symbols for each measurement in the Add Measurement dialog box as shown in the following figure.

  3. Add a rectangular graph named "Power Spectrum".

  4. Add a PWR_SPEC measurement to the "Power Spectrum" graph using the settings in the following figure, then click OK.

  5. Run the System Simulator. The simulation responses shown in the following graphs should display.

    NOTE: The constellation at the output is slightly skewed. You may alter the AMPIMBAL and PHIMBAL parameters and analyze the effect on the constellation even further. The system thus simulated has a "dirty" input signal (causing imbalance) and a clean LO. You may also build the system with a clean input signal and a dirty LO (causing imbalance). To do so you need to remove the IMBAL_IQ block from the MIXER_B block "IN" terminal and add it between the TONE block and the "LO" terminal of the MIXER_B block. This also causes the output constellation to skew in a similar pattern.

    Next, you perform a phase imbalance vs. error vector magnitude (EVM) measurement using the vector signal analyzer (VSA).

  6. Expand the Meters category, then click the Network Analyzer group. Select the VSA block and place it on the system diagram. Connect the source signal input of the VSA to the complex output of the QAM_RX that is directly connected to the QAM_SRC. Connect the VSA's measured signal input to the complex output of the other QAM_RX.

  7. Add an equation "PHASE=0" to the system diagram and set the PHIMBAL parameter of the IMBAL_IQ block to "rad(PHASE)", and the DCOFFET and AMPIMBAL parameters to zero as shown in the following system diagram.

  8. Set the VSA parameters as shown in the following figure. In this case, the PHASE variable is swept after 8000 samples pass through the VSA. The PHASE variable is set to start at 0 degrees and sweep to 12 degrees in increments of 2 degrees.

  9. Your system diagram should look like the following figure.

  10. Add a rectangular graph named "EVM".

  11. Add an EVM_PS measurement from the System > NW Analyzer category to the "EVM" graph using the settings in the following figure. The EVM_PS measurement allows you to plot phase on the x-axis, and EVM results on the y-axis. This measurement is set to take in 200 symbols at a time and make an EMV measurement on each symbol. After 5 blocks of 200 symbols, the %RMS average in dBs displays. Set VSA.M1 to Use for x-axis to ensure that the values for PHASE are plotted along the x-axis.

  12. Run the System Simulator. The simulation response shown in the following graph should display.

  13. Save the project as "16QAM_IQ_Imbalance".

Nth order IP Measurement

This example illustrates how to use an nth order Intercept Point measurement (IPn). The complete example is available as IPn.emp. To access this file from a list of Getting Started example projects, choose File > Open Example to display the Open Example Project dialog box, then Ctrl-click the Keywords column header and type "getting_started" in the text box at the bottom of the dialog box. You can use this example file as a reference.

  1. Create a new project and add a new system diagram named "IPn".

  2. Expand the RF Blocks category, then click the Sources group. Select the TONE block and place it on the system diagram. Set the TONE source FRQ parameter to "{1,1.1}" and its PWR parameter to "-10", then click OK. The tone source will generate tone at 1GHz and 1.1GHz each with a power level of -10dBm. Note that the sampling frequency parameter (SMPFRQ) of the TONE source is blank. The sampling frequency defaults to _SMPFRQ = 8GHz on the System Simulator Options dialog box Basic tab.

  3. Double-click on the output port (triangle) of the TONE source and set its port to Complex or Complex Envelope. The output port displays in red.

  4. Connect a test point to the output of the TONE source and name it "INPUT".

  5. Expand the RF Blocks category, then click the Amplifiers group. Select and place an AMP_B block on the system diagram. Double-click AMP_B and click Show Secondary in the Element Options dialog box that displays. Set the IP3 parameter to "20" dBm. Leave all other parameters at their default values and click OK.

  6. Connect the TONE source to AMP_B.

  7. Set the NOISE parameter in all of the blocks to RF Budget only.

  8. Add a test point named OUTPUT, and connect it the AMP_B output.

  9. Expand the Meters category, then click the Network Analyzer group. Select and place a vector signal analyzer VSA on the system diagram. Connect the VSA SRC input to the output of the TONE source and its MEAS input to the AMP_B output. Your system diagram should look similar to the following figure. Leave all VSA parameters at their default values.

  10. Add a rectangular graph named "Input", then from the System > Spectrum category of measurements, add a power spectrum measurement (PWR_SPEC) to the graph at test point INPUT. Set RBW/#Bins to "0.01 GHz" and set Y-Axis Output to Power Spectrum (Pwr/Bin). Make sure to select the dBm check box, and leave all other parameters at their default settings.

  11. Run the System Simulator. The simulation response in the following graph should display.

  12. Add another rectangular graph named "Output". Add a power spectrum measurement to the graph at the test point OUTPUT. Set RBW/#Bins to "0.01 GHz". Make sure to check the dBm check box, and leave all other parameters at their default settings.

  13. Run the System Simulator. The simulation response in the following graph should display.

  14. Add a tabular graph named "IP3". Add an IPn measurement to the graph from the System > NW Analyzer category. Click Show Secondary, and set the parameters of the IPn measurement as shown in the following figure. Make sure to select the dBm check box, specify the Input fc (x-axis) as "1 GHz" and the Input BW as "1 RBW (bin)". Leave all other parameters at their default settings and click OK.

  15. Run the System Simulator. The resulting measurement is displayed on the "IP3" table. The first column is the power of the 1GHz input tone (-10dBm) and the second column is the Output IP3 of the amplifier (20dBm). The IPn measurement can autodetect the frequency of the intermodulation product specified (in this case 1.2GHz) and make the corresponding calculation. Of course, you can also specify the frequency of interest. The VSA can straddle an RF link and be used to measure an nth order intermodulation product at any given point in the RF link. For more information on the IPn measurement see the Microwave Office Measurement Catalog online Help.

  16. Save the file as "IPn_measurement.emp".

EVM vs Swept Power

This example illustrates how to set up a swept power vs. EVM simulation. The complete example is available as EVM_PS.emp. To access this file from a list of Getting Started example projects, choose File > Open Example to display the Open Example Project dialog box, then Ctrl-click the Keywords column header and type "getting_started" in the text box at the bottom of the dialog box. You can use this example file as a reference.

  1. Create a new project and a new system diagram named "EVM".

  2. Place a QAM_SRC on the system diagram and modify its parameters as follows: Set the MOD parameter to 16-QAM (Gray), OUTLVL to the variable "PWR", leave OLVLTYP at Avg. Power (dBm), set CTRFRQ to "5.2" GHz, and set PLSTYP to Rectangular. Leave all other parameters at their default settings and click OK.

  3. Note that the RATE parameter defaults to 1e9 (_DRATE) and the secondary parameter samples per symbol (_SMPSYM) defaults to 8. Thus, the bandwidth of the signal is approximately 1GHz and the sampling frequency of the system is 8GHz.

  4. Choose Draw > Add Equation or click the Equation button on the toolbar to add the following equation to the system diagram:

    PWR= -10

  5. Expand the Filters category, then click the Bandpass group. Select and place a Bandpass Butterworth Filter (BPFB) on the system diagram just after the QAM_SRC.

  6. Double-click the BPFB block to display the Element Options dialog box, and click the Filter Design tab to open the Filter Wizard.

  7. Set the filter parameters as shown in the following figure.

  8. Click in the window where "Click to View Response" is displayed. After the response is plotted, click OK.

  9. Expand the Signal Processing category and place a DLYCMP block just after the filter. DLYCMP adjusts a signal with signal delay present so the signal delay falls on a sample boundary. It interpolates to compensate for fractional sample signal delays. DLYCMP is particularly useful when working with circuit filter blocks such as BPFB, which typically introduce signal delays that do not fall on a sample boundary. The DLYCMP ensures that VSS software properly compensates for the filter's group delay prior to making the EVM measurement.

  10. Place an amplifier block (AMP_B) just after DLYCMP and leave its parameters at their default values. Connect the blocks and place a test point named AMPOUT at the output of the amplifier.

  11. Expand the Meters category, then click the Network Analyzers group. Select and place a vector signal analyzer VSA block on the system diagram. Connect its SRC input to the output of the QAM_SRC and its MEAS input to the output of AMP_B.

  12. Set the NOISE parameter in all the blocks to RF Budget only.

  13. Set the VSA VARNAME parameter to "PWR" (including the quotes) and its VALUES parameter to "stepped (-10,10,2)". Next, set its secondary parameter SWPCNT to "5000". The VSA is used to sweep the signal's average power from -10dBm to 10dBm in increments of 2dB, and make an EVM measurement for each power level. The VSA sweeps the power after 5000 samples pass through the amplifier. Your system diagram should look like the following figure.

  14. Add a rectangular graph named "EVM" to the project.

  15. Add an EVM_PS measurement to the graph from the System > NW Analyzer category and set its parameters as shown in the following figure. Click OK.

    The EVM_PS measurement displays the amplifier's output power on the x-axis, and the EVM measurement (%RMS average in dBs) on the y-axis. The VSA takes in 100 symbols at a time and makes an EVM on each symbol. The end result is an EVM measurement based on the average of 5 blocks of 100 symbols each. The Delay Comp. setting of the EVM_PS measurement automatically delays the reference signal relative to the measured signal prior to making the EVM measurement. The Mag/Phase setting automatically scales the measured signal's magnitude relative to the reference signal's magnitude, as well as compensates for the phase distortion due to the filter prior to making the EVM measurement. AMP_B does not characterize the AM/PM effects of an amplifier. See the online Help for more information on EVM_PS.

  16. Add a constellation graph named "IQ" to the project. Add a System IQ measurement to this graph and set the Time Span to "100" symbols. Run the System Simulator. After the simulation stops your graphs should look similar to those shown in the following figure. Note, as the simulation is running you will see the IQ plot begin to distort as the amplifier goes into compression. As the amplifier goes into compression, the EVM degrades.

  17. Save the project with the name "EVM_PS".

Swept Variables

This example illustrates how to use a swept variable block. The complete example is available as SWPVAR.emp. To access this file from a list of Getting Started example projects, choose File > Open Example to display the Open Example Project dialog box, then Ctrl-click the Keywords column header and type "getting_started" in the text box at the bottom of the dialog box. You can use this example file as a reference.

  1. Create a new project and a new system diagram. Name the system diagram "Swept Variable". Leave all system options at their default settings. The sampling frequency of the system is automatically set to 8GHz.

  2. Expand the RF Blocks category, then click the Sources group. Select and place a TONE source on the system diagram. Set its FRQ parameter to the variable "F" (note that after you click OK it defaults to Hz), the PWR parameter to "-10dBm", and the NOISE parameter to RF Budget only. Click OK.

  3. Double-click on the output port (triangle) of the TONE source and set its port to Complex or Complex Envelope. The output port displays in orange.

  4. Choose Draw > Add Equation or click the Equation button on the toolbar and add the following equation (without quotation marks) to the system diagram: "F=.1e9"

  5. Expand the RF Blocks category, then click the Amplifier group. Select and place an AMP_B block after the TONE source. Set the NOISE parameter to RF Budget only and leave all other parameters at their default settings.

  6. Place a test point named "AMP" at the output of the amplifier.

  7. Click the Simulation Control node and then select and place a Swept Variable Control block (SWPVAR) on the system diagram.

  8. Set the SWPVAR block parameters as shown in the following figure. The SWPVAR is now set to sweep the TONE's frequency (F) from 0.1GHz to 0.5GHz in steps of 0.1GHz.

  9. Your system diagram should look like the following figure.

  10. Add a rectangular graph named "Spectrum" to the project. From the System > Spectrum category of measurements, add a power spectrum measurement (PWR_SPEC) at the AMP test point.

  11. Select dBm as the Complex Modifier, set RBW/#Bins to "0.1GHz", and set Y-Axis Output to Power Spectrum (Pwr/Bin). Leave all other spectrum measurement parameters at their default settings.

  12. Run the System Simulator. Note in the spectrum graph plot that the fundamental frequency is sweeping from 0.1GHz to 0.5GHz. You can also see the corresponding harmonics. After the simulation stops your graph should look similar to the graph in the following figure.

  13. Save the project as "SWPVAR". You may also want to review the parameters available to you in the Spectrum measurement. In particular, you may want to explore the use of the settings of the SWPVAR.SWP1 parameter.

  14. Depending on the RBW/#Bins and VBW/#Avg. settings, the frequencies of interest, and the complexity of the system, you may have to change the SWPCNT parameter of the SWPVAR block. In addition, you may have to change the sampling frequency of the system to view all frequencies of interest. See the online Help for the SWPVAR block and the power spectrum (PWR_SPEC) measurement, and the VSS Modeling Guide for more information.

Please send email to awr.support@ni.com if you would like to provide feedback on this article. Please make sure to include the article link in the email.

Legal and Trademark Notice