Go to www.awrcorp.com
Back to search page Click to download printable version of this guide.

Version 13.03 Updates

The NI AWR Design EnvironmentTM (NI AWRDE) version 13.03 includes the following new features, enhancements, and user interface changes.

New 3D EM Elements

Updated Example Libraries

  • AWR_Module PDK scripts that hide/show flood and keepout regions are now functional.

  • AWR_RFBoard_2layer PDK updates:

    • Updated both flat and PCELL QFNs to better conform to RF industry standards

    • Fixed library 1, 2, & 3 bondwires H2 and Beta to connect properly with default parameter

    • Corrected DXF export mapping for +/- layers export

    • Updated IC_GaAs library element HiK dielectric value to have more reasonable tand

    • Configured global page so project units are more easily changed and relations are unaffected

    • Added Air_h parameter to Stackups for easier scaling

    • Added substrate Monte Carlo analysis tolerances to Globals which affect MSUBs and STACKUPs

    • Added handy PDK toolbar with SimulateOpenGraphs, GerberFileExport, and ToggleBackground Color buttons

API

  • The Tuner object has a new Visibility property that both checks and sets whether the Tuner window is visible or hidden.

  • Fixed an issue with setting values for enumerated API options which do not take sequential values.

  • Added API access to the Options collection for EM3DStructure objects.

  • Schematics window-in-window embedded graphs now print the graphs with the same resolution whether the print operation is initiated by API methods or from the NI AWRDE.

  • Added support for enabling and disabling state job queues in the Job Scheduler configuration via the API.

Data Sets

  • Fixed a data set lock issue that caused unnecessary EM resimulations.

Graphs

  • Yield Analysis results now display Antenna Plot graphs correctly.

  • Graphs with RF Budget measurements from different system diagrams now have a correct x-axis while the VSS Time Domain simulator is running.

Job Scheduler

  • From the Scheduler node, you can now remotely install/uninstall the NI AWRDE on remote compute node servers running AWR_JobScheduler service version 13.02+. See Compute Node Remote Update for details.

  • Several Job Scheduler crashes are now fixed.

  • An intermittent deadlock no longer occurs during job cancellation.

  • Jobs with Min Processors per Job set to "0" now run on machines with more than 8 logical processors.

  • A new ReservedSystemMemory option in the jobschedulersettings.xml file limits how much memory a job can utilize by reserving an amount of memory from being allocated to a job. The default reserved value is the smaller of 20% of the system memory or 2 GB. An error is issued for the job if it reaches this limit.

  • The Job Scheduler shut-down sequence is now faster.

  • Remote connections between computers are now faster, and recover better from network drops.

  • Increased connection wait timeout, which should help remote computing connection issues on degraded networks.

  • Remote status is now returned to user computers for scheduled jobs that start up while the user computer is disconnected from the Scheduler node. Remote status resumes when the user reconnects to the Scheduler.

  • The Simulation dialog box now displays the status of remote jobs on the remote machine, and matches the information on the Job Monitor that is pointing to the remote machine.

Layout

  • MTRACE and MCTRACE layouts are now consistently correct after being stretched.

  • Shapes drawn on multiple layers now consistently display when zoomed in on a small edge.

  • Polygons drawn on a multi-layer line type with coincident points are now correctly drawn.

  • Subtraction operations between shapes drawn on multi-layer line types now consistently produce correct results.

  • Fixed a routing issue where using coordinate entry to just change layers would sometimes also add an additional segment.

  • A warning message now displays in the Status Window when Lock Hierarchical Updates is enabled (choose Layout > Lock Hierarchical Updates). A Warning dialog box also displays when exporting a layout (choose Layout > Export Layout).

Layout - EM

  • Mirroring a bond-wire cell in EM layout no longer sometimes results in the cell being placed at a large offset instead of the correctly mirrored position.

  • Zero-thickness impedance materials are now transferred correctly as thin metals in the Preview Geometry structure.

  • EM ports no longer move to another shape when viewed in the Preview Geometry window.

  • The outline of a copied pCell with dynamic parameters now consistently displays correctly while it is being dragged before placement.

  • Fixed a regression in which the EM Layers pane became unresponsive if the Drawing Layer pane was not open.

  • EM 3D Layout shapes no longer lose their fill and display in wireframe in certain situations.

Load Pull

  • Added input return loss (IRL) contours/values for various Load Pull measurements.

Measurements - Circuit

  • Markers now remain associated with a measurement when the measurement changes.

Measurements - Systems

  • Using a PWR_SPEC measurement in an output equation no longer causes a crash.

Models - Circuit

  • The EEHEMT model and large signal APLAC simulations now support PDK models that do not use the LShunt parameter.

  • The PORT_PS2 model Fdelt parameter is now tunable.

  • The PORTIQ_ENV model PWR parameter can now be swept.

  • Fixed Singular Y Matrix simulation errors with compiled models.

Models - System

  • The PHARRAY_RXSIG block has a new MEASBHV parameter which controls whether or not measurements that support PHARRAY_RXSIG adjust results for the number of channels.

  • The AMP_B model with its FRQINTRP (frequency interpolation for frequency dependency) parameter set to "Cubic Spline" no longer causes floating point overflow errors.

  • A warning is now issued if the NL_F block DFTYP parameter is not set to "Auto".

  • The LTE library is updated to reflect the latest improvements in VSS modulation/demodulation capabilities.

Scripts

  • The VSS XML Generation script now allows you to add custom descriptions to parts in the library.

Shape Modifiers and Geometry Simplification (SPP) Rules

  • Shapes can no longer be lost when using the Boolean engine in SPP rules.

  • Fixed a small cutline gap created by LAYSPPMOD using the Clipper Boolean engine.

Simulation - Analyst

  • Analyst Boundary Condition annotation now immediately updates when layout is edited.

Simulation - APLAC

  • Fixed XPARAM simulations with data files that are tabulated as a function of GP_2_1 and 2-tone data files that are tabulated as a function of AM, and both AP and AN are defined outside the block.

  • N-tone frequency or power sweep simulation now works with XPARAM files that contain only one gamma value for each frequency or power-level data block.

  • APLAC simulation results are no longer missing when pass-down variables are swept.

  • SDiode tunneling current is no longer set to zero if the sidewall tunneling current is zero.

  • Improved PINDRC model ADS compatibility.

  • Improved UCSD_HBT model ADS compatibility.

Simulation - AXIEM

  • Improved AXIEM modeling of floating ports, which fixes the issue of significant voltage or current on open nodes in DC analysis of AXIEM subcircuits.

Simulation - Extraction

  • HFSS no longer resimulates Extracted EM structures which have current data sets.

Simulation - Systems

  • When an RF Budget Analysis measurement is connected to an M_PROBE, and the M_PROBE is connected to a port of a subcircuit, the port of the subcircuit is now used as the display point in the graph. Previously, the port of the block inside the subcircuit that was connected to the subcircuit port was used as the display point in the graph.

  • In RF Inspector simulations if the LO of a mixer is generated from a pair of image reject mixers, the output of the main mixer is no longer too high.

  • An RFI simulation crash no longer occurs when impedance mismatch is enabled.

  • Fixed a VSS floating point error.

  • Using a CHANGE_FS block with its FSOUT parameter left empty with either certain blocks downstream (for example, FIR_IMP) or no blocks downstream that specified a sampling frequency, no longer results in a "Node properties not propagated" error reported for the downstream block.

  • NL_S_ENV no longer generates an error if there are more ports in the circuit than defined in the NL_S_ENV block, and the maximum port number in the NL_S_ENV block is less than the maximum port number in the circuit.

User Interface

  • Window-in-Window now works with 3D layout of arbitrary 3D EM structures.

  • The Tools > Create New Process command now finishes without extraneous "Missing LPF" messages to dismiss, and now creates a simpler sample design.

Tuning, Yield Analysis and Optimization

  • Circuit envelope simulations no longer generate errors when tuning, optimizing, or running yield analysis.

  • Optimizing goals that include nonlinear stability analysis results from the STAN wizard no longer causes a crash.

  • Tuning an NPORT_F parameter no longer causes an error with APLAC simulators.

Wizards - IFF Import/Export

  • Enhanced the component parameter mapping in the IFF Import Wizard to allow mapping of enumerated parameter values using strings for the MWO values.

  • The IFF Import Wizard now inserts a '0' at the beginning of NCONN names that start with an underscore character in order to make the name compatible with NI AWRDE name restrictions.

Wizards - PCB Import

  • Importing a 3DI file when there are no global definition documents named "Global Definitions" now works.

  • Implemented the possible per file units overrides per the ODB++ standard.

Wizards - RF Budget

  • Cascaded headroom (C_HDRM) measurements now properly display in the RF Budget Wizard.

Wizards - Symbol Generator

  • The Symbol Generator Preview function now works with system diagrams.

Please send email to awr.support@ni.com if you would like to provide feedback on this article. Please make sure to include the article link in the email.

Legal and Trademark Notice