Go to www.awrcorp.com
Back to search page Click to download printable version of this guide.

7.2. Working with Measurements

A measurement is data such as gain, noise, power, or voltage that is computed by a simulation and plotted on a graph (or otherwise output). Every measurement is associated with a particular graph, and it displays as a subnode of that graph in the Project Browser. When you choose Simulate > Analyze to perform simulations, the required simulator is invoked for each particular measurement.

The measurements that simulations can compute are organized into categories (measurement types). For an overview of the categories and detailed descriptions of AWR Microwave Office measurements, see the AWR Microwave Office Measurement Catalog. For an overview of the categories and detailed descriptions of VSS measurements, see the AWR Visual System Simulator Measurement Catalog.

Note that measurements transform N-port data sources into a vector of real or complex data that can be plotted on a graph.

You can list and modify measurements associated with a graph by right-clicking in the graph window or the graph legend and choosing Modify Measurement to display the Modify Measurement dialog box.

7.2.1. Adding a New Measurement

You can add a new measurement from the Project Browser or from another source such as a schematic, system diagram, EM document, or output equation.

7.2.1.1. Adding a Measurement from the Project Browser

To add a new measurement from the Project Browser:

  1. Right-click a graph node in the Project Browser and choose Add Measurement, or choose Project > Add Measurement.

    The Add Measurement dialog box displays. See “Add/Modify Measurement Dialog Box” for more information about this dialog box.

  2. Select the desired Measurement Type and Measurement, specify the desired options, and click OK. For comprehensive information about all available measurements, see the AWR Microwave Office Measurement Catalog or the AWR Visual System Simulator Measurement Catalog.

    The Project Browser displays the new measurement under the target graph. The name of the new measurement conforms to the standard measurement naming conventions.

7.2.1.2. Adding a Measurement through Another Source

To add a measurement to a schematic, system diagram, or EM document, right-click in the document and choose Add Measurement. A submenu displays with a list of previously selected favorite measurements, as shown in the following figure.

You can specify a measurement as a favorite by clicking the Favorite button while the measurement is selected in the Add/Modify Measurement dialog box. Favorites display in the submenu only in a new AWR Design Environment session. After choosing a favorite measurement from the submenu, a Select graph for new measurement dialog box displays to prompt you to select the graph to which you want to add the measurement. You can also click New Graph to add the measurement to a new graph. After selecting the graph, the Add/Modify Measurement dialog box displays to allow you to edit the measurement if needed. For example, you can change the port index or test point. To suppress the graph prompt, Ctrl-right-click to select a measurement from the submenu. To suppress the display of the Add/Modify Measurement dialog box, Shift-click the OK button in the Select graph for new measurement dialog box. When you suppress the graph prompt, the first graph available is used. If no graphs exist, a new rectangular graph is created and used. After you make your selections, the specified graph opens and the measurement is placed on it. You can now simulate to see the new results.

When plotting on a real-valued graph, the AWR Design Environment suite auto-converts complex measurements to real measurements using the DB-magnitude complex modifier. Conversely, when plotting on a graph that supports complex results, any complex modifier is removed. This ability means that you only need one entry, for example, “S(1,1)” that plots as S(1,1) on a Smith chart and as DB(|S(1,1)|) on a rectangular graph.

You can also add measurements from the source in Output Equations. You do not need to specify a list of favorite measurements since the measurement is simply Eqn(var_name).

7.2.1.3. Measurement Naming Conventions

The names of measurements displayed in the Project Browser are composed of two parts. The first part is the name of the data source the measurement uses. The second part is the measurement type being created. The two parts of the name are separated by a colon (:). An example measurement name is:

MySchematic:|Icomp(DCVS.Vcollector,0)|[*,X]

where MySchematic is the data name, and Icomp is the measurement type. Depending on the type of measurement chosen, various properties of the measurement may display as arguments in parentheses. This specific case indicates that the current Icomp is measured in a DCVS element whose ID is Vcollector. The harmonic number of this specific measurement is specified in the second argument and has the value 0. The vertical bar symbols denote that the magnitude of the current Icomp is specified. When swept parameters are used, the sweep arguments display in square brackets at the end of the measurement name. In this case, the measurement has two swept parameters. For the first swept parameter, the "*" indicates that all values of the swept parameter display. For the second swept parameter, the "X" indicates that this parameter displays on the x-axis of the graph. The data source name "All Sources" is reserved for template measurements, as discussed in “Using Project Templates with Template Measurements”.

7.2.1.4. Ordering Measurements

To order a new (copied) measurement amongst existing measurements, drop it on top of the measurement above which you want it to display. To place it at the bottom of the list of measurements, drop it onto the graph node.

To reorder existing measurements, select the measurement you want to move and press Alt + Up Arrow or Alt + Down Arrow to move the measurement accordingly. Alternatively, simply drag the measurement to the position you want. The graph legend also reflects this revised order of measurements.

7.2.2. Measurement Location Selection

You can make linear measurements only at ports, while you can make nonlinear and system (VSS) measurements at any node in the circuit. When adding nonlinear and system measurements for circuit analysis, the Measurement Component you select in the Add/Modify Measurement dialog box includes any ports and sources by default.

NOTE: For nonlinear circuit simulation, you can use the M_PROBE in a schematic and point measurements to the probe as an easy way to probe nodes in a circuit. See “Implementation Details” for more information.

For example, the following nonlinear measurement for a circuit has two ports and two DC sources.

You can click the ellipsis button to display a window that allows you to choose any node in your circuit to perform your measurement.

The window is a view of the schematic specified in Data Source Name.

You can select the component where you want the measurement made; this model name displays in Testpoint in the lower left corner of the window. The following figure shows the LPTUNER2 block (at the output of the transistor) selected.

The model itself is not enough information; in Testpoint, you need to select the proper node number for the model. These items are listed below the selected model using @N syntax, where N is the node number. The following figure shows node 1 selected for this model.

After you select a node, press Enter or click OK at the top left of the window.

You can also use this window to select locations down through the schematic hierarchy. At the upper left you can expand the name of the top level schematic to show any subcircuit instances. Click on an instance name to display it in the window. The following figure shows the subcircuit selected in this example.

The selected node displays as the Measurement Component in the Add/Modify Measurement dialog box.

You can transverse hierarchy directly in the view of the schematic by selecting any subcircuit, right-clicking and choosing Edit Subcircuit, or clicking the down arrow button at the top of the window. You can push back up through hierarchy by right-clicking with nothing selected and choosing Exit Subcircuit, or clicking the down arrow button at the top of the window.

NOTES: Some nonlinear models can also have measurements made across internal branches of the model. These branches display in this window.

When the measurement component of a current measurement is an element without a node number, the measurement result is the current into node 1 of the element.

7.2.3. Modifying, Copying, and Deleting Measurements

You can modify, copy, or delete the measurements associated with any graph, as well as specify that obsolete measurements continue to display (in gray). To view and edit the current project's measurements individually or in collections, you can also use the Measurement Editor.

7.2.3.1. Modifying Measurements

To modify a measurement:

  1. Double-click the desired measurement in the Project Browser, or right-click the measurement in the graph legend and choose Modify Measurement. The Modify Measurement dialog box, which is identical to the Add Measurement dialog box, displays. See “Add/Modify Measurement Dialog Box” for more information about this dialog box.

  2. Make the desired modifications, and click OK.

7.2.3.2. Copying Measurements

To copy a measurement from one graph to another, select the measurement in the Project Browser and drag and drop it on the target graph node. When compatible, the AWR Design Environment suite automatically converts the measurement for the new graph type. See “Ordering Measurements” for information about ordering the measurement amongst others in the graph.

To copy a measurement on the same graph, select the measurement in the Project Browser and drag and drop it on the same graph node. The Add/Modify Measurement dialog box automatically displays.

7.2.3.3. Deleting Measurements

To delete a measurement, do one of the following:

  • Select the measurement in the Project Browser, and choose Edit > Delete, or

  • Right-click the measurement in the Project Browser, and choose Delete , or

  • Select the measurement in the Project Browser, and press the Delete key.

7.2.3.4. Displaying Obsolete Graph Measurements

Measurement results are plotted on a graph (in a dimmed color) even when the simulated graph data is outdated due to user changes in component values or geometries, or because of changes in equations that affect the measurement results. The associated graph legend entry also displays in gray. A graph can contain a mixture of active and obsolete plot and legend entries as appropriate for the individual measurement status.

7.2.4. Using the Measurement Editor

The Measurement Editor displays the active project measurements with their options, allowing you to quickly edit measurements individually or in collections. The Measurement Editor provides various ways to manage the measurements in your project, such as changing their sort order, filtering on specific criteria, editing multiples, and pre-populating the filter selection by choosing to open the Measurement Editor off of a particular source.

To open the Measurement Editor, right-click a source document such as a schematic, EM structure, or system diagram, or a host document such as a graph, optimization goal, or annotation, and choose Edit Measurements. You can also right-click a graph in the Project Browser and choose Edit Measurements or choose Graph > Edit Measurements. See “Measurement Editor Columns” for a list of supported source and host documents.

When you open the Measurement Editor in this manner, it automatically applies a filter for the source or host document. For example, if you open the Measurement Editor from a schematic named "Swept_Power", a filter is applied in the Document column for the "Swept_Power" schematic.

NOTE: The Measurement Editor does not restrict access to specific settings for each measurement the way the Add/Modify Measurement dialog box does. For example, the Vtime (time domain voltage) measurement has real values, but the Measurement Editor allows checking the box under dB or setting Cplx Modifier. Use caution when editing multiple measurements to ensure the modified settings are applicable to the measurements.

7.2.4.1. Navigating the Measurement Editor

The Measurement Editor allows you to edit field entries singly or in multiples, by Ctrl-clicking each item. You can also Shift-click to select consecutive items in a single column, or press Ctrl + A to select the entire column. Multi-selection works within a single column only; it does not span columns. You can maintain the row selection when navigating to a different column, however. After multi-selecting you can press the Shift key and then use the left and right arrow keys to select the same rows in adjacent columns.

To customize the width of a Measurement Editor column you can drag the column's right boundary. To move a column, you can click on the column header and drag it to a different position.

7.2.4.2. Measurement Editor Columns

Host Doc - displays the measurement location (for example, the graph name). This field is read only.

Host Type - displays the Host Doc type. Valid types are Graph, OptGoal (Optimization Goal), YldGoal (Yield Goal), Anno (Annotation), (OutFile) Output File, or OutEqn (Output Equation).  This field is read only.

Enabled - selected indicates that the measurement is enabled.

Document - the source document that the measurement is using for its data. You can select from a list of sources: circuit schematics, EM structures, system diagrams, data files, or output equation documents.

Measurement - type the name of the measurement you desire to make on the source document. If the string you enter is not a valid measurement it retains its original value. This field auto-corrects case.

Simulator - the simulator used in the measurement. There are two-letter shortcuts for each non-default simulator; which is leaving the field blank. In addition to the following shortcuts, you can enter any of the other simulators in the Simulator column that apply for the measurement being made:

  • Blank - default simulators

  • AP - APLAC linear or APLAC HB, depending on the source document.

  • AP_TR - APLAC transient

  • SP - Spectre

Config - the Switch List to use. 

dB - selected indicates that the measurement is plotted in dB.

Complex Modifier - the modifier applied to the simulation data. You can select from the following modifiers: None, Real, Imag, Mag, Ang, Angu, or Conj.

Parameters - a comma separated list of measurement parameter values that are meaningful to a measurement, that are listed in the parentheses of the measurement string. For an S-parameter measurement, for example, the parameters are the ports, and are entered as 1,1 for S(1,1). You can enter this list with or without parentheses. You should have knowledge of what comprises a measurement string before editing the parameters of a measurement. 

Sweep Parameters - a comma separated list of the measurement sweep parameter values that reside in the brackets of the measurement string. Controls how the sweeps (frequency or otherwise) display on the graph. You should have knowledge of what comprises a measurement string before editing the sweep parameters of a measurement. If the Sweep Parameters are completely blank then the first sweep (usually frequency) is used for the X axis and all traces are plotted for the other sweeps. The valid sweep parameter entries are:

  • X - use for X axis

  • "*" - plot all traces

  • Integer - specifies a particular one-based index

  • ~ - disable Sweep

  • T - select with Tuner

Frequency Sweep - the frequency list that the measurement is plotting.  The supported frequency lists, where applicable, are: FDOC, FPRJ, F_OSC, FSAMP, FSPEC, FDOCN, F_DC, and F_SYMB. You may also specify a frequency list from a sweep frequency block by typing the ID of the sweep frequency block (for example, type FSWP1 if the sweep frequency block is SWPFRQ.FSWP1). When this entry is left blank the frequencies used are FDOC.

Tag - The tag for the measurement. You can use tags for grouping and filtering of measurements in the Measurement Editor. 

7.2.4.3. Sorting and Filtering

You can sort the measurements in the Measurement Editor in any column in ascending or descending order by clicking that column header, and clicking again to reverse the sort order. You can also sort on multiple columns by clicking the column header of the first column to set the sort order for that column and then clicking the second column header to set the sort order of that column.

In addition to sorting you can also filter to find a specific measurement or set of measurements. Filtering is enabled for every column. To filter on a column, click in the filter text box below the column name and type the text you want to filter for in that column. For example, to find all S-parameter measurements in your project you can type "S" in the filter text box in the Measurement column.

The filter text box also supports regular expressions, increasing the ability to perform intelligent searches. The form and functionality of these regular expressions is modeled after the regular expression facility in the Perl 5 programming language. The following table shows some syntax examples.

Syntax Comment
. Match any single character
* Match zero or more of the preceding characters
+ Match one or more of the preceding characters
? Match zero or one of the preceding characters
! Filter out subsequent characters
\d Match any digit (0-9)
ch[at] Match cat and hat
W[1-3] Match W1, W2, and W3
^M Match names that start with M
^W\d+ Match names that start with W followed by one or more digits
\$$ Match names that end in $

7.2.4.4. Tagging

You can enter one or more user-defined tags in the Tag column to associate measurements with that phrase. For example, if you are plotting power curves you might enter the bias of the transistor as the tag to remind yourself which measurement is for what bias.

Filtering is accomplished with a sub-string search that displays all measurements that contain a tag that matches the filter text. If tagging is set up properly, filtering and sorting with tags provide a great way to keep the measurements in your design organized. For information on filtering and sorting, see “Sorting and Filtering”.

7.2.5. Disabling a Measurement from Simulation

To prevent a measurement from being computed when you choose Simulate > Analyze, you can disable the measurement.

To disable/enable individual measurements, right-click on the measurement and choose Toggle Enable. When one or more measurements are disabled, you can right-click on the associated graph node and choose Toggle All Measurements to reverse the disabled/enabled status of all measurements.

To disable all measurements in a graph, right-click the associated graph node in the Project Browser and choose Disable All Measurements. You can re-enable all measurements by choosing Enable All Measurements.

To disable all measurements in a project, right-click the Graphs node in the Project Browser and choose Disable All Measurements. You can re-enable all measurements by choosing Enable All Measurements.

7.2.6. Simulating Only Open Graphs

To simulate only the open graphs in your project, right-click the Graphs node in the Project Browser and choose Simulate Open Graphs.

7.2.7. Post-Processing Measurements and Plotting the Results

You can use the Output Equation feature of the AWR Design Environment suite to assign the result of a measurement to a variable. You can then use this variable in other equations just like any other variable, and you can plot the final "post-processed" result just like any other measurement.

For information on defining variables and equations for this purpose, see “Assigning the Result of a Measurement to a Variable”. For information on how to plot the final result, see “Plotting Output Equations”.

7.2.8. Measurements with Swept Variables

When you define sweeping (frequency, power, etc.), the Add/Modify Measurement dialog box controls how the swept analysis data displays.

For information on swept variable analysis, see “Swept Parameter Analysis ”.

7.2.9. Plotting One Measurement vs. Output Power, Voltage, or Current

You can plot a measurement versus output power, voltage, or current, instead of a swept input quantity. To specify a user-defined x-axis for a measurement, place an X_SWP block in the schematic on which you are making the measurement. On the X_SWP block, specify the x-axis quantity type (power, voltage, or current), and the component node on which the x-axis quantity is measured. In the following figure, the input power is swept using the SWPVAR (ID = SWP1) block. The X_SWP (ID = OutputPower) block is set up to measure the fundamental output power at Port 2.

When you make a measurement on a schematic with an X_SWP block, the X_SWP block ID displays as an x-axis drop-down option for swept parameters in the Add/Modify Measurement dialog box. The following figure shows the dialog box corresponding to a PAE measurement on the schematic shown in the previous figure. For the SWPVAR.SWP1 parameter, Use OutputPower for x-axis is selected instead of Use for x-axis, where OutputPower corresponds to the X_SWP block ID. The resulting graph plots PAE versus output power.

You can add multiple X_SWP blocks to a schematic to plot measurements versus various harmonic power, voltage, and current components measured at various nodes. See the “User-defined X-axis Value Sweep: X_SWP ” for more information about this block.

7.2.10. Plotting One Measurement vs. Another Measurement

You can plot one measurement versus another measurement. Typical measurements have an input sweep on the x-axis (for example, frequency or input power). If you want to put a measurement other than power, voltage, or current on the x-axis, you can use the PlotVs measurement in the Data measurement category. See “Plot Measurement 1 vs Measurement 2: PlotVs” for more information about this measurement. If you want power, voltage, or current for the x-axis, use the X_SWP element instead of the PlotVs measurement.

7.2.11. Single Source vs. Template Measurements

Template measurements are AWR Microwave Office measurements you create by choosing All Sources as the Data Source Name in the Add Measurement dialog box. A template measurement creates a measurement for each data source that is added to the project. When a data source is removed from the project, the measurements for the source that were created from measurement templates are also removed. Measurement templates provide a method for specifying a particular measurement that is to be made for each of the data sources in the project, without creating individual measurements for each data source.

A measurement that is associated with a particular data source is a single source measurement. Single source measurements are created by selecting the name of the associated data source as the Data Source Name in the Add Measurement dialog box. Since single source measurements reference a particular data source, if the data source is deleted or renamed, the measurement generates an error.

7.2.12. Using Project Templates with Template Measurements

You can use project templates to save options, LPFs, artwork cells, design notes, global definitions, frequency, graph, and measurement information for a particular project for use in other projects or for comparison purposes. When you create a project template, it saves all frequency and graph information, and all measurements that are specified as having All Sources as the Data Source Name.

You can use project templates with template measurements to allow the AWR Microwave Office program to be used as a default viewer for N-port data sources. For example, if the AWR Microwave Office program is associated with sources that have a *.s2p extension, then if you click a mysource.s2p source in the Windows source manager or Explorer, the AWR Microwave Office program loads the default project template and adds the mysource.s2p source to the project. If the default project template includes template measurements, the measurements of the mysource.s2p source are automatically created, and the desired measurements of mysource.s2p automatically display.

7.2.12.1. Measurement Comparison Using Project Templates

Project templates are useful for comparing measurements of various data files. The following example illustrates this utility.

In this example, S-parameter data files are compared for gain and return loss over a frequency range of 2-18 GHz. The first step is to create a project template that includes the frequencies, graphs, and measurements required for the comparison. To create the template:

  1. Double-click Project Options in the Project Browser. In the Project Options dialog box on the Frequencies tab, specify the following values and click Apply.

  2. Right-click Graphs in the Project Browser and add a rectangular graph named "Gain". Repeat the same step to add a rectangular graph named "Return Loss".

  3. Right-click the "Gain" graph and choose Add New Measurement. Add a measurement with the following values and click OK.

  4. Right-click the "Return Loss" graph and choose Add New Measurement. Add a measurement with the following values and click OK.

  5. To save the measurements, graphs, and frequencies in a project template, choose File > Save Project As. In Save As type, choose Project Template (*.emt). Name the file "Compare data" and click Save.

  6. To compare S-parameter data files, open Windows Explorer to view the data files. Drag and drop the files onto the Project Browser Data Files node.

    The measurements in the template automatically display on the graphs after simulation, as shown in the following figure.

Please send email to awr.support@cadence.com if you would like to provide feedback on this article. Please make sure to include the article link in the email.

Legal and Trademark Notice